IPTC-II/XMP - Template always deletes old value (single photo)?

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

Post Reply
jcancha
Posts: 3
Joined: Sun Jun 03, 2018 6:37 pm

IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha » Sun Jun 03, 2018 7:04 pm

If I use a template to add keywords to a single photo using the IPTC-IIM/XMP dialogue all existing keywords are overwritten. Is there an option to just add keywords from a template to the already existing value of that picture? As far as I can see, that option only works for changing multiple photos, not for single files. Is that a bug or did I miss something? Thank you.

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview » Mon Jun 04, 2018 2:53 pm

what do you have in IPTC dialog>Options
Pierre.

jcancha
Posts: 3
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha » Mon Jun 04, 2018 3:44 pm

Here's a screen of the options settings. For templates on multiple files those settings work perfectly fine, but they do not seem to work on individual photos...I could not change them anyway since the switches are inactive in single mode.
XnViewMP-Options.png
XnViewMP-Options.png (6.76 KiB) Viewed 226 times

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview » Thu Jun 07, 2018 10:05 am

i need to add an option to choose behavior when using template (clear all or merge)
Pierre.

jcancha
Posts: 3
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha » Thu Jun 07, 2018 10:15 am

Ok, thank you.

Post Reply