0.98 "Filter by" setting causing XNView to open with blank fullscreen

Bugs which have been reproduced by a second user or the developer, or features to do

Moderators: helmut, XnTriq, xnview, Dreamer

User avatar
fractl
Posts: 35
Joined: Fri Sep 26, 2014 10:15 am

0.98 "Filter by" setting causing XNView to open with blank fullscreen

Post by fractl »

XnView: MP 0.98.4 64bits (May 31 2021)
OS: Linux 64bit
Libformat version: 7.81

Effect: Confusing behaviour makes it look like the file is missing. XNView opens fullscreen showing only a blank background. When this happened to me with a video (because I had set the filter to images), I thought XnView was broken at first.

To reproduce:
1. Open XNView and set the Filter by setting to be "Video".
2. Go into Settings and check that under General, the setting for Mode when starting with a file is set to "Fullscreen - Browser".
[Note: It is totally not obvious to me what the difference should be between Fullscreen - Browser and Fullscreen - Viewer is.]
3. Close XnView.
4. Open a file manager and do whatever actions are necessary to make an *image* file open in XNView.

Actual behaviour (bug): XNView opens fullscreen showing only a blank background. Arrow keys and buttons at the bottom don't do anything and neither does Enter (even though this is a setting which usually switches to browser mode). :bug:

Expected behaviour: Selected image file is displayed. Pressing Enter should take you back to Browser mode if that setting is enabled. I'm not sure what the distinction is with the "Fullscreen - Viewer" mode, but if you have that setting, it shows the image and then drops you back into an empty folder if your selected filter hides all images.
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.98 "Filter by" setting causing XNView to open with blank fullscreen

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.