Save as new file type and delete original

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

bdragon
Posts: 106
Joined: Mon May 01, 2017 8:06 am

Save as new file type and delete original

Postby bdragon » Sat May 27, 2017 5:55 am

I've set up xnconvert so that it should save in a specific format. (jpg, because i don't really care for compression artifacts in stuff that is not for work)

Then i told it to delete the old pictures once done with the changes (reasoning that this way i would have a "backup" to restore from the recycle bin if i don't like the result).

This works only if the old filename does not match the new filename.

If the old picture was "pic.png" and the new is "pic.jpg" then the old picture is sent in the recycle bin.

But if they are both "pic.jpg" then the new picture overwrites the old. And that's undesirable.

Am i missing some setting, or is this by design? If this is by design: could you add an option that lets me find all original pictures in the recycle bin?

Thank you.

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Save as new file type and delete original

Postby xnview » Tue May 30, 2017 2:10 pm

it's the same bug as this topic??
Pierre.

bdragon
Posts: 106
Joined: Mon May 01, 2017 8:06 am

Re: Save as new file type and delete original

Postby bdragon » Tue May 30, 2017 2:13 pm

wops. Sorry, i forgot i had written about it. Yes, feel free to delete this thread.

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Save as new file type and delete original

Postby xnview » Fri Jun 30, 2017 12:06 pm

O.k., thank you, I can also reproduce the problem. Issue 1284 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Save as new file type and delete original

Postby xnview » Sat Jul 08, 2017 12:11 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.


Return to “Retest”

Who is online

Users browsing this forum: No registered users and 1 guest