0.90: Bugs in the slideshow

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
Thunichgud
Posts: 4
Joined: Thu Sep 24, 2009 10:02 am

0.90: Bugs in the slideshow

Post by Thunichgud » Sat Mar 10, 2018 6:12 pm

Windows 7
XnViewMP 0.90
Program of XnViewMP installed on internal HD, pictures and .sld files stored on external HD (USB connection)

1. I installed XnViewMP the first time (version 0.90) in my admin account and XnViewMP and Windows did know .sld files. When I changed after that to my normal (non admin) user account, XnViewMP and Windows didn't know .sld files.
2. From inside of XnViewMP a slideshow can be startet by clicking on a previously stored .sld file. But when I try to start a slideshow directly from outside of XnViewMP by doubleclicking in the windows explorer onto the .sld file I get only a black screen - no pictures visible.
3. At an internal started slideshow the navigation buttons foreward, backward, pause are missing. Only the ESC button stops the slideshow and returns to the UI of XnViewMP. ENTER has no effect. ENTER should stop the slideshow, too.
4. During a slideshow the large SPACE button should pause the show and continue it at a second press.
5. As in the classic XNView it should be possible to store in the .sld file one or more pathes to the directory of the picture files instead of storing all pictures file by file. This is better, when the content of picture files in a directory often changes. So it isn't neccessary to renew the .sld file every time after a change of the file content.
6. It should be possible to use in .sld files both: an absolute path (e.g. C:\user\public\pictures\) or a relative path ( \pictures\). The second case is better, when the pictures and the belonging .sld files are stored on an external HD, which is used on different computers.
7. During a paused slideshow zooming and panning should be possible.

Thunichgud
Posts: 4
Joined: Thu Sep 24, 2009 10:02 am

Re: 0.90: Bugs in the slideshow

Post by Thunichgud » Sat Apr 14, 2018 1:20 pm

@XnView:
Will these bugs be repaired in next version of XnViewMP ? They are very annoying !!

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90: Bugs in the slideshow

Post by xnview » Tue Apr 17, 2018 8:38 am

Thunichgud wrote:
Sat Mar 10, 2018 6:12 pm
1. I installed XnViewMP the first time (version 0.90) in my admin account and XnViewMP and Windows did know .sld files. When I changed after that to my normal (non admin) user account, XnViewMP and Windows didn't know .sld files.
2. From inside of XnViewMP a slideshow can be startet by clicking on a previously stored .sld file. But when I try to start a slideshow directly from outside of XnViewMP by doubleclicking in the windows explorer onto the .sld file I get only a black screen - no pictures visible.
will be fixed
3. At an internal started slideshow the navigation buttons foreward, backward, pause are missing. Only the ESC button stops the slideshow and returns to the UI of XnViewMP. ENTER has no effect. ENTER should stop the slideshow, too.
4. During a slideshow the large SPACE button should pause the show and continue it at a second press.
See issue for current status and some details.
5. As in the classic XNView it should be possible to store in the .sld file one or more pathes to the directory of the picture files instead of storing all pictures file by file. This is better, when the content of picture files in a directory often changes. So it isn't neccessary to renew the .sld file every time after a change of the file content.
By editing the .sld? or in the slideshow dialog?
6. It should be possible to use in .sld files both: an absolute path (e.g. C:\user\public\pictures\) or a relative path ( \pictures\). The second case is better, when the pictures and the belonging .sld files are stored on an external HD, which is used on different computers.
See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90: Bugs in the slideshow

Post by xnview » Thu Jun 07, 2018 9:45 am

This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.
Pierre.

User avatar
Tschens
Posts: 26
Joined: Sat May 12, 2018 7:38 am
Contact:

Re: 0.90: Bugs in the slideshow

Post by Tschens » Thu Jun 14, 2018 7:01 pm

4. seems to be working (stop/continue slideshow with space).

At least the following problems are still there in the current beta 0.91:

2. From inside of XnViewMP a slideshow can be startet by clicking on a previously stored .sld file. But when I try to start a slideshow directly from outside of XnViewMP by doubleclicking in the windows explorer onto the .sld file I get only a black screen - no pictures visible.
3. At an internal started slideshow the navigation buttons foreward, backward, pause are missing. Only the ESC button stops the slideshow and returns to the UI of XnViewMP. ENTER has no effect. ENTER should stop the slideshow, too.

btw: @Problem 2): I get a black screen, not a white screen.

Did not check the rest.
Olympus OMD E-M1, BS Kinetics underwater housing, 2xSubtronic pro 60 flashes. Zuiko mFT lenses: 60 macro, 7-14, 8 mm fisheye, 14-150, Panasonic 100-300.
My Homepage | My book at Amazon

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90: Bugs in the slideshow

Post by xnview » Wed Jun 20, 2018 7:55 am

Tschens wrote:
Thu Jun 14, 2018 7:01 pm
2. From inside of XnViewMP a slideshow can be startet by clicking on a previously stored .sld file. But when I try to start a slideshow directly from outside of XnViewMP by doubleclicking in the windows explorer onto the .sld file I get only a black screen - no pictures visible.
ok, will be fixed (currently works only if you -slide ...)
3. At an internal started slideshow the navigation buttons foreward, backward, pause are missing. Only the ESC button stops the slideshow and returns to the UI of XnViewMP. ENTER has no effect. ENTER should stop the slideshow, too.
ok, but what do you means by foreward, backward? Arrow keys?
Pierre.

User avatar
Tschens
Posts: 26
Joined: Sat May 12, 2018 7:38 am
Contact:

Re: 0.90: Bugs in the slideshow

Post by Tschens » Wed Jun 20, 2018 4:43 pm

When I try to start a slideshow by double-klicking an sld file from outside XNviewMP, I get the attached screenshot: white background, no pictures, but arrow buttons for navigation. When starting the sld file from inside XNviewMP, the slideshow works, but no buttons appear.
Attachments
Screenshot01.jpg
Screenshot01.jpg (6.54 KiB) Viewed 522 times
Olympus OMD E-M1, BS Kinetics underwater housing, 2xSubtronic pro 60 flashes. Zuiko mFT lenses: 60 macro, 7-14, 8 mm fisheye, 14-150, Panasonic 100-300.
My Homepage | My book at Amazon

jgh
Posts: 15
Joined: Wed Jul 19, 2017 4:08 pm

Re: 0.90: Bugs in the slideshow

Post by jgh » Sun Jul 15, 2018 11:34 pm

Having been trying XnViewMP 0.90 (on Linux Mint and Windows 64 bit), hitting various slideshow issues and finding this topic, now trying 0.91Beta3 on Windows 7 64bit... Still some issues:

1) On Creating a Slideshow, the default 'Create' window is too big for my screen, and the bottom (including bottom right for resizing, OK and and Cancel buttons) is hidden behind Task Bar, and hence inaccessible. (I can move the window up to top of screen, but bottom of window is still too low).
2) In Create Slideshow, the default (initial) location for Add Files/Folder is the program folder - not what I expect (which would be current Browser view folder or 'My Pictures')
3) Creating a Slideshow and using 'Add Folder' I would expect there to be an option to include sub-folders or not, rather than for it to just include the contents of sub-folders.
4) Creating a Slideshow, and setting Info to be displayed, {Filename} is without extension, there is also {Filename With Ext}, but in the Insert menu they are 'Filename without Extension' and 'Filename' respectively, as on the insert menu for setting fullscreen info (under Tools > Setting > View > Info).
Some of the Info options that are available for fullscreen, are not there for slideshow (e.g Background opacity) - I would expect the available options to be the same, and have the effect.
5) An entry missing from the Insert menu (for both fullscreen and slideshow) is File Index.
6) What is 'File Number'? - It is available, but its meaning is not obvious, nor is an explanation readily available.

On using Slideshow, I would expect it and Quick Slideshow to work similarly.

7) Viewing Slideshow, the Space Bar for Pause/Unpause, and Left/Right Arrow for previous/next all work (most of the time - I had an XnViewMP failure on one test, dump uploaded earlier this evening); on Quick Slideshow, space bar does NOT work for pause (is there an alternative?), but for previous/next both left/right arrow and PageUp/PageDown keys work. My expectation would Space Bar for Pause; and left/right arrow and PageUp/PageDown keys for prev/next to all work on both slideshow and Quick Slideshow; and I would hope that, as in other apps, up/down arrow keys would also for prev/next.
8 ) While Fullscreen slideshow displays correctly (to my mind) by overlaying the Windows task bar; in Quick slideshow the converse is true, the bottom of the image behind (and semi hidden by) the task bar. (Note: the same difference in behaviour is observed between 'full screen' from browser tab (image in front of task bar) and 'full screen' from image tab (image behind task bar).
9) I would expect slideshow and Quick slideshow to have largely the same options: not only speed (which should be in same units - not seconds for one and milliseconds for other), and order; but also others such as loop and fullscreen.

jgh
Posts: 15
Joined: Wed Jul 19, 2017 4:08 pm

Re: 0.90: Bugs in the slideshow

Post by jgh » Mon Jul 16, 2018 8:05 pm

A couple of other slideshow issues i have found:
10) Using 'Add Folder' can add files to the slideshow that XnView cannot handle, e.g. font and *.sys files, resulting in a plain black screen on playing the slide show. Only suitable files (that can be handled) should be added. What determines what types of file are added?
11) There should be a specific file list filter option for slideshow (*.sld) files - at the moment they come under 'All others files'.

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90: Bugs in the slideshow

Post by xnview » Wed Jul 18, 2018 2:07 pm

jgh wrote:
Sun Jul 15, 2018 11:34 pm
1) On Creating a Slideshow, the default 'Create' window is too big for my screen, and the bottom (including bottom right for resizing, OK and and Cancel buttons) is hidden behind Task Bar, and hence inaccessible. (I can move the window up to top of screen, but bottom of window is still too low).
which screen size do you have? So you should have the problem with other dialog like contact sheets?
2) In Create Slideshow, the default (initial) location for Add Files/Folder is the program folder - not what I expect (which would be current Browser view folder or 'My Pictures')
right
3) Creating a Slideshow and using 'Add Folder' I would expect there to be an option to include sub-folders or not, rather than for it to just include the contents of sub-folders.
4) Creating a Slideshow, and setting Info to be displayed, {Filename} is without extension, there is also {Filename With Ext}, but in the Insert menu they are 'Filename without Extension' and 'Filename' respectively, as on the insert menu for setting fullscreen info (under Tools > Setting > View > Info).
Sorry but i don't undestand the problem
Some of the Info options that are available for fullscreen, are not there for slideshow (e.g Background opacity) - I would expect the available options to be the same, and have the effect.
ok
5) An entry missing from the Insert menu (for both fullscreen and slideshow) is File Index.
right
6) What is 'File Number'? - It is available, but its meaning is not obvious, nor is an explanation readily available.
you means 'Filename number'?
7) Viewing Slideshow, the Space Bar for Pause/Unpause, and Left/Right Arrow for previous/next all work (most of the time - I had an XnViewMP failure on one test, dump uploaded earlier this evening); on Quick Slideshow, space bar does NOT work for pause (is there an alternative?), but for previous/next both left/right arrow and PageUp/PageDown keys work. My expectation would Space Bar for Pause; and left/right arrow and PageUp/PageDown keys for prev/next to all work on both slideshow and Quick Slideshow; and I would hope that, as in other apps, up/down arrow keys would also for prev/next.

8 ) While Fullscreen slideshow displays correctly (to my mind) by overlaying the Windows task bar; in Quick slideshow the converse is true, the bottom of the image behind (and semi hidden by) the task bar. (Note: the same difference in behaviour is observed between 'full screen' from browser tab (image in front of task bar) and 'full screen' from image tab (image behind task bar).
9) I would expect slideshow and Quick slideshow to have largely the same options: not only speed (which should be in same units - not seconds for one and milliseconds for other), and order; but also others such as loop and fullscreen.
Please make separate post
Pierre.

jgh
Posts: 15
Joined: Wed Jul 19, 2017 4:08 pm

Re: 0.90: Bugs in the slideshow

Post by jgh » Thu Jul 19, 2018 3:57 pm

Thanks.
xnview wrote:
Wed Jul 18, 2018 2:07 pm
jgh wrote:
Sun Jul 15, 2018 11:34 pm
1) On Creating a Slideshow, the default 'Create' window is too big for my screen, and the bottom (including bottom right for resizing, OK and and Cancel buttons) is hidden behind Task Bar, and hence inaccessible. (I can move the window up to top of screen, but bottom of window is still too low).
which screen size do you have? So you should have the problem with other dialog like contact sheets?
Screen size 1366*768 (window height appears to match screen height). Create contact sheet dialog window is ok (is smaller to fit screen with plenty of room to spare).
2) In Create Slideshow, the default (initial) location for Add Files/Folder is the program folder - not what I expect (which would be current Browser view folder or 'My Pictures')
right
3) Creating a Slideshow and using 'Add Folder' I would expect there to be an option to include sub-folders or not, rather than for it to just include the contents of sub-folders.
?
4) Creating a Slideshow, and setting Info to be displayed, {Filename} is without extension, there is also {Filename With Ext}, but in the Insert menu they are 'Filename without Extension' and 'Filename' respectively, as on the insert menu for setting fullscreen info (under Tools > Setting > View > Info).
Sorry but i don't undestand the problem
I expect consistency! That "Filename" should be (and mean) with ext (e.g. pic.jpg) , or without ext (e.g. pic), not sometimes one, sometimes the other. On the "Info Insert>>" menu (popup list), it lists 'Filename' and 'Filename without Extension' - but when I choose "Filename", then on the 'info to be displayed' panel I see {Filename With Ext} (which is what I get)
Some of the Info options that are available for fullscreen, are not there for slideshow (e.g Background opacity) - I would expect the available options to be the same, and have the same effect.
ok
5) An entry missing from the Insert menu (for both fullscreen and slideshow) is File Index.
right
6) What is 'File Number'? - It is available, but its meaning is not obvious, nor is an explanation readily available.
you means 'Filename number'?
Yes, sorry
7) Viewing Slideshow, the Space Bar for Pause/Unpause, and Left/Right Arrow for previous/next all work (most of the time - I had an XnViewMP failure on one test, dump uploaded earlier this evening); on Quick Slideshow, space bar does NOT work for pause (is there an alternative?), but for previous/next both left/right arrow and PageUp/PageDown keys work. My expectation would Space Bar for Pause; and left/right arrow and PageUp/PageDown keys for prev/next to all work on both slideshow and Quick Slideshow; and I would hope that, as in other apps, up/down arrow keys would also for prev/next.
8 ) While Fullscreen slideshow displays correctly (to my mind) by overlaying the Windows task bar; in Quick slideshow the converse is true, the bottom of the image behind (and semi hidden by) the task bar. (Note: the same difference in behaviour is observed between 'full screen' from browser tab (image in front of task bar) and 'full screen' from image tab (image behind task bar).
9) I would expect slideshow and Quick slideshow to have largely the same options: not only speed (which should be in same units - not seconds for one and milliseconds for other), and order; but also others such as loop and fullscreen.
Please make separate post
New posts raised:
viewtopic.php?f=109&t=37715
viewtopic.php?f=82&t=37717

Jeremy

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90: Bugs in the slideshow

Post by xnview » Fri Jul 20, 2018 11:03 am

jgh wrote:
Thu Jul 19, 2018 3:57 pm
Screen size 1366*768 (window height appears to match screen height). Create contact sheet dialog window is ok (is smaller to fit screen with plenty of room to spare).
ok, it's an error
I expect consistency! That "Filename" should be (and mean) with ext (e.g. pic.jpg) , or without ext (e.g. pic), not sometimes one, sometimes the other. On the "Info Insert>>" menu (popup list), it lists 'Filename' and 'Filename without Extension' - but when I choose "Filename", then on the 'info to be displayed' panel I see {Filename With Ext} (which is what I get)
I don't understand the problem. When you choose 'Filename' in the menu, the field is {Filename with Ext}, and 'Filename without extension', it's {Filename}, it's the same everywhere
6) What is 'File Number'? - It is available, but its meaning is not obvious, nor is an explanation readily available.
you means 'Filename number'?
for example if you have a filename like IMG_0011.jpg, it's 0011
Pierre.

jgh
Posts: 15
Joined: Wed Jul 19, 2017 4:08 pm

Re: 0.90: Bugs in the slideshow

Post by jgh » Fri Jul 20, 2018 3:26 pm

Thanks
xnview wrote:
Fri Jul 20, 2018 11:03 am
I expect consistency! That "Filename" should be (and mean) with ext (e.g. pic.jpg) , or without ext (e.g. pic), not sometimes one, sometimes the other. On the "Info Insert>>" menu (popup list), it lists 'Filename' and 'Filename without Extension' - but when I choose "Filename", then on the 'info to be displayed' panel I see {Filename With Ext} (which is what I get)
I don't understand the problem. When you choose 'Filename' in the menu, the field is {Filename with Ext}, and 'Filename without extension', it's {Filename}, it's the same everywhere
... so I would say wrong everywhere. If I choose 'Filename without extension' and get {Filename}, that's a bug to my mind.
To get {Filename} I would expect to have to choose 'Filename' - both meaning the same - either with or without extension (not really important which).
6) What is 'File Number'? - It is available, but its meaning is not obvious, nor is an explanation readily available.
you means 'Filename number'?
for example if you have a filename like IMG_0011.jpg, it's 0011
Yes, I see, fair enough for that sort of filename - many of mine aren't like that.
But (rhetorically) it's still not obvious what it is/should be for, eg, 'JGH_20170913_E1804_cr2.jpg' or 'Copy of A06_Y28_V7-22a.jpg'.

Jeremy

Post Reply