IPTC-II/XMP - Template always deletes old value (single photo)?

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

jcancha
Posts: 6
Joined: Sun Jun 03, 2018 6:37 pm

IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha »

If I use a template to add keywords to a single photo using the IPTC-IIM/XMP dialogue all existing keywords are overwritten. Is there an option to just add keywords from a template to the already existing value of that picture? As far as I can see, that option only works for changing multiple photos, not for single files. Is that a bug or did I miss something? Thank you.
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

what do you have in IPTC dialog>Options
Pierre.
jcancha
Posts: 6
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha »

Here's a screen of the options settings. For templates on multiple files those settings work perfectly fine, but they do not seem to work on individual photos...I could not change them anyway since the switches are inactive in single mode.
XnViewMP-Options.png
XnViewMP-Options.png (6.76 KiB) Viewed 1588 times
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

i need to add an option to choose behavior when using template (clear all or merge)
Pierre.
jcancha
Posts: 6
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha »

Ok, thank you.
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.
jcancha
Posts: 6
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha »

xnview wrote: Tue Sep 17, 2019 10:21 am This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Unfortunately, the problem also occurs with the version 0.94. When I apply a template to a single file, the old data is overwritten. Here is a screen of the settings:
2019-09-17 XNView MP 094.jpg
2019-09-17 XNView MP 094.jpg (46.59 KiB) Viewed 1218 times
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

could you send me the template file?
Pierre.
mudo_j
Posts: 25
Joined: Fri Feb 17, 2017 7:01 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by mudo_j »

If I may try to jump in here without harm:

XnView MP 0.94 beta 3, 64-bit, Windows 10
Edit IPTC-IIM/XMP mode: XMP, update or create IPTC-IIM

Files are zipped to keep the metadata untouched:

0_empty.jpg - no metadata
1_ccl_template-source.jpg - no metadata, then Country, City and Location written. Then the template was exported/saved:
montmartre.iptc.
2_c-k-sc.jpg - no metadata, then a caption, 3 keywords and 2 supplemental categories written.
3_c-k-sc_copy_plus_template.jpg - copy of the previous file, with caption, keywords, supp. categories. Then the template was loaded, data written.

The file now has the imported Country, City and Location. Caption/description has survived, but keywords and suppl. categories are gone.

I hope this helps.
Attachments
template_deletes.zip
(40.92 KiB) Downloaded 39 times
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

mudo_j wrote: Wed Oct 30, 2019 9:49 pm The file now has the imported Country, City and Location. Caption/description has survived, but keywords and suppl. categories are gone.
Loading template replace all fields, it's the same in 0.93. When loading a template, must ask to replace or merge fields...
Pierre.
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

See issue for current status and some details.
Pierre.
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.0. Please check and confirm the bug fix here.
Pierre.
jcancha
Posts: 6
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha »

Unfortunately, the problem is not solved in 0.98.0 either. If you use a template for a single photo, the existing keywords are replaced, no matter if "Merge" is selected or not. "Merge" keeps the caption intact but the keywords are still overwritten.
User avatar
xnview
Author of XnView
Posts: 34672
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by xnview »

jcancha wrote: Mon Dec 14, 2020 4:08 pm Unfortunately, the problem is not solved in 0.98.0 either. If you use a template for a single photo, the existing keywords are replaced, no matter if "Merge" is selected or not. "Merge" keeps the caption intact but the keywords are still overwritten.
I try with 2_c-k-sc.jpg from your archive, and load 'montmartre' template, keywords are always here if i use 'merge datas'
Pierre.
jcancha
Posts: 6
Joined: Sun Jun 03, 2018 6:37 pm

Re: IPTC-II/XMP - Template always deletes old value (single photo)?

Post by jcancha »

I try with 2_c-k-sc.jpg from your archive, and load 'montmartre' template, keywords are always here if i use 'merge datas'
2_c-k-sc.jpg was sent by mudo_j, not by me. But I have now also tried to replicate the problem using that file. The template 'montmartre' doesn't seem to contain any keywords at all, therefore the existing keywords in 2_c-k-sc.jpg survived. Please try again with my template 'Garten.iptc' attached here. This should overwrite the keywords in 2_c-k-sc.jpg despite 'merge datas'.
Attachments
Garten.zip
(363 Bytes) Downloaded 6 times
Post Reply