[0.93] Slideshow bugs

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
Thunichgud
Posts: 7
Joined: Thu Sep 24, 2009 10:02 am

[0.93] Slideshow bugs

Post by Thunichgud » Sun Feb 03, 2019 1:26 pm

1. The slideshow files .sld should be full compatible to the slideshow files of the classic version of XnView (or vice versa).
I have stored my photos on an external HD and use it on different devices: on a desktop PC with XnView Classic and on a notebook with XnViewMP. I have to make different slideshow files for the two software versions. Not good.
2. Store only a path (or multiple pathes) to the photo files in the slideshow file (as in XnView Classic).
When I create in XnViewMP a slideshow file, every photo file is stored - file by file - in a long list of photo files. When the content of photo files in the directory changes, new files will not be shown until I create a new slideshow file. When I delete a photo file which is listed in the old slideshow file, the software outputs an error message when during a slideshow the photo is missed. So I have to create an new slideshow file, too, when I delete a photo. When the slideshow file stores only the pathes to the photo files these problems are obsololet.

User avatar
xnview
Author of XnView
Posts: 32078
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.93] Slideshow bugs

Post by xnview » Mon Feb 04, 2019 1:14 pm

Thunichgud wrote:
Sun Feb 03, 2019 1:26 pm
1. The slideshow files .sld should be full compatible to the slideshow files of the classic version of XnView (or vice versa).
I have stored my photos on an external HD and use it on different devices: on a desktop PC with XnView Classic and on a notebook with XnViewMP. I have to make different slideshow files for the two software versions. Not good.
Some settings are not the same, but i can add a compatibility load
2. Store only a path (or multiple pathes) to the photo files in the slideshow file (as in XnView Classic).
When I create in XnViewMP a slideshow file, every photo file is stored - file by file - in a long list of photo files. When the content of photo files in the directory changes, new files will not be shown until I create a new slideshow file. When I delete a photo file which is listed in the old slideshow file, the software outputs an error message when during a slideshow the photo is missed. So I have to create an new slideshow file, too, when I delete a photo. When the slideshow file stores only the pathes to the photo files these problems are obsololet.
yes right
Pierre.

User avatar
xnview
Author of XnView
Posts: 32078
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.93] Slideshow bugs

Post by xnview » Fri Aug 16, 2019 12:49 pm

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 32078
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.93] Slideshow bugs

Post by xnview » Tue Sep 17, 2019 10:19 am

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.

Thunichgud
Posts: 7
Joined: Thu Sep 24, 2009 10:02 am

Re: [0.93] Slideshow bugs

Post by Thunichgud » Sun Dec 01, 2019 3:47 pm

Bug 1633 and 1634

The bugs are still not fixed in [0.94.1].
- It is still not possible, to use a .sld-file from XnView classic in XnViewMP. Only a black sceen is shown. My classic .sld-files consists only of a path to the picture files and the settings of XnView. In my XnView classic .sld-file no list of files is included.
- It is still not possible to create a classic .sld-file with only one or multiple pathes in it. When I try to select a directory to the picture files in XnViewMP, the prog reads the inventory of that directory and puts it in a long list of files.
- And a new bug:
After installation using XnViewMP-win for Windows 7 32 bit, my windows don't knows the file format of the .sld-file. I have to select the belonging XnViewMP.exe at every start of a slideshow.

User avatar
xnview
Author of XnView
Posts: 32078
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.93] Slideshow bugs

Post by xnview » Mon Dec 02, 2019 8:04 am

Thunichgud wrote:
Sun Dec 01, 2019 3:47 pm
- It is still not possible, to use a .sld-file from XnView classic in XnViewMP. Only a black sceen is shown. My classic .sld-files consists only of a path to the picture files and the settings of XnView. In my XnView classic .sld-file no list of files is included.
When using 'Open' in slideshow dialog?
- It is still not possible to create a classic .sld-file with only one or multiple pathes in it. When I try to select a directory to the picture files in XnViewMP, the prog reads the inventory of that directory and puts it in a long list of files.
You can add paths by editing .sld
- And a new bug:
After installation using XnViewMP-win for Windows 7 32 bit, my windows don't knows the file format of the .sld-file. I have to select the belonging XnViewMP.exe at every start of a slideshow.
Right .sld is not associated
Pierre.

Post Reply