Data Loss! Cut and paste selected files

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
User avatar
dunntry
Posts: 18
Joined: Tue Jun 20, 2017 11:07 pm

Data Loss! Cut and paste selected files

Post by dunntry » Sat Feb 15, 2020 11:35 am

I tagged a hundred files, then selected them, and cut them to paste them into another folder.

Strangely, I started getting messages that there were duplicates in the target folder (I don't think there were), so I was offered a choice to delete the left or right file, which I did for a few instances, then I selected "replace all" to hurry it up.

But!! The target folder was missing half the files from the source folder. GONE. Not in recycle bin. Kaput

This is the same bug that was reported a while ago here:
viewtopic.php?f=62&t=38899&p=156190&hil ... ss#p156190

I immediately deleted XnView off my machine. I have huge problems now with this missing data.

:twisted: :twisted: :twisted: :twisted: :twisted:

This is not serious software. This is not for use by professional people who value their data :bugconfirmed:

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Data Loss! Cut and paste selected files

Post by xnview » Tue Feb 18, 2020 2:20 pm

Sorry about the problem, you have selected the folder to paste?
Pierre.

User avatar
dunntry
Posts: 18
Joined: Tue Jun 20, 2017 11:07 pm

Re: Data Loss! Cut and paste selected files

Post by dunntry » Tue Feb 18, 2020 11:19 pm

Maybe this is why the bugs never get fixed .... my easy-to-understand post is now questioned in an odd way by the developer.
🙄

Meanwhile I am trying out FastStone Viewer, which is a XnView replacement and seems more stable.

jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: Data Loss! Cut and paste selected files

Post by jadO » Wed Feb 19, 2020 8:00 am

dunntry wrote:
Sat Feb 15, 2020 11:35 am
I tagged a hundred files, then selected them, and cut them to paste them into another folder.

Strangely, I started getting messages that there were duplicates in the target folder (I don't think there were), so I was offered a choice to delete the left or right file, which I did for a few instances, then I selected "replace all" to hurry it up.

But!! The target folder was missing half the files from the source folder. GONE. Not in recycle bin. Kaput
This is indeed strange. I have just tried to reproduce but it did not happen.
Here is what I did:

1. Have a folder with files
2. Created sub folder
3. Moved files into this sub folder (I tried cut&paste via keyboard and context menu, dragging files and move to via context menu)
4. I also tagged the files with colors, keywords and checkbox.
5. I copy and pasted them into other folders, parent folders etc.

I did not experience the issue. All files got moved successfully. No messages about existing files, no files deleted.

What you describe seems to be kind of normal behavior as cut and paste includes deletion of the file from the old location. It seems that in your case for some reason the file have not been created sucessfully at their new location but sucessfully deleted from the old location. Maybe some Antivirus software interfering?

But I agree that the software should not delete data if it cannot create it at the new place. It must delete data at old place only if 100% correctly created at the new place.
Last edited by jadO on Wed Feb 19, 2020 10:27 am, edited 2 times in total.

cday
XnThusiast
Posts: 2455
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Data Loss! Cut and paste selected files

Post by cday » Wed Feb 19, 2020 8:25 am

...

And if files are important it is always wise to back them up to protect against any of the possible causes of data loss, which is not to excuse a possible serious bug... :(

User avatar
dunntry
Posts: 18
Joined: Tue Jun 20, 2017 11:07 pm

Re: Data Loss! Cut and paste selected files

Post by dunntry » Wed Feb 19, 2020 10:17 am

What you need to do is re-create the test scenario:
  1. Tag about 50 files (tif files)
  2. Select tagged files and Cut them
  3. Paste into target folder
  4. But first, put some duplicates in the target folder, so that you get the dialogue that asks if you want to delete from left or right.
  5. Do a few deletes from left or right, then say "Replace All"
  6. Check results. Are all your files there?
If that does not reproduce bug, then all I can surmise is that there is a memory leak in XnView that caused this. I had been working with it for an hour or so, moving around 5MB files (TIF files), when this happened. It only happened with there was a conflict and the 'Delete which file?' dialogue came up.

Memory leaks can cause strange behaviour due to corruption.

jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: Data Loss! Cut and paste selected files

Post by jadO » Wed Feb 19, 2020 10:28 am

dunntry wrote:
Wed Feb 19, 2020 10:17 am
What you need to do is re-create the test scenario:
  1. Tag about 50 files (tif files)
By "tag" you mean categorise?

jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: Data Loss! Cut and paste selected files

Post by jadO » Wed Feb 19, 2020 11:05 am

I have tried with tiff-files. But I cannot reproduce it.

I had some duplicates in the target folder as suggested and the duplicate warning popped up. Inspection of target and source folders show all files.

However there is another bug: In the duplicate warning dialog I selected "delete" from the target folder. From my understanding this means that the duplicate in the target folder gets deleted and the duplicate from the source folder get moved into the destination.
However the 2 files that I had chosend to delete got deleted from the target folder but NOT moved from the source folder into the target folder.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Data Loss! Cut and paste selected files

Post by xnview » Wed Feb 19, 2020 12:58 pm

dunntry wrote:
Wed Feb 19, 2020 10:17 am
What you need to do is re-create the test scenario:
My apologies for the problem, :bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

User avatar
dunntry
Posts: 18
Joined: Tue Jun 20, 2017 11:07 pm

Re: Data Loss! Cut and paste selected files

Post by dunntry » Thu Feb 20, 2020 6:24 am

Well, better late than never, I suppose.

But you have to wonder how many people have silently lost data during the years that this extremely severe and ugly bug has existed.

😣😫😬😡

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Data Loss! Cut and paste selected files

Post by xnview » Fri Feb 21, 2020 3:38 pm

dunntry wrote:
Thu Feb 20, 2020 6:24 am
But you have to wonder how many people have silently lost data during the years that this extremely severe and ugly bug has existed.
You are the first one (and the original thread) to report this bug.
Pierre.

User avatar
dunntry
Posts: 18
Joined: Tue Jun 20, 2017 11:07 pm

Re: Data Loss! Cut and paste selected files

Post by dunntry » Sat Feb 22, 2020 10:03 pm

Whatever you say, my friend. I can tell you that I will never use your software again, that's for sure. It's Amateur Hour here, all the time. 🤡

Bye.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Data Loss! Cut and paste selected files

Post by xnview » Sat Mar 21, 2020 9:24 am

This problem is supposed to be fixed in XnView MP 0.96. Please check and confirm the bug fix here.
Pierre.

Post Reply