Misbehaving crop function [0.97.1 and earlier]

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
tritrek
Posts: 3
Joined: Sun Oct 18, 2020 2:50 pm

Misbehaving crop function [0.97.1 and earlier]

Post by tritrek »

Subject: Cannot crop in portrait

XnView: Version 0.97.1 64bits (Oct 13 2020)
OS: Windows 64bit

When working with a portrait oriented image, no matter what ratio or fixed size crop preset you're using, it always works as landscape.

Effect: Major annoyance. I have a whole ebook with badly cropped images and I wanted to fix those by setting a fixed size crop area and using that to ensure all crops are of the same size. However whether I use a ratio or a size setting it always starts the crop as landscape and I couldn't find a way to swap that...

To reproduce:
1. Create a crop template, e.g. in this case a 100x200px
2. Open an image, in this case a 500x1000px image
3. Pick the crop template and apply.
4. The crop area is landscape (200 x 100px - w x h) despite it's set for 100 x 200px.

Actual behaviour (bug): Can't crop because of the wrong orientation :bug:

Expected behaviour: Crop template gets applied as it's set, e.g. if it's set to 100x200 it won't actually act as 200x100
Here's the template:
crop_template.jpg
crop_template.jpg (9.24 KiB) Viewed 716 times
And here's how it's acting:
xnviewmp.jpg
Last edited by tritrek on Sun Oct 18, 2020 4:01 pm, edited 1 time in total.
cday
XnThusiast
Posts: 2736
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Misbehaving crop function

Post by cday »

Current XnView MP version is 0.97.1, could you please retest in that version in case the issue you report has already been fixed, you can test in the portable ZIP version if you prefer, I don't know whether it might have been...
tritrek
Posts: 3
Joined: Sun Oct 18, 2020 2:50 pm

Re: Misbehaving crop function

Post by tritrek »

cday wrote: Sun Oct 18, 2020 3:39 pm Current XnView MP version is 0.97.1, could you please retest in that version in case the issue you report has already been fixed, you can test in the portable ZIP version if you prefer, I don't know whether it might have been...
Hi, it is that version. I have downloaded the portable version to test it: it's behaving in the same way.
User avatar
xnview
Author of XnView
Posts: 34717
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Misbehaving crop function [0.97.1 and earlier]

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
tritrek
Posts: 3
Joined: Sun Oct 18, 2020 2:50 pm

Re: Misbehaving crop function [0.97.1 and earlier]

Post by tritrek »

Thank you!
User avatar
xnview
Author of XnView
Posts: 34717
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Misbehaving crop function [0.97.1 and earlier]

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.0. Please check and confirm the bug fix here.
Pierre.
Post Reply