0.98 crop issue

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
simon
Posts: 36
Joined: Wed Aug 23, 2006 4:51 pm

0.98 crop issue

Post by simon »

In the previous version, this worked fine, but in the new one, any crop predefined in pixels or in mm (including those by defaults) results in a portrait crop, i.e. width and height are swapped if width>height. This does not occur for crops predefined in terms of ratio.
(winMP0.98 on windonw10pro)
Thanks
User avatar
xnview
Author of XnView
Posts: 34647
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98 crop issue

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 34647
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98 crop issue

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.1. Please check and confirm the bug fix here.
Pierre.
User avatar
LazyOne
Posts: 2
Joined: Wed Jan 27, 2021 11:40 pm

Re: 0.98 crop issue

Post by LazyOne »

This problem is supposed to be fixed in XnView MP 0.98.1. Please check and confirm the bug fix here.
Sadly it is still here:
XnView MP Windows
Version 0.98.1 64bits (Jan 20 2021)

I mean: it works if pic is in landscape mode (width > height) .. but on portrait pics (height > width) it still does not work (it used to work in 0.97 or so).

Image

I have to use custom 9:16 entry to have it working in a desired way (to select a portion of the large portrait (tall) image, crop and save so it can be used as a desktop background.

Image

The image on the screenshot is small, it is used to just illustrate the issue. But you should see its' dimensions in the status bar area.

That aforementioned custom entry that works in such case:
Image

Obviously, on landscape pics it works other way around.
User avatar
xnview
Author of XnView
Posts: 34647
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98 crop issue

Post by xnview »

it's not the original bug issue (pixels or mm)
Pierre.
User avatar
LazyOne
Posts: 2
Joined: Wed Jan 27, 2021 11:40 pm

Re: 0.98 crop issue

Post by LazyOne »

it's not the original bug issue (pixels or mm)
Right, you are correct on pixels: seems to work fine if I use preset in pixels (e.g. 1920x1080 or similar).

I must have been confused with this (viewtopic.php?f=62&t=41403&p=167383&hilit=crop#p167383) .. where 2 issues were described (pixels and ratio) and you said "ok, known issue" and linked this thread.
Post Reply