Slow program start [Solved]

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
nomm
Posts: 4
Joined: Sat Jan 09, 2021 6:18 pm

Slow program start [Solved]

Post by nomm »

hello,
I use XnView MP (0.98.0 64bits) on Mac OSX (10.15.7). I have the problem, that ervery program start is very slow. It takes about 30 - 40 seconds until the spinning color wheel stops and I can start browsing through the photos.
Any ideas to speed up the program start? It is always the same even when I start in the same directory.

Thanks.
User avatar
xnview
Author of XnView
Posts: 34644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: slow program start

Post by xnview »

do you have tabs that reopened?
Pierre.
nomm
Posts: 4
Joined: Sat Jan 09, 2021 6:18 pm

Re: slow program start

Post by nomm »

No, only the main tab "Browser" has to reopened.

Some additional informations
Setting for Startup:
Startup directory "Last"

It seems, that the number of photos in the directory that I have selected at the startup don't affect the delay (if the directory includes at least 1 photo ). The delay is always the same (30 - 40 seconds). But when I select a directory at startup that contains no photos, then the startup is fast.
User avatar
xnview
Author of XnView
Posts: 34644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: slow program start

Post by xnview »

If you start in an empty folder, it's fast, in a folder with 1 file, it's slow, right?
Pierre.
nomm
Posts: 4
Joined: Sat Jan 09, 2021 6:18 pm

Re: slow program start

Post by nomm »

I made several tests and now i think I have the reason for the delay.

The directory tree looks like this:
/Users/<username>/pictures/fotos/2009-11-01
.. /2009-12-06
.. /2010-01-01
etc.

Underneath the "fotos" directory, I have a large number of directories (more than 850 directories). And in each directory are photos. If I have selected one of these directories at the start of the program, the startup takes 40 seconds. If I select a directory above the directory "fotos" the startup is very fast.
User avatar
xnview
Author of XnView
Posts: 34644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: slow program start

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 34644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: slow program start

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.1. Please check and confirm the bug fix here.
Pierre.
nomm
Posts: 4
Joined: Sat Jan 09, 2021 6:18 pm

Re: slow program start

Post by nomm »

No delay anymore, thank you very much for the bug fix.
ellenm344
Posts: 1
Joined: Thu Feb 18, 2021 6:02 pm

Re: Slow program start [Solved]

Post by ellenm344 »

I still have the problem. It only started fairly recently. I am accessing a large drive across my local network. The folders act normally when viewed with the Finder, but in XnView, hovering over the folders pane with the mouse causes immediate and fairly permanent beachball action. This is more like Adobe Bridge than XnView's normal behavior. Is there any fix I can try? Nothing but the Browser is open in XnView. I have just updated to the latest version of XnViewMP: 1.9.8.1
Thanks,
Ellen
Post Reply