black color issue for PNG

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
.nos.

black color issue for PNG

Post by .nos. » Tue Jan 08, 2008 9:52 pm

Hi,
I noticed an issue concerning 32bits PNG files.
It looks like pictures in this format actually uses the color set in "Options/View/Background color" instead of the black color.
means if you leave this option to grey (default), you'll get grey instead of black in the whole picture. if you set black, you'll get black as expected.
This is also true for the thumbnails view and preview with their respective background color

Tested with XnView 1.92 (19 dec 2007)

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Alpha ?

Post by Clo » Tue Jan 08, 2008 10:07 pm

:) Hello !

• Please, try to tick the box in:

–> View Menu >> Use Alpha Channel

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

Guest

Post by Guest » Wed Jan 09, 2008 10:44 pm

Use alpha channel was already checked;
But if I uncheck it, those 32bits PNG files are then displayed properly; thx for the tips.
only left the thumbnails view, where I can't find this option, so you still see the transparent objects in the picture with the thumbnails background color...

possibly I'm wrong, but looks like to me that Use alpha channel option works in the opposite way.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Strange

Post by Clo » Wed Jan 09, 2008 11:17 pm

:arrow: .nos.

:) Hello !

• Strange, here the option in the menu works normally…
- If I untick it, then the BG is black…

- You can use too the option (F12) >> View [×] Use chequered pattern… or so to replace the transparency.
- The colour depth you set for display in Win does matter too, here I've 16 BPP only,
and I can't see the transparency in the thumbnails (black BG), the chequered pattern is not applied,
while it's in the Preview of the browser…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 31372
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jan 10, 2008 4:27 am

Anonymous wrote:Use alpha channel was already checked;
But if I uncheck it, those 32bits PNG files are then displayed properly; thx for the tips.
only left the thumbnails view, where I can't find this option, so you still see the transparent objects in the picture with the thumbnails background color...

possibly I'm wrong, but looks like to me that Use alpha channel option works in the opposite way.
Could you post the png picture used?
Pierre.

.nos.

Post by .nos. » Sat Jan 12, 2008 4:24 am

Hi, sure I can
I've used ImageShack; should you have better solution, let me know.

Image

you should see the creature on the bottom left transparently; but even the browser show it in plain white...and some nasty bugs with the chains hanging from the ceiling.

User avatar
XnTriq
Moderator & Librarian
Posts: 5424
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Sat Jan 12, 2008 4:00 pm

It's another mangled game/video screenshot.

Recommended settings:
  • View »
    • » Use alpha channel » On
      » Show Mask » Off
  • Tools » Options... »
    • » General » Read/Write » PNG » Parameters » Compose image with transparency » Off
      » General » Read/Write » PNG » Parameters » Compose image with alpha (32bits) » Off
      » View » View » Background colour » R128/G128/B128
      » View » View » Use checkerboard pattern as background » On
      » View » Fullscreen » Background colour » R128/G128/B128
See also:

.nos.

Post by .nos. » Sat Jan 12, 2008 8:32 pm

Ok, I was suspecting the screenshot was mangled; but as far as I remember, it was allright with my previous version of xnview (1.82)

Anyway, the point is that I can't use your setting to see them properly; I've got to set View > use alpha channel to off.
besides, I've to set View > Preview > use alpha channel to off in order to display a proper preview, and lastly, I've to rebuild the thumbnails to show them with the right transparency. thx to the links you posted, I didn't know this command

Post Reply