XnView crash if folder with a lot of file

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

jherek
Posts: 2
Joined: Tue Feb 10, 2009 10:18 am

Post by jherek » Tue Feb 10, 2009 12:14 pm

Hi,

first of all: I've been using Xnview since years now (since 1.05/07 I guess) and as this is my first post here I'd like to give my biggest thanks to the author(s) for this awesome little program - it helped me a lot :)

Now about the crashes: in 1.95.4 I seemed to have a similar problem with lots of .jpg and .png files, both mixed in a few folders. When reading the images in those folders Xnview crashes - read ahead functions are turned off.

Then I discovered that the crashes also happen in 2 or 3 folders which contain only 20 images, some in high res formats. And only in thumbnail view. In file detail view Xnview didn't crash.

After some tests with moving and sorting files I could locate a crash problem with two .jpg files. Both are jpg v.1.2, both have no dpi values in their properties and both show an exif-offset of 8 under EXIF.
Then I tried out deleting EXIF data in Xnview: >Edit >Metadata >Delete ... and marked EXIF data to delete ... et voila ... the thumbnails do work now without crashing.

Maybe Xnview has a problem with reading (corrupted?) EXIF data - I checked those pics with two other viewers and they hadn't.

So my - and perhaps hispanicos ? - question would rather be, how do I find corrupted image(data) files in a huge collection of pics?

greetz - jherek

User avatar
xnview
Author of XnView
Posts: 33205
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Feb 10, 2009 1:02 pm

jherek wrote: Maybe Xnview has a problem with reading (corrupted?) EXIF data - I checked those pics with two other viewers and they hadn't.
Could you send me these corrupted files?
Pierre.

jherek
Posts: 2
Joined: Tue Feb 10, 2009 10:18 am

Post by jherek » Wed Feb 11, 2009 7:39 am

Yes, to the webmaster mail adress?

User avatar
xnview
Author of XnView
Posts: 33205
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Feb 11, 2009 8:15 am

jherek wrote:Yes, to the webmaster mail adress?
yes
Pierre.

obelisk
Posts: 403
Joined: Fri Jan 09, 2009 9:54 am

Post by obelisk » Tue Mar 03, 2009 12:20 pm

I get this issue, and error is usually with avi file, crash in avisplitter.???

juppzupp
Posts: 2
Joined: Sun Mar 08, 2009 5:43 pm

Post by juppzupp » Sun Mar 08, 2009 6:39 pm

Hello i can confirm that problem.

I will try to explain. I am sorry about my english.

My folder tree on drive d:\ : seven folders and one file at the main folder at the harddisk.

d:\
d:\Folder 1
d:\Folder 2
.
.
d:\Folder 7
d:\filename.flv


When the contents of drive "d:\" are shown in XNVIEW-main-window and i want to move to a subfolder by clicking the foldername, XNVIEW stops CPU= 50% (important: do not click the "+" at folder tree, you must click the foldername at foldertree or you must click the foldername at XNVIEW main window) . After clicking another foldername the window-title of xnview shows "no response". The only thing i can do is closing XNVIEW with the "X" at top right of the window.

First i guess, it has to do with my big folders (a lot of subfolders with a lot of files with all extensions). But that isn't the problem.
The problem is the file with extension ".flv". when i rename the "filename.flv" to "filename.xxx" everything is ok.


I use the newest version of XNVIEW (.zip Feb. 24. 2009 Windows XP SP3). I am sure , i haven't had that problem with the versions before, because I am using xnview since years and i have saved that "flv"-file on drive e:\ since nine months

User avatar
xnview
Author of XnView
Posts: 33205
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sun Mar 08, 2009 7:22 pm

juppzupp wrote: First i guess, it has to do with my big folders (a lot of subfolders with a lot of files with all extensions). But that isn't the problem.
The problem is the file with extension ".flv". when i rename the "filename.flv" to "filename.xxx" everything is ok.
Could you send me the flv file?
Pierre.

obelisk
Posts: 403
Joined: Fri Jan 09, 2009 9:54 am

Post by obelisk » Sun Mar 08, 2009 10:11 pm

i get this if 'caching' lots of new files, whether in diff folders.

juppzupp
Posts: 2
Joined: Sun Mar 08, 2009 5:43 pm

Post by juppzupp » Mon Mar 09, 2009 4:40 pm

I will send the file to the webmasters mailadress. (9 MB)

-done- :D

Post Reply