Search found 33 matches

by JMM72
Wed Jan 04, 2017 4:31 pm
Forum: MP - Resolved Bugs & Requests
Topic: 0.83: Error detecting split 7z files, and potential crash
Replies: 13
Views: 3895

Re: 0.83: Error detecting split 7z files, and potential cras

I assume that copying and renaming any huge file to .001 can be used for trying to reproduce the problem. No, any file with .001 extension is detected as Hayes JTFax format with CCITT Group 3 compression, but only 7zip files cause the crashes here (64 bit XMP). The file must have .001 extension, th...
by JMM72
Thu Dec 22, 2016 12:23 am
Forum: Retest
Topic: 0.83: XnView MP can rename files to too long names
Replies: 13
Views: 1771

0.83: XnView MP can rename files to too long names

Hello. Using: XnViewMP Version 0.83 x64 (Oct 3 2016) Libformat version 6.92, under Windows 7 64 bit. Using F2 to rename a file can cause the file to have a filename too long so it can't be accessed. This bug has two possible outcomes. As you might already know, under Windows the complete path to a f...
by JMM72
Thu Dec 22, 2016 12:02 am
Forum: MP - Resolved Bugs & Requests
Topic: 0.83: Error detecting split 7z files, and potential crash
Replies: 13
Views: 3895

Re: 0.83: Error detecting split 7z files, and potential cras

As I said, any first volume of a split 7z file will trigger this bug, but here you go.
For some reason I can't add the file to this post, download from: http://www.eligeotravez.net/x.7z.001


You can download 7Zip and create a larger split 7z file to trigger the crash.
by JMM72
Tue Dec 20, 2016 4:07 pm
Forum: MP - Resolved Bugs & Requests
Topic: 0.83: Error detecting split 7z files, and potential crash
Replies: 13
Views: 3895

0.83: Error detecting split 7z files, and potential crash

Hello. Using: XnViewMP Version 0.83 x64 (Oct 3 2016) Libformat version 6.92 Although this looks as one bug, it's actually two, the crash shouldn't happen but an error should be shown, besides the bad detection. It took me a bit to get why and how XMP kept crashing in a certain folder, it all started...
by JMM72
Thu Aug 18, 2016 11:04 pm
Forum: MP - Suggestions
Topic: New annoyance in version .81
Replies: 2
Views: 666

Re: New annoyance in version .81

I don't know what you have different. For me non-image files don't switch to properties. It stays in preview, and the preview space becomes all black.

Regards.
by JMM72
Sat Aug 13, 2016 8:33 pm
Forum: MP - Resolved Bugs & Requests
Topic: Keys file codification causes some keys to not be read
Replies: 1
Views: 464

Keys file codification causes some keys to not be read

I think this also applies to non-beta XnViewMP, but since I discovered it with 0.82 Beta 4, I think it's better in this forum. In short: XnViewMP doesn't save the key configuration in UTF-8, but it's the codification which seems to not give problems with strange characters/keys. When opening in full...
by JMM72
Sat Aug 13, 2016 7:59 pm
Forum: MP - Resolved Bugs & Requests
Topic: 0.82.b3- Close pressing ESC in fullscreen mode not working
Replies: 7
Views: 826

0.82.b4- Close pressing ESC in fullscreen works too much

I was going to post a bug but I think it's related to this one. With Beta 3, starting in full screen, setting ESC exits only in full screen mode. I open an image, it opens in full screen, I go to next previous whatever, I press ESC and XnViewMP exits. If I do the same, but first I move to explorer v...
by JMM72
Mon Aug 01, 2016 11:49 am
Forum: MP - General Support
Topic: No update setting?
Replies: 5
Views: 468

Re: No update setting?

I agree the location is counter-intuitive, it should be in general, next to 'only one program instance' imho. The other day I had a popup for 0.83 (false alarm for what it seems) and took me a while to find the setting because I wanted to trigger the update popup again. Btw, today I also had a popup...
by JMM72
Fri Jul 01, 2016 1:16 am
Forum: MP - Suggestions
Topic: Column for file path on details view
Replies: 0
Views: 242

Column for file path on details view

Name says it all, I've always missed such a column. Most useful when viewing recursively inside a path but wanting to know where is each file on a quick glance. I'd say it's easy and quick to implement, but since I don't know the guts of XnViewMP, it's just a guess.
by JMM72
Thu Jun 30, 2016 1:08 pm
Forum: Closed/Resolved
Topic: Doesn't delete in 'view' mode
Replies: 13
Views: 1999

Re: Doesn't delete in 'view' mode

Well we're getting to the bottom of it. By default, deleting in view mode doesn't have any key set, but it uses Del, and it works. What doesn't work is if you go to key shortcuts and assign Del to delete in view mode, and that's what caused all this upheaval with Del not working. Strange, isn't it? ...
by JMM72
Thu Jun 30, 2016 2:19 am
Forum: MP - Resolved Bugs & Requests
Topic: 0.80: Dragging on explorer mode doesn't move, but copy
Replies: 4
Views: 3100

Re: Dragging on explorer mode doesn't move, but copy

0.81 64 bit on Windows 7 64 bit. If I drag a thumbnail (or many) over the thumnail of a folder, the thumbnails are moved. If I drag them over the folder tree, the thumbnails are copied. Tried this on the same folder, just changed if I was doing the move operation over the thumnail or over the folder...
by JMM72
Thu Jun 30, 2016 12:54 am
Forum: MP - Suggestions
Topic: Compare mode
Replies: 1
Views: 408

Compare mode

Selecting 2 files, the screen is split in two and you see each image in one part of the screen. Clicking on one or the other would allow to move/zoom the view of each file; and then a function to 'sync views' would make a movement or zoom in one of the views to be replicated (and scaled accordingly ...
by JMM72
Wed Jun 29, 2016 1:17 pm
Forum: Closed/Resolved
Topic: Doesn't delete in 'view' mode
Replies: 13
Views: 1999

Re: Doesn't delete in 'view' mode

I can confirm that in 0.81 64 bit the Del key still doesn't work (Win 7 64 bit). Still using the dot key trick I previously described. I'm too tired to check if 0.81 32 bit works, but if there's a difference there I guess it's worth checking.
by JMM72
Mon Jun 27, 2016 1:00 am
Forum: Closed/Resolved
Topic: Doesn't delete in 'view' mode
Replies: 13
Views: 1999

Re: Doesn't delete in 'view' mode

I hope you can follow me. While delete doesn't work by itself, there's a way to make it work, as in modern keyboards there are two delete keys. One is in they numeric keypad, and the other is in the access cluster just over the stand-alone arrow keys (the cluster usually has 6 keys: insert, delete, ...
by JMM72
Thu Jun 23, 2016 7:59 pm
Forum: MP - Resolved Bugs & Requests
Topic: 0.80: Dragging on explorer mode doesn't move, but copy
Replies: 4
Views: 3100

0.80: Dragging on explorer mode doesn't move, but copy

XnView MP 0.80 64bit running on Windows 7 64bit. On explorer mode, dragging a thumbnail over a folder on the same drive doesn't make a move operation, but a copy. The icon on the mouse arrow still shows the move (arrow) instead of the copy (plus sign), but it does copy. Installing 0.79 makes it work...