Search found 303 matches

by CameronD
Sun Jul 23, 2017 2:18 am
Forum: MP - General Support
Topic: Copy/backup catalog info by folder
Replies: 5
Views: 889

Re: Copy/backup catalog info by folder

You can (and I strongly recommend) writing the ratings metadata to the image file (or a sidecar according to your preference). (See Settings->metadata). That way, you can reconstruct your DB should it every become lost/corrupted. As far as I know you would need to manipulate the database file yourse...
by CameronD
Sun Jul 23, 2017 2:11 am
Forum: MP - General Support
Topic: Copy/Move to
Replies: 5
Views: 445

Re: Copy/Move to

The only thing would be how a Folder/Directory is defined. It applies to whatever is selected: zero or more folders plus zero or more files. I suspect that applying it to selected items is why the Windows explorer has it under edit. However, windows explorer is also inconsistent because delete and ...
by CameronD
Sun Jul 23, 2017 1:59 am
Forum: MP - General Support
Topic: Copy/Move to
Replies: 5
Views: 445

Re: Copy/Move to

Currently these entries are in 'Edit' menu, some users ask for 'File' which seems more logical What do you think? That refers to browser - for an image window these options appear under File , and in that context it makes more sense that way than under Edit . For the browser window it seems to me t...
by CameronD
Mon Jul 10, 2017 2:50 pm
Forum: Closed/Resolved
Topic: 0.84: Thumbnail of large images are dark
Replies: 10
Views: 582

Re: 0.84: Thumbnail of large images are dark

Version 0.87 beta 1 - all my test thumbnails now look like they should (after waiting for them all to be rebuilt!). However , the 4-in-one folder thumbnails still have the problem. This is even if I visit the lower folder first, allow the correct thumbnails to be cached and then visit the folder abo...
by CameronD
Mon Jul 10, 2017 2:24 pm
Forum: Closed/Resolved
Topic: 0.84: Manual refresh doesn't refresh folder tree
Replies: 4
Views: 483

Re: 0.84: Manual refresh doesn't refresh folder tree

working very well now, even network mapped drives where windows explorer sometimes had trouble.
by CameronD
Mon Jul 10, 2017 2:16 pm
Forum: Closed/Resolved
Topic: 0.84: Database search progress not indicated
Replies: 4
Views: 562

Re: 0.84: Database search progress not indicated

confirm problem is fixed in 0.87 beta 1.
Thank you :D
by CameronD
Mon Jun 19, 2017 2:12 pm
Forum: New
Topic: 0.84 and 0.85b2 - list details vanish on restart
Replies: 16
Views: 1428

Re: 0.84 and 0.85b2 - list details vanish on restart

xnview wrote:so it's always after an IPTC editing?
yes.

From looking at how the DB behaves, I guess it might also happen if other software changes metadata between stopping and restarting xnviewmp.
by CameronD
Mon Jun 19, 2017 9:40 am
Forum: New
Topic: 0.84 and 0.85b2 - list details vanish on restart
Replies: 16
Views: 1428

Re: 0.84 and 0.85b2 - list details vanish on restart

update: I started with a blank DB and stepped through the process, saving the db each stage. The problem seems to be that when the large block of captions is written to, the IPTC/XMP data is updated in the file, but the metadata in the DB is not. When I restart XnviewMP it scans the modified files a...
by CameronD
Mon Jun 19, 2017 9:08 am
Forum: New
Topic: 0.84 and 0.85b2 - list details vanish on restart
Replies: 16
Views: 1428

Re: 0.84 and 0.85b2 - list details vanish on restart

Hello Pierre, I can still reproduce on 0.86, x64 on Windows 7. Sometimes ! I have done some experimenting and it seems to be reproducible under the following conditions. I have a folder with 160 jpeg images. Select a number of files, more than 10 is needed - 14 or 15 seems to make it fairly reliable...
by CameronD
Tue Mar 28, 2017 10:47 pm
Forum: New
Topic: 0.84: Very slow startup on Win7 x64
Replies: 7
Views: 826

Re: 0.84: Very slow startup on Win7 x64

In my case, it seems to be MsMpEng.exe (part of the MS antimalware service) that is chewing up all the cpu. Slow startup time is around 35 seconds :!: At a guess, it might be related to the fact that my test install is not under "Program Files", so the scanner assumes less, or it might be some weird...
by CameronD
Mon Mar 27, 2017 3:05 pm
Forum: New
Topic: 0.84: UI panels % size not consistent
Replies: 4
Views: 315

Re: 0.84: UI panels % size not consistent

I use a layout with folder list on left, image file listing in the middle and categories list on the right. Both the folder and the categories list are each about 10% of full screen width. As I narrow it, the folder and categories list panes stay the same number of pixels wide, while the file listin...
by CameronD
Mon Mar 27, 2017 2:52 pm
Forum: New
Topic: 0.84: Very slow startup on Win7 x64
Replies: 7
Views: 826

Re: 0.84: Very slow startup on Win7 x64

This may or may not be related, but I have been noticing some very slow startup with 0.85b2. I do not see any problem with v0.84, but v0.85b2 seem to take more like 20 seconds to fire up occasionally . As far as I can tell, it happens the first time after I resume from hibernation, and sometimes aft...
by CameronD
Sun Mar 26, 2017 11:42 am
Forum: Closed/Resolved
Topic: 0.84: IPTC window: Wrong workflow with multi-selection
Replies: 41
Views: 5313

Re: 0.84: IPTC window: Wrong workflow with multi-selection

xnview wrote:so which label?
My preference would be
  1. Apply to current Image
  2. Apply to all Images
  3. Cancel,
but whether it says "File" or "Image" I have no strong opinion.


What do others think?
by CameronD
Sun Mar 26, 2017 9:16 am
Forum: New
Topic: 0.84 and 0.85b2 - list details vanish on restart
Replies: 16
Views: 1428

Re: 0.84 and 0.85b2 - list details vanish on restart

...Is it "Details" view or "Thumbnails+Details" view? Details - one line per file- see screenshots. I have 4 installations of xnviewMP, all 64-bit, each with their own ini file, db, etc 0.84 dark theme (normal working version) 0.84 test - default theme 0.85 beta 1 0.85 beta 2 All show the bug. Even...
by CameronD
Sat Mar 25, 2017 1:27 pm
Forum: New
Topic: 0.84 and 0.85b2 - list details vanish on restart
Replies: 16
Views: 1428

Re: 0.84 ans 0.85b2 - list details vanish on restart

Works for me... - same specs as you. (Sorted by ShutterSpeed.) Hmm, obviously depends on something else as well. :? Not worth putting much effort into, as it's a simple enough step to make it display properly. For one last test, try enabling all columns and retest. In my case, the initial list appe...