Sorting: EXIF metadata (Aperture, Shutterspeed, Focallength)

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Sorting: EXIF metadata (Aperture, Shutterspeed, Focallength)

Post by PP0815 » Thu Apr 02, 2015 10:54 pm

WinXP, XNView 0.72

I sometimes like to sort the photos by increasing or decreasing EXIF metadata like shutterspeed or focal length but the sorting doesn't work as it should (IMO :))
For example: a picture with the focal length of 18mm will get sorted between 179 and 181 and or for shutter speed: the slow shutterspeed of 1/8s is right after the fast 1/799s while it should be between 1/7s and 1/9s.
I guess the sorting need to add a few zeros so 1/8 is interpreted as 1/0008 or 18mm = 0018mm but it shouldn't display these 0 numbers.

Thanks

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Fri Apr 03, 2015 7:02 am

i can't reproduce, dou you have some samples when sort is not good?
Pierre.

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by PP0815 » Tue Apr 07, 2015 5:27 pm

Sorry for the delay.
Here are two examples.

shutter speed 1/10 is much slower than 1/1024. 1/12, 1/128 etc are still slower but are sorted after the 1/1024 so the sorting is wrong.
Same goes for the pic of the focal length sorting

thanks
Attachments
Focal Length.png
Shutter Speed.png

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Sat Apr 18, 2015 1:32 am

See Issue 641 for current status and details.
Pierre.

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by PP0815 » Thu Jun 11, 2015 10:06 pm

issue is still there...well not like before but the 0.75beta and the new 0.75beta from today (11.06) both doesn't show any EXIF data columns after "ISO" (next in line would be shutter-speed BTW)

again thanks for your work

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Fri Jun 12, 2015 9:16 am

PP0815 wrote:issue is still there...well not like before but the 0.75beta and the new 0.75beta from today (11.06) both doesn't show any EXIF data columns after "ISO" (next in line would be shutter-speed BTW)
the sort doesn't work??
Pierre.

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by PP0815 » Fri Jun 12, 2015 2:55 pm

I can't test the sorting of shutterspeed or aperture cause the view mode "detailed" in the browser doesn't show anything after the ISO column (although it is set to show ALL columns).

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Tue Jun 23, 2015 9:02 am

PP0815 wrote:I can't test the sorting of shutterspeed or aperture cause the view mode "detailed" in the browser doesn't show anything after the ISO column (although it is set to show ALL columns).
but in your screenshots you had these columns???
Pierre.

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by PP0815 » Tue Jun 23, 2015 11:21 pm

Yes cause the screenshots were made with version 0.72. The post about the missing columns is about the 0.75betas

so again:
0.72 = wrong sorting (columns are visible)
0.75beta = columns after ISO not visible

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Thu Jun 25, 2015 12:17 pm

PP0815 wrote:Yes cause the screenshots were made with version 0.72. The post about the missing columns is about the 0.75betas

so again:
0.72 = wrong sorting (columns are visible)
0.75beta = columns after ISO not visible
Strange, i have no problem, could you try to remove headers line in [Browser] section of xnview.ini?
Pierre.

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by PP0815 » Thu Jun 25, 2015 7:32 pm

I did as you said and erased the line on xnview.ini on 0.75beta and......

NICE!

1. All columns are there again
2. Focal Length and aperture is now in a correct order.
:D

but the shutterspeed is still not ordered correct.

Thank you so far!!

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Fri Jun 26, 2015 7:19 am

PP0815 wrote: but the shutterspeed is still not ordered correct.
it works for me, please send photos for which the sorting doesn't work?
Pierre.

PP0815
Posts: 26
Joined: Wed Mar 26, 2014 10:47 am

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by PP0815 » Fri Jun 26, 2015 1:01 pm

Here are a few. The shutterspeeds are 1sec, 1/5th, 1/10th and 1/100th (yes the pics are completly black to save upload time).

EDIT: I just realized by checking EXIF data from random other cameras (net downloads) that Shutter speed and Exposure time are exactly the same on some cameras but on other cameras they're not. My Canon 100D has small differences between shutter speed and exposure time (for example my 1/100th of a second exposure time picture has shutter speed 1/99) while Canon D60 and 300D seem to have same values for shutter and exposure. BTW I'm more interested in the exposure time value than in shutter speed so adding a column for exposure would be really nice (Do I have to make an extra thread in the suggestion subforum?)

Well, no matter the terms, the sorting is still not in correct de-/increasing order I added two more pics to make it more clear. shutterspeeds are 1/1328 (exposure 1/1250) and 1/166 (exposure 1/160).
If you place all pics in a folder the order should be

1 sec
1/5
1/10
1/99
1/166
1/1328

the order I get with 0.75beta is

1 sec
1/10
1/1328
1/166
1/5
1/99
Attachments
1328th of a sec.JPG
166th of a sec.JPG
100th of a sec.JPG
10th of a sec.JPG
5th of a sec.JPG
1 sec.JPG

User avatar
xnview
Author of XnView
Posts: 32251
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by xnview » Sat Jun 27, 2015 2:09 am

ok, right, i'll fix it
Pierre.

User avatar
helmut
Posts: 8176
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Sorting: EXIF metadata (Apature, Shutterspeed, Focalleng

Post by helmut » Thu Mar 02, 2017 7:55 pm

The black images are a good idea, PP0815. Sorting works fine for me in v0.84.

A minor issue is left:
From what I can see the sort order ascending/descending is wrong: When sorting ascending, list should start with shortest shutter speed and end with longest shutter speed.

Could some one else please check and confirm?

Post Reply