Exif mod. date shown as "date taken" in the browser

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
jms
Posts: 15
Joined: Thu Aug 18, 2016 3:02 pm

Exif mod. date shown as "date taken" in the browser

Post by jms » Wed Oct 26, 2016 6:30 pm

I have some pictures with an exif date modified of 18.8.2016 and date taken of 20.2.2016.
But in the browser, XnView shows in the tooltip 18.8. as the date taken and if I sort by exif date, it sort by that modified date and not by date taken.

User avatar
xnview
Author of XnView
Posts: 33485
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Exif mod. date shown as "date taken" in the browser

Post by xnview » Fri Oct 28, 2016 11:40 am

please send a file sample?
Pierre.

jms
Posts: 15
Joined: Thu Aug 18, 2016 3:02 pm

Re: Exif mod. date shown as "date taken" in the browser

Post by jms » Fri Oct 28, 2016 12:22 pm

I already found your answer in http://newsgroup.xnview.com/viewtopic.p ... 75&p=46930
by xnview » Mon Mar 19, 2007 8:44 am
Ok, it's normal, the date used for sort is 'EXIF: date modified'
So it is sorting by <date modified> by design.
I was assuming it sorts by date taken.
But the mouse-over tooltip should be changed. It says the date is {Date taken} but this is wrong.

I cannot upload a sample because I'm limited to 2MB and it only makes sense if I upload the original image.

User avatar
helmut
Posts: 8214
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Exif mod. date shown as "date taken" in the browser

Post by helmut » Sun Feb 19, 2017 2:53 pm

jms wrote:... So it is sorting by <date modified> by design.
Correct.
jms wrote:... But the mouse-over tooltip should be changed. It says the date is {Date taken} but this is wrong.
helmut wrote:By default, XnView 0.83 and before uses the following entry for tooltips:
"<b>{Filename}</b><br>{Modified Date} - {Date taken}<br>{Size KB} Kib"

The placeholder {Date taken} for EXIF date taken is wrong, correct is {EXIF:Date taken}. In XnView 0.84 the default is correct, when updating and using your .ini files please check in Tools » Settings | Browser | Browser whether the tooltip is set properly.
From what I can see the original "problem" is solved. Please post here if this should not be the case.

:arrow: Closed

jms
Posts: 15
Joined: Thu Aug 18, 2016 3:02 pm

Re: Exif mod. date shown as "date taken" in the browser

Post by jms » Sun Feb 19, 2017 4:23 pm

When saving a picture in linux, the modification date is not updated.

User avatar
helmut
Posts: 8214
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Exif mod. date shown as "date taken" in the browser

Post by helmut » Sun Feb 19, 2017 4:51 pm

Thank you for your prompt reply, jms.
jms wrote:When saving a picture in linux, the modification date is not updated.
O.k., that's a different problem. Could you please create a new bug report for it?

jms
Posts: 15
Joined: Thu Aug 18, 2016 3:02 pm

Re: Exif mod. date shown as "date taken" in the browser

Post by jms » Sun Feb 19, 2017 5:47 pm

I just found the setting "tools-settings-general-file operations-keep orignal file date/time".
The default was to keep the original date.

User avatar
helmut
Posts: 8214
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Exif mod. date shown as "date taken" in the browser

Post by helmut » Sun Feb 19, 2017 6:34 pm

jms wrote:I just found the setting "tools-settings-general-file operations-keep orignal file date/time".
The default was to keep the original date.
Good that you've found the solution and thank you for posting it here, jms. :)

Post Reply