XnView stopped playing multimedia files

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
csecu
Posts: 3
Joined: Mon Aug 26, 2019 1:26 pm

XnView stopped playing multimedia files

Post by csecu » Mon Aug 26, 2019 10:34 pm

Up until a week or two ago, XnView played all my multimedia files. Now it won't play any.

I first noticed this when a slideshow I was playing, that included multimedia files, stopped playing the multimedia files one day. It still played the audio track, but quit showing the video.

The following 4 screenshots are captures of the XnView window during various operations.

In this screenshot, I have selected a very small AVI file. In the preview pane, it appears to be playing, and the sound is audible, but there is no picture:

Image


This screenshot shows the same video file, with the Properties tab selected:

Image


This screenshot shows the same video file with the Preview tab selected again. Note that it retains the image from the Properties tab in the area where the video would have been playing:

Image


Now, there is one way I can get XnView to display this video. If I select TOOLS -> OPEN, the video actually plays, like this:

Image


It isn't just AVI files; XnView no longer plays (outside of that one command) any multimedia format; I've tried MKV, MP4, MPG, and WMV files. None play, in either preview mode or in a slideshow, like they used to.

While researching a possible fix for this, I read a recommendation to put ffmpeg in the path. I have done this, but no joy.

The only thing I can think of is that something in one of Windows most recent updates broke this, but I am not tech savvy enough to figure out how to fix it if that is the case.

I'm running a Core I7-7700 with 16GB RAM and a GTX 1080 Ti on Windows 10. I have the very latest Windows updates, the latest graphics drivers and the latest version of XnView installed.

User avatar
xnview
Author of XnView
Posts: 31489
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView stopped playing multimedia files

Post by xnview » Tue Aug 27, 2019 12:36 pm

csecu wrote:
Mon Aug 26, 2019 10:34 pm
Up until a week or two ago, XnView played all my multimedia files. Now it won't play any.
Do you have made changes on your system?
So, you have the problem only in preview from browser? Even if you resize the window?
Pierre.

csecu
Posts: 3
Joined: Mon Aug 26, 2019 1:26 pm

Re: XnView stopped playing multimedia files

Post by csecu » Tue Aug 27, 2019 3:08 pm

xnview wrote:
Tue Aug 27, 2019 12:36 pm
csecu wrote:
Mon Aug 26, 2019 10:34 pm
Up until a week or two ago, XnView played all my multimedia files. Now it won't play any.
Do you have made changes on your system?
So, you have the problem only in preview from browser? Even if you resize the window?
I made no graphics settings changes on my system that I can think of. I disabled the Windows Game Bar to keep from popping up dialog boxes when I started a game, but that was weeks before this started happening.

The problem is in Preview in the browser, in playing multimedia files in slldeshows, and also when I double-click the file in Preview mode. Resizing the window has no effect. When I double-click the file in the browser mode, the video doesn't play and the background shows through, which looks like this:

Image


UPDATE: I have been unable to reproduce the background showing through when I double click on a file in the browser mode. Every multimedia file I have tried now seems to play normally when I double-click on it. I made no system changes; I just decided to try another file type. When it played, I tried all of them again.

However, still no multimedia files play in preview mode, nor in slideshows.

User avatar
xnview
Author of XnView
Posts: 31489
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView stopped playing multimedia files

Post by xnview » Wed Aug 28, 2019 2:58 pm

do you use Klite codec pack?
Pierre.

csecu
Posts: 3
Joined: Mon Aug 26, 2019 1:26 pm

Re: XnView stopped playing multimedia files

Post by csecu » Wed Aug 28, 2019 3:55 pm

xnview wrote:
Wed Aug 28, 2019 2:58 pm
do you use Klite codec pack?
No.

User avatar
xnview
Author of XnView
Posts: 31489
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView stopped playing multimedia files

Post by xnview » Thu Aug 29, 2019 4:58 pm

you can try to install it
Pierre.

Post Reply