Wmp Plugin bug

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
BlueDrop
Posts: 16
Joined: Wed Mar 12, 2008 5:05 pm

Wmp Plugin bug

Post by BlueDrop » Wed Mar 12, 2008 5:11 pm

Hello to all,
I want to refer a bug that has "wmp" plugin.
When I try to open a folder with this type of images, xnview open the folder but, after processing for some seconds (4-5s) it crash!
This happen only with wmp plugin: is there a solution?
Thanks. Regards.
Last edited by BlueDrop on Mon Aug 08, 2011 1:27 pm, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 32758
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Wmp Plugin bug

Post by xnview » Wed Mar 12, 2008 5:34 pm

DarkBDBB wrote:Hello to all,
I want to refer a bug that has "wmp" plugin.
When I try to open a folder with this type of images, xnview open the folder but, after processing for some seconds (4-5s) it crash!
This happen only with wmp plugin: is there a solution?
Thanks. Good-Bye.
Could you send some samples?
Pierre.

User avatar
BlueDrop
Posts: 16
Joined: Wed Mar 12, 2008 5:05 pm

Post by BlueDrop » Wed Mar 12, 2008 5:41 pm

Instead, can you post some wmp standard images?
As images, I only convert jpg image to wmp image through xnview...
And, do you know that in properties of files, is not displayed the compression ratio?
Bye.

User avatar
BlueDrop
Posts: 16
Joined: Wed Mar 12, 2008 5:05 pm

Post by BlueDrop » Wed Mar 12, 2008 6:36 pm


ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Thu Mar 13, 2008 1:04 am

XnView 1.93 beta 3 crashes when I try to open the Properties for this file.
Windows 10 Pro x64 1909
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Works, but---

Post by Clo » Thu Mar 13, 2008 1:52 am

:arrow: ckit

:) Hello !

• It works here, no crash when I ask for «Properties» (local menu), but :
1. It must be displayed as 1:1 scale, or else there is a “grid” of coloured artifacts i.e. as reduced to fit the window.
2. I use old DLLs- There is almost no plugin DLL in the ZIP pack of 1.93-ß3.
- Here : <Xwmp.dll> 304 KiB - July-12-2006

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Thu Mar 13, 2008 4:28 am

ckit wrote:XnView 1.93 beta 3 crashes when I try to open the Properties for this file.
This is NOT an OS type bug, I can reproduce it on both Win2000 Pro SP4 and WinXP Pro SP2.
Windows 10 Pro x64 1909
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

No crash still

Post by Clo » Thu Mar 13, 2008 7:48 am

:arrow: ckit

:) Hello !

• Here XP-Pro SP1

- I started the file in the browser, asked for Properties from the tab : OK.
- In "View", like said above, OK.

- However : That's a strange image ! It can be viewed properly only when it's shown at a round part of the size,
let's say : 1:1, ½, ¼… as well in View as in the preview. The colours are different according to the scale !
- Of course, the thumb nail (that isn't in a round fraction) is reduced as a pulp of culours…
… but no crash !

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32758
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Mar 13, 2008 8:27 am

ckit wrote:XnView 1.93 beta 3 crashes when I try to open the Properties for this file.
Ok, i have the crash with property dialog, but not by viewing or browsing it
Pierre.

User avatar
BlueDrop
Posts: 16
Joined: Wed Mar 12, 2008 5:05 pm

Post by BlueDrop » Thu Mar 13, 2008 4:48 pm

When I speak about "properties", I mean the tab near "preview".
In version before I could see also "quality" of image, but not with this version.

I don't know why crash, but it continue to happen...
The crash arrive when I view a folder with inside a "wmp" file.
I tried to remove the plugin from xnview, and it does not happen...
Bye.
P.S. I'm italian, so is difficult for me to describe the error...
P.P.S. Here the archive with image and error text.

User avatar
BlueDrop
Posts: 16
Joined: Wed Mar 12, 2008 5:05 pm

Post by BlueDrop » Thu Mar 13, 2008 8:49 pm

Found the bug!!!!!!!
If you select "View" -> "View as" -> "Icons" the bug can be reproduced!
If you select "Thumbnails", xnview does not crash!
Fix it!
Bye.
P.S. I'm the only one who discovered this bug...Hmmm...

ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Fri Mar 14, 2008 3:07 am

xnview wrote:
ckit wrote:XnView 1.93 beta 3 crashes when I try to open the Properties for this file.
Ok, i have the crash with property dialog, but not by viewing or browsing it
Fixed in XnView 1.93 final.
Windows 10 Pro x64 1909
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
BlueDrop
Posts: 16
Joined: Wed Mar 12, 2008 5:05 pm

Post by BlueDrop » Sun Mar 16, 2008 1:22 pm

Have you fixed the bug I referred?
Bye.

Post Reply