Thumbnail Label time is incorrect

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
JStockton
Posts: 7
Joined: Fri Dec 19, 2014 7:14 pm

Thumbnail Label time is incorrect

Post by JStockton »

Using v2.32...

I retimestamp all my JPG photos after I edit them to match the EXIF timestamp

But I have noticed that the Thumbnail label "File Modified Date" is always off by - 1 hour exactly

Here is actual file with EXIF and MODIFIED time stamps of Jan 1, 2014 1:13 pm
Actual JPG
Actual JPG
Now here is screen PIC trhat shows modified time stamp
Timestamp as on PC
Timestamp as on PC
An here is what XnView shows for thumbnail label--off by an hour
XnView's INCORRECT time in label
XnView's INCORRECT time in label
My OPTIONS settings
My OPTIONS settings
User avatar
XnTriq
Moderator & Librarian
Posts: 5618
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Thumbnail Label time is incorrect

Post by XnTriq »

There have been changes regarding daylight saving time in v2.25 + v2.30, and this bug was supposed to be fixed. :-|
Which version(s) of Windows are you running?
XnTriq ([url=http://newsgroup.xnview.com/viewtopic.php?p=123828#p123828]Change timestamp is off one hour[/url]) wrote:
I've come to believe that the problem depends on whether or not Automatically adjust clock for daylight saving changes (Contol Panel » Date and Time » Time Zone) is activated.
BTW: I found the following settings helpful for testing:
[color=green][u]T[/u]ools[/color] » [color=green][u]O[/u]ptions...[/color] » [color=green]Browser[/color] » [color=green]Browser[/color] » [color=green]Show tooltips[/color] wrote:

Code: Select all

Modified: <Modified Date [a d/b/Y H:M:S]>
   Taken: <Date Taken [a d/b/Y H:M:S]>
Digitized: <Date Digitized [a d/b/Y H:M:S]>
JStockton
Posts: 7
Joined: Fri Dec 19, 2014 7:14 pm

Re: Thumbnail Label time is incorrect

Post by JStockton »

I am using Win XP Pro, SP3, with all Daylight time fixes installed. My system is all normal and up to date as far as XP is concerned, and it is only XnView that is the problem--I have no other issue with other JPG viewing programs I use.

Hey, the timestamp you see in Explorer should be the timestamp you see in your label--period. Right?
Post Reply