[Subsidiary] Custom colours are lost…

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

[Subsidiary] Custom colours are lost…

Post by Clo »

:arrow: Pierre & All

:) Hello !

- From the Options, set any custom colour in the Win-palette, let's say for the «View» window background…
- Close the options…
- Come back to the same colour choice, call the palette : your customized colour has gone :(

- Although it's a usual behaviour of Win 9x, it's possible to improve this in the program, since it's done in another viewer. Below, a piece of codes which is used in this viewer (from its author himself, and free to use) :

Image

- It should be great to keep the customized colours, this'ld avoid me to yell when bound to reset the same colours endlessly… :P

:mrgreen: Kind regards,
Claude
Clo
Last edited by Clo on Mon Oct 16, 2006 12:37 am, edited 1 time in total.
Old user ON SELECTIVE STRIKE till further notice
User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique

Post by ouistiti »

2 Clo
Same behaviour here with an "XP" machine... :(
Friendly
Paul
L'important n'est pas de convaincre, mais de donner à réfléchir.
The important thing is not to convince, but to incite to think.

1,77245385090552...
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [Subsidiary] Custom colours are lost…

Post by xnview »

Clo wrote::arrow: Pierre & All

:) Hello !

- From the Options, set any custom colour in the Win-palette, let's say for the «View» window background…
- Close the options…
- Come back to the same colour choice, call the palette : your customized colour has gone :(

- Although it's a usual behaviour of Win 9x, it's possible to improve this in the program, since it's done in another viewer. Below, a piece of codes which is used in this viewer (from its author himself, and free to use) :
Yes, right. Currently customized colors are not saved...
Pierre.
User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique

Post by ouistiti »

2 Pierre
Do you think that could be fixed in a future version? It's really irritating… This works fine in Uniview under XP, like you can see below :

Image

I guess it's this program that Clo is talking about ?

Friendly

Paul
L'important n'est pas de convaincre, mais de donner à réfléchir.
The important thing is not to convince, but to incite to think.

1,77245385090552...
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Palette still…

Post by Clo »

:arrow: Ouistiti

:) Hello Paul!

- Indeed, it's in Uniview… Not a competitor really, since designed for freeware personal use only, and too because the program development is pending (the author has his university studies to end…).
- Below, the palette I get under Win 98 SE in that program:

————Image

- This is got as well for the Options (background colours…) as for the painting retouch-features, where it's more important… ;)

:mrgreen: Friendly regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice