RC4: Missing elipsis in "View in Hex mode"

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

RC4: Missing elipsis in "View in Hex mode"

Post by helmut » Thu Jun 02, 2005 7:44 pm

In Browser, the menu says File > View in hex mode
Instead, it should say "View in Hex mode..." (notice the case and elipsis "...").
Last edited by helmut on Tue Jun 07, 2005 12:11 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 32758
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC4: Missing elipsis

Post by xnview » Thu Jun 02, 2005 7:55 pm

helmut wrote:In Browser, the menu says File > View in hex mode
Instead, it should say "View in Hex mode..." (notice the case and elipsis "...").
Ok
Pierre.

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Mon Jun 06, 2005 11:22 pm

In RC5 the elipsis has been fixed but not the case.

kaptainkory
Posts: 41
Joined: Mon May 23, 2005 4:59 am

Post by kaptainkory » Tue Jun 07, 2005 2:10 am

Doesn't an elipsis imply that a dialogue box will open? In this case, no dialogue box is opened, so I don't understand the need for the elipsis. Please explain.

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Jun 07, 2005 4:56 pm

kaptainkory wrote:Doesn't an elipsis imply that a dialogue box will open? In this case, no dialogue box is opened, so I don't understand the need for the elipsis. Please explain.
Correct. There's various spots for "View in Hex mode". In "File > View in Hex mode" a dialog is opened to choose a specific file, so an elipsis should be used here.

kaptainkory
Posts: 41
Joined: Mon May 23, 2005 4:59 am

Post by kaptainkory » Tue Jun 07, 2005 5:08 pm

Aha, but when selecting an image in Browser and then opening a context menu, it should only be "View in Hex mode" (no elipsis) since no dialogue is opened. Right? Hmm.

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Jun 07, 2005 5:10 pm

kaptainkory wrote:Aha, but when selecting an image in Browser and then opening a context menu, it should only be "View in Hex mode" (no elipsis) since no dialogue is opened. Right? Hmm.
Right. This way the user will know.

kaptainkory
Posts: 41
Joined: Mon May 23, 2005 4:59 am

Post by kaptainkory » Tue Jun 07, 2005 5:12 pm

Well, right now the context menu says "View in hex mode...". Has this been listed as a bug elsewhere? I can't remember.

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Jun 07, 2005 5:21 pm

kaptainkory wrote:Well, right now the context menu says "View in hex mode...". Has this been listed as a bug elsewhere? I can't remember.
Perhaps there's one string constant only and fixing at one location made the other one wrong. Moved back to "New/Open".

kaptainkory
Posts: 41
Joined: Mon May 23, 2005 4:59 am

Post by kaptainkory » Fri Jun 10, 2005 3:48 pm

In RC6,

Context Menu = "View in Hex mode" (CORRECT)
File -> "View in Hex mode" (INCORRECT...should say "View in Hex mode..."

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Fri Jun 10, 2005 6:52 pm

Moved back to "New/Open".

User avatar
helmut
Posts: 8192
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Jun 15, 2005 11:00 pm

Verified fixed in RC7.

Locked