b2: *.PPS doesn't work in ß2

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

b2: *.PPS doesn't work in ß2

Post by Clo » Tue Dec 20, 2005 2:55 am

:) Hello !

- The PPS file type is not recognized in the 1.84 ß-2. I get the ususal hellish message.

- I added PPS in the "Custom" field of "Files displayed", same.
- As thumb-nail, I get only the icon of the type, and no display in any mode, still the message :(

- Indeed, it works in 1.80.3

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Aokromes
Posts: 204
Joined: Wed Oct 22, 2003 3:40 am
Location: Vitoria-Gasteiz Beyond Stargate Network ;)

Post by Aokromes » Tue Dec 20, 2005 11:43 am

It's quite strange, for me it works fine, i have tryed with: http://www.powerpoints.org/pop.php?pps=humor307 and others without trouble.

Image

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: b2: *.PPS doesn't work in ß2

Post by xnview » Tue Dec 20, 2005 3:36 pm

Clo wrote::) Hello !

- The PPS file type is not recognized in the 1.84 ß-2. I get the ususal hellish message.

- I added PPS in the "Custom" field of "Files displayed", same.
- As thumb-nail, I get only the icon of the type, and no display in any mode, still the message :(

- Indeed, it works in 1.80.3
not recognized means not shown in thumbnail view??
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Doesn't work at all

Post by Clo » Tue Dec 20, 2005 8:04 pm

:) Hello !

- I mean : it is not displayed in view, and I have the file-type icon in the board of thumb-nails.

- It doesn't work at all, I have the message " The file xyz.pps has a format which can be defined" or so.
- Same trying to open from any way:
¤ click on the thumb-nail —> Message
¤ open from the tool-bar —> Message
¤ open from the menu —> Message
¤ Drag & Drop in Total Commander on the icon —> Message

:(

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Doesn't work at all

Post by xnview » Wed Dec 21, 2005 10:38 am

Clo wrote::) Hello !

- I mean : it is not displayed in view, and I have the file-type icon in the board of thumb-nails.

- It doesn't work at all, I have the message " The file xyz.pps has a format which can be defined" or so.
- Same trying to open from any way:
¤ click on the thumb-nail —> Message
¤ open from the tool-bar —> Message
¤ open from the menu —> Message
¤ Drag & Drop in Total Commander on the icon —> Message
Do you have options/Startup/Use all formats?
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Why 2 conflictual ways ?

Post by Clo » Wed Dec 21, 2005 2:21 pm

:) Hello !

- It's the point ! It works if I tick that box, but there is an inconsistency there :

- If you state such a format in "Displayed files", it might be displayed anyway in all modes.

- Features and options applied differently to various display modes are confusing.

:mrgreen: K R
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Why 2 conflictual ways ?

Post by xnview » Thu Dec 22, 2005 12:06 pm

Clo wrote::) Hello !

- It's the point ! It works if I tick that box, but there is an inconsistency there :

- If you state such a format in "Displayed files", it might be displayed anyway in all modes.

- Features and options applied differently to various display modes are confusing.
No this option initialize my base library with all formats available or not
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Fire it !

Post by Clo » Fri Dec 23, 2005 4:36 am

:) Hello Pierre !
No this option initialize my base library with all formats available or not
- Hence, it might be enabled by default… and even be removed as an option (set enabled in the code), only usable as an extra-INI entry to disable it in some special cases, I guess…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Fire it !

Post by xnview » Fri Dec 23, 2005 7:41 am

Clo wrote::) Hello Pierre !
No this option initialize my base library with all formats available or not
- Hence, it might be enabled by default… and even be removed as an option (set enabled in the code), only usable as an extra-INI entry to disable it in some special cases, I guess…
No, not enabled by default, because many users don't want to use all formats.
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Î Back above !

Post by Clo » Fri Dec 23, 2005 7:51 am

:) Hi again!
No, not enabled by default, because many users don't want to use all formats.
- So, back to above !!! If one doesn't want all formats, the ones stated -like I did- MUST work, and they don't !

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh » Fri Dec 23, 2005 8:34 am

What about 'Include box' for file types and 'Exclude box' for files displayed?
Cheers,
Bruce

Guest

Post by Guest » Fri Dec 23, 2005 9:14 am

b2, deleted ini.
PPS files are displayed as icons (OK), double click displays file in PowerPoint (OK), so no confirmation here.

Clo, if you still think there is problem, make a diff of ini files- clean and the one with which there is problem?

X.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Or like…

Post by Clo » Sat Dec 24, 2005 5:03 pm

:arrow: marsh

:) Hello B. !
- First, I wish you a Merry X-Mas !

¤ This could be treated as well like in the last § of that thread :wink:
¤ Use all formats disabled by default sounds illogical for me, and I'm pretty sure that many users will fall in the trap !

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Tue Dec 27, 2005 11:46 am

Seems no real problem to fix here. Move to Closed.

X.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Tue Dec 27, 2005 11:28 pm

Xyzzy wrote:Seems no real problem to fix here. Move to Closed.

X.
Clo, agree?

Locked