Copier/Coller de XnView vers une appli : ne marche plus [RE]

Questions générales en Français

Moderators: XnTriq, xnview

User avatar
Piteur
Posts: 339
Joined: Sun Mar 06, 2005 2:43 pm
Location: Europe

Re: Pas pour moi…

Post by Piteur »

Clo wrote:Toutefois, elle ne l'est pas complètement pour moi car j'utilise très peu le clavier (mains endommagées) et j'aimerais avoir des commandes stables pour des boutons, comme dit auparavant…
Ah, je comprends mieux votre insistance pour obtenir des boutons ! Moi qui n'en utilise presqu'aucun, les raccourcis-clavier me sont indispensables... :wink:
VERSEAU44
Posts: 9
Joined: Wed Oct 28, 2015 4:14 pm

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by VERSEAU44 »

Bonjour,

Je "déterre" ce POST car en basculant de XnView à XnViewMP (version 0.76.1 en 64 bit), j'ai voulu copier une image de XnView vers WinWord 2007 et là, msg d'erreur : "impossible d'obtenir les données pour la liaison clipboard 1" !

Après 10mn de recherche, je me rends compte que :
. XnViewMP copie l'image + son adresse et que le Presse-papier Office le voit comme un fichier (Cf. "Files" mis en surbrillance en ouvrant le menu "coller spécial" de WinWord)
. je peux faire un coller spécial et sélectionner "image indépendante du périphérique (DIB)" ... fastidieux
. le CTRL+V fonctionne sous WinWord si je fais plutôt un CTRL+SHIFT+C sous XnViewMP (mais change les habitudes de ma "petite" famille où nous sommes 7 quand-même)
. je peux configurer XnViewMP pour inverser les raccourcis clavier : CTRL+C est finalement associé à "cmd_copyImage" et CTRL+SHIFT+C, à "cmd_copyFile"

Hé bien ...non : cette dernière opération ne fonctionne pas :x
Malgré un reboot et la vérification que le CTRL+C est associé à "cmd_copyImage" dans les Paramètres, XnViewMP continue à me copier un "fichier" : il me faut toujours passer par le CTRL+SHIFT+C pour que le CTRL+V fonctionne sous WinWord.
D'ailleurs, en passant par le menu "Edition/Copier dans le presse-papier", XnViewMP m'indique "Données image" ... CTRL+SHIFT+C !!!

Après 15mn de multiples tentatives dans tous les sens ... je n'arrive pas à mes fins :o

MERCI pour votre aide !
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by xnview »

VERSEAU44 wrote: D'ailleurs, en passant par le menu "Edition/Copier dans le presse-papier", XnViewMP m'indique "Données image" ... CTRL+SHIFT+C !!!
Avec ça, le coller dans word fonctionne?
Pierre.
VERSEAU44
Posts: 9
Joined: Wed Oct 28, 2015 4:14 pm

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by VERSEAU44 »

Oui, impecc ...

Mais, Pierre, arrives-tu à reproduire mon pb de ne pouvoir correctement affecter les raccourcis clavier ?
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by xnview »

VERSEAU44 wrote:Oui, impecc ...

Mais, Pierre, arrives-tu à reproduire mon pb de ne pouvoir correctement affecter les raccourcis clavier ?
Non je change le racourci pour "copy" puis "copy image", et ça marche
Pierre.
VERSEAU44
Posts: 9
Joined: Wed Oct 28, 2015 4:14 pm

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by VERSEAU44 »

xnview wrote:Non je change le racourci pour "copy" puis "copy image", et ça marche
!?!?

Une piste pour essayer de résoudre le pb ?

PS : je suis sous Windows 7 Pro en multi-utilisateurs qui chacun utilise XnViewMP avec son propre configuration
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by xnview »

au niveau de la configuration, c'est bon pour les 2 raccourcis?
Pierre.
VERSEAU44
Posts: 9
Joined: Wed Oct 28, 2015 4:14 pm

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by VERSEAU44 »

Bonsoir Pierre !

Après 10mn de test, BCP de constats surprenants :
a) les 2 raccourcis sont bien correctement inversés et affichés comme tels en configuration MAIS "Edition/Copier dans le presse-papier/Données image" affiche toujours l'ancien raccourci (CTRL+MAJ+C) !
b) avec cette configuration, je sélectionne un bout d'image puis fais CTRL+C (donc normallement cmd_copyImage), bascule dans Word pour faire un CTRL+V : l'image entière se colle (pas la sélection), avec Nom de fichier et Chemin s'affichant dans le Presse-Papier !
c) je reviens dans XnViewMP et refais la même démarche mais avec CTRL+SHIFT+C : cette fois, c'est bien la sélection qui se colle (avec dans le Presse-Papier, ce bout d'image qui s'affiche)
d) dans Word, je copie vers le Presse-Papier ce que je viens de coller de XnViewMP : le Presse-Papier affiche bien ce que je copie. Je colle dans XnViewMP sans pb. Dans XnViewMP, je sélectionne ce que je viens de coller de Word et fais un CTRL+C : pb car le Presse-Papier affiche "ClipBoard 1" et affiche une erreur quand j'essaie de le coller dans Word.
e) même démarche que d) mais avec CTRL+CHIFT+C : le collage sous Word fonctionne mais la taille est environ 1.5 fois + grande que l'originale ...

MERCI pour tes éclaircissements !!!
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Copier/Coller de XnView vers une appli : ne marche plus

Post by xnview »

Bizarre, n'ayant pas word, j'ai fait le test avec LibreOffice, et cela marche correctement...
Pierre.