Affichage de Exif <User Comment>

Questions générales en Français

Moderators: XnTriq, xnview

Post Reply
Grasyop

Affichage de Exif <User Comment>

Post by Grasyop »

Bonjour,

J'ai un problème avec l'affichage des commentaires utilisateurs : certains s'affichent, d'autres non.

Il semble que les commentaires éliminés soient ceux contenant des caractères accentués.

S'agit-il d'un bug ?

D'avance, merci.

Grasyop
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Police !!!

Post by Clo »

:) Bonjour,

- Disons plutôt une lacune…

- Pierre doit modifier les infos EXIF sous peu pour les obtenir traduisibles et en fichier "Texte".
- Toutefois, actuellement ce n'est pas fait, et la police interne du programme (et de la DLL-FR) ne permet pas d'afficher tous les caractères…
- Par exemple, si vous avez un commentaire comme " Œufs de Pâques", vous aurez "Imageufs de Pâques" au mieux… Œ manque (œ aussi, 29 caractères en tout…)

:mrgreen: Cordialement,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 34681
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de Exif <User Comment>

Post by xnview »

Grasyop wrote:J'ai un problème avec l'affichage des commentaires utilisateurs : certains s'affichent, d'autres non.

Il semble que les commentaires éliminés soient ceux contenant des caractères accentués.

S'agit-il d'un bug ?
Pourriez vous m'envoyer un exemple de fichier?
Pierre.
Guest

Post by Guest »

Je viens de vous envoyer deux fichiers, sur l'adresse 'webmaster'.

Mais en fait, le problème vient peut-être de l'enregistrement de l'Exif, et pas de XnView...

Grasyop
User avatar
xnview
Author of XnView
Posts: 34681
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview »

Anonymous wrote:Je viens de vous envoyer deux fichiers, sur l'adresse 'webmaster'.

Mais en fait, le problème vient peut-être de l'enregistrement de l'Exif, et pas de XnView...

Grasyop
Désolé, je n'ia rien reçu???
Pierre.
Grasyop

Post by Grasyop »

J'ignore pourquoi vous n'avez pas reçu mon premier message, mais je viens de vous en envoyer un second, à la même adresse ( que j'ai vérifiée ).

Grasyop
User avatar
xnview
Author of XnView
Posts: 34681
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview »

Grasyop wrote:J'ignore pourquoi vous n'avez pas reçu mon premier message, mais je viens de vous en envoyer un second, à la même adresse ( que j'ai vérifiée ).
reçu merci
Pierre.
Grasyop

Exif <User Comment> et version 1.82 beta

Post by Grasyop »

Bonjour,

L'exif <User Comment> dans la version 1.82 beta :

- Dans Propriétés>Exif - User Comment, tous les commentaires semblent désormais apparaître correctement.

- Par contre, dans les vignettes ( explorateur ) ainsi que dans le diaporama, c'est moins bien qu'avant : les commentaires contenant un caractère accentué restent absents ; les autres commentaires sont remplacés par le sigle 'ASCII'.

Grasyop
User avatar
xnview
Author of XnView
Posts: 34681
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Exif <User Comment> et version 1.82 beta

Post by xnview »

Grasyop wrote:Bonjour,

L'exif <User Comment> dans la version 1.82 beta :

- Dans Propriétés>Exif - User Comment, tous les commentaires semblent désormais apparaître correctement.

- Par contre, dans les vignettes ( explorateur ) ainsi que dans le diaporama, c'est moins bien qu'avant : les commentaires contenant un caractère accentué restent absents ; les autres commentaires sont remplacés par le sigle 'ASCII'.

Grasyop
Cela sera corrigé
Pierre.
Grasyop

Fins de commentaires

Post by Grasyop »

Bonjour,

Vous avez bien amélioré les choses dans la version beta 2 !
Merci pour ce travail ! :D

Il reste cependant des problèmes ( détails ) avec les fins de commentaires.
Certains d'entre eux ne s'arrêtent pas correctement et sont suivis de symboles supplémentaires, souvent la lettre w suivie d'une note de musique, parfois un mot complet comme la marque de mon appareil.
Comme le problème n'apparaît pas sur les photos que je vous ai déjà envoyées, je vous en envoie une nouvelle.

Grasyop
Grasyop

Post by Grasyop »

Problème résolu. Merci beaucoup. :D

Grasyop
Post Reply