XnView MP 0.90 Rotate Bug

*** Please report new bugs here! ***

Moderator: Dreamer

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.90 Rotate Bug

Post by xnview » Mon Mar 18, 2019 11:51 am

obelisk wrote:
Sun Mar 17, 2019 5:23 am
You use your camera take a jpg + RAW.
use LR to make RAW->jpg in the same folder
This file now looks rotated WRONGLY in XnView .

It looks CORRECT in all other viewers.
Send me sample files to reproduce?
Pierre.

obelisk
Posts: 401
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk » Wed Mar 27, 2019 11:29 pm

Can I email you a private file to look at

obelisk
Posts: 401
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk » Sun Mar 31, 2019 11:21 pm

I posted a few samples. I can see from photos even in 2006 /SOME/ have this problem in 0.90 and not versions before.

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.90 Rotate Bug

Post by xnview » Mon Apr 01, 2019 1:58 pm

I've tried your file, and is loaded in portrait mode, it's no that?
Pierre.

wspollack-2019
Posts: 1
Joined: Fri Apr 05, 2019 12:55 am

Re: XnView MP 0.90 Rotate Bug

Post by wspollack-2019 » Fri Apr 05, 2019 1:20 am

I have been using XnView MP for a couple of years now, and this rotation problem happens to me quite often.

I take pictures with my iPhone 6 (or iPhone 4, before that), nothing unusual with the settings on the phone. The pictures are 3264 x 2448, typically c. 1.5MB - 2 MB.

I take most of the pics in landscape mode, but maybe 10% of the time I use portrait mode. And maybe half of those portrait-mode pics I change to landscape.

Most of the time when I do that, XnView MP will rotate the image, and when I move on to the next image, it will ask me to save and overwrite the portrait version, and I tell it do that. So all seems okay. But then when I move back to that changed image -- after looking at some more pics that I just uploaded -- it will be in the original portrait mode, as if I hadn't done anything to do. So I rotate and save it again. And maybe this time, it works.

And then -- sometimes -- when I close XnView MP and then run it again, that picture will be back in portrait mode. And I go through the process again.

I wish I could tell you what is different about these portrait pics, but there is nothing I can tell. I was thinking about sending you some, but when I go to verify that a pic won't STAY rotated, after a couple of tries to make sure that the pic really won't STAY that way ... it will, in fact, STAY that way.

I have found that rotating one of these to landscape mode and THEN cropping it, and then saving it, seems to work almost all of the time. But not quite all of the time.

This has been going on for the couple of years that I have been using XnView MP. Obviously, XnView MP is a very nice program, or I would have switched to another photo manager. But saving rotation has been a problem.

As I say, nothing strange. I don't manually alter the EXIF data or do anything technical like that. I get the pics from my phone to the Mac using PhotoSync (https://www.photosync-app.com/home.html), and the only thing I have that app do, as part of the movement, is rename the photo with the date-and-time.

I am conscientious about having the latest versions of XnView MP, the Mac O/S, and so forth.

Regards,

Bill

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.90 Rotate Bug

Post by xnview » Mon Apr 15, 2019 1:18 pm

wspollack-2019 wrote:
Fri Apr 05, 2019 1:20 am
I have been using XnView MP for a couple of years now, and this rotation problem happens to me quite often.

I take pictures with my iPhone 6 (or iPhone 4, before that), nothing unusual with the settings on the phone. The pictures are 3264 x 2448, typically c. 1.5MB - 2 MB.

I take most of the pics in landscape mode, but maybe 10% of the time I use portrait mode. And maybe half of those portrait-mode pics I change to landscape.
Could you send me a sample file and the way to reproduce this problem?
Pierre.

obelisk
Posts: 401
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk » Fri Apr 26, 2019 11:22 am

OK cannot understand still?
I wish it were easier to attach files.
Every single TIFF file shows sideways.
I'm going back to 0.8

gregs4163
Posts: 1
Joined: Mon Jul 08, 2019 12:53 pm

Re: XnView MP 0.90 Rotate Bug

Post by gregs4163 » Mon Jul 08, 2019 1:00 pm

Occasionally, I'm seeing portrait thumbnails rotated to landscape but the preview view is showing them in the correct orientation using 0.93.1

Post Reply