0.93: libstdc++ relocation error

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
Daniel710
Posts: 7
Joined: Mon Oct 08, 2018 5:30 pm

0.93: libstdc++ relocation error

Post by Daniel710 » Tue Feb 05, 2019 12:14 pm

XnView: MP - 64 bit
OS: Linux, Xubuntu 14.04, 64 bit

XnView doesn't run after upgrading from 0.92 to 0.93. The error is:

Code: Select all

/opt/XnView/XnView: relocation error: /opt/XnView/lib/libQt5WebKit.so.5: symbol _ZTVNSt7__cxx1115basic_stringbufIcSt11char_traitsIcESaIcEEE, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

User avatar
xnview
Author of XnView
Posts: 33449
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93: libstdc++ relocation error

Post by xnview » Tue Feb 05, 2019 1:43 pm

XnView is now built on ubuntu 16.04, you can try the appimage package
Pierre.

Daniel710
Posts: 7
Joined: Mon Oct 08, 2018 5:30 pm

Re: 0.93: libstdc++ relocation error

Post by Daniel710 » Tue Feb 05, 2019 1:55 pm

The AppImage gives exactly the same error:

Code: Select all

/tmp/.mount_XnViewgrmN1x/usr/XnView/XnView: relocation error: /tmp/.mount_XnViewgrmN1x/usr/XnView/lib/libQt5WebKit.so.5: symbol _ZTVNSt7__cxx1115basic_stringbufIcSt11char_traitsIcESaIcEEE, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

User avatar
xnview
Author of XnView
Posts: 33449
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93: libstdc++ relocation error

Post by xnview » Tue Feb 05, 2019 2:38 pm

and by installing

Code: Select all

sudo apt-get install libstdc++6
?
Pierre.

Daniel710
Posts: 7
Joined: Mon Oct 08, 2018 5:30 pm

Re: 0.93: libstdc++ relocation error

Post by Daniel710 » Tue Feb 05, 2019 2:58 pm

It's already installed. Maybe the AppImage was also built on Ubuntu 16.04?

User avatar
xnview
Author of XnView
Posts: 33449
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93: libstdc++ relocation error

Post by xnview » Tue Feb 05, 2019 3:52 pm

Daniel710 wrote:
Tue Feb 05, 2019 2:58 pm
It's already installed. Maybe the AppImage was also built on Ubuntu 16.04?
yes
Pierre.

Post Reply