0.96.1 Transparency not shown in PNG thumbnails

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
User avatar
Rick
Posts: 88
Joined: Sat Oct 08, 2005 4:10 pm
Contact:

0.96.1 Transparency not shown in PNG thumbnails

Post by Rick » Mon Apr 20, 2020 4:40 pm

0.96.1 x64 on Windows 10 x64
Thumbnails formerly showed the checkerboard background to indicate transparent areas
It has disappeared in this version
--
Rick

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by xnview » Tue Apr 21, 2020 6:39 am

you had it in 0.96?
Pierre.

User avatar
Akovia
Posts: 98
Joined: Sat Apr 02, 2011 2:10 am
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by Akovia » Sat Apr 25, 2020 8:56 pm

xnview wrote:
Tue Apr 21, 2020 6:39 am
you had it in 0.96?
Yeah, but it must be something specific about the files. Here are 2 side by side and one shows the transparency fine and the other doesn't.
Screenshot_2020-04-25_16-52-00.jpg
Attachments
clearart.png
clearlogo.png
Arch Linux
XnView MP

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by xnview » Sun Apr 26, 2020 1:33 pm

Rick wrote:
Mon Apr 20, 2020 4:40 pm
It has disappeared in this version
which version has that, there is no checkerboard for thumbnail
Pierre.

User avatar
Akovia
Posts: 98
Joined: Sat Apr 02, 2011 2:10 am
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by Akovia » Sun Apr 26, 2020 3:43 pm

xnview wrote:
Sun Apr 26, 2020 1:33 pm
Rick wrote:
Mon Apr 20, 2020 4:40 pm
It has disappeared in this version
which version has that, there is no checkerboard for thumbnail
o.96.1 which is why I posted here instead of starting a new thread.
I've never experienced (AFAICR) any png thumbnail not showing a checked background until this update. What was strange is that some pngs still show checks but some don't.
Screenshot_2020-04-26_11-37-20.jpg
Arch Linux
XnView MP

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by xnview » Mon Apr 27, 2020 3:21 pm

Akovia wrote:
Sun Apr 26, 2020 3:43 pm
o.96.1 which is why I posted here instead of starting a new thread.
I've never experienced (AFAICR) any png thumbnail not showing a checked background until this update. What was strange is that some pngs still show checks but some don't.
but which version do you had with checkedboard??
Pierre.

User avatar
Akovia
Posts: 98
Joined: Sat Apr 02, 2011 2:10 am
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by Akovia » Mon Apr 27, 2020 5:01 pm

xnview wrote:
Mon Apr 27, 2020 3:21 pm
but which version do you had with checkedboard??
AFAICR = As far as I can remember.

I don't ever recall running into a png file that didn't have a checkered background until I ran into this example the other day. When I searched the forums for the issue, I ran into this post and figured it was related as I had just upgraded my version as well from 0.96 > 0.96.1.

When I get a chance (hopefully today) I'll roll back my version and see if 0.96 is acting the same way with this particular file. I didn't do this because it really seemed related since someone else had the exact same problem after the recent update.
Arch Linux
XnView MP

User avatar
Akovia
Posts: 98
Joined: Sat Apr 02, 2011 2:10 am
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by Akovia » Mon Apr 27, 2020 7:53 pm

hmm, it looks like I can't downgrade easily. I checked my existing packages on my system and the only other version I have is xnviewmp-0.76.1-2-x86_64.pkg.tar.xz

I have only run into that one image so far so it's not a huge problem. If I run into any more I will certainly post them here.
Arch Linux
XnView MP

cday
XnThusiast
Posts: 2455
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by cday » Mon Apr 27, 2020 8:13 pm

You should be able to download more versions if you wish to test them from this link: Old versions.

User avatar
Akovia
Posts: 98
Joined: Sat Apr 02, 2011 2:10 am
Contact:

Re: 0.96.1 Transparency not shown in PNG thumbnails

Post by Akovia » Mon Apr 27, 2020 8:49 pm

cday wrote:
Mon Apr 27, 2020 8:13 pm
You should be able to download more versions if you wish to test them from this link: Old versions.
Sorry but that is giving me an error when I try.

Code: Select all

$ ./xnview.sh 
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted (core dumped)
I don't know why I don't have my old pkgbuild for 0.96, but it's not on my system.
Arch Linux
XnView MP

Post Reply