Cannot install XnConvert on Fedora 31

XnConvert Multi Platform - Windows, MacOSX, Linux
Post Reply
alex.seidanis
Posts: 4
Joined: Fri Feb 07, 2020 12:48 am

Cannot install XnConvert on Fedora 31

Post by alex.seidanis » Fri Feb 07, 2020 12:54 am

Hello,

tried to install XnConvert on my Fedora 31 but I get:

Code: Select all

Error: 
 Problem: conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnconvert-1.82-2.x86_64
  - nothing provides libQt5EglFSDeviceIntegration.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnconvert-1.82-2.x86_64
  - nothing provides libQt5Gui.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnconvert-1.82-2.x86_64
  - nothing provides libQt5Network.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnconvert-1.82-2.x86_64
  - nothing provides libQt5XcbQpa.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnconvert-1.82-2.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
I installed qt5-qtbase, qt5-qtbase-devel, qt5, qt5-devel, qt, qt-devel, nothing seems to do the trick.
Any assistance around this would be sincerely appreciated, thanks.

User avatar
xnview
Author of XnView
Posts: 32454
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Cannot install XnConvert on Fedora 31

Post by xnview » Sat Feb 08, 2020 3:49 pm

when you try to install the .deb? XnConvert comes with QT libs, no need to install them
Pierre.

alex.seidanis
Posts: 4
Joined: Fri Feb 07, 2020 12:48 am

Re: Cannot install XnConvert on Fedora 31

Post by alex.seidanis » Sun Feb 09, 2020 11:54 am

Thanks for your response Pierre.
Fedora is an rpm-based distro, doesn't know what to do with deb files, as far as I know anyway.

User avatar
xnview
Author of XnView
Posts: 32454
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Cannot install XnConvert on Fedora 31

Post by xnview » Sun Feb 09, 2020 1:50 pm

please try the tgz package
Pierre.

alex.seidanis
Posts: 4
Joined: Fri Feb 07, 2020 12:48 am

Re: Cannot install XnConvert on Fedora 31

Post by alex.seidanis » Sun Feb 09, 2020 10:27 pm

I got the following errors:

Code: Select all

./XnConvert 
./XnConvert: /lib64/libQt5Network.so.5: version `Qt_5_PRIVATE_API' not found (required by ./XnConvert)

Code: Select all

./xnconvert.sh 
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

./xnconvert.sh: line 5: 53019 Aborted                 (core dumped) "$dirname"/XnConvert "$@"

User avatar
xnview
Author of XnView
Posts: 32454
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Cannot install XnConvert on Fedora 31

Post by xnview » Mon Feb 10, 2020 7:25 am

it's the same problem
you need to remove lib/libfreetype.* from XnConvert package
Pierre.

alex.seidanis
Posts: 4
Joined: Fri Feb 07, 2020 12:48 am

Re: Cannot install XnConvert on Fedora 31

Post by alex.seidanis » Mon Feb 10, 2020 10:13 am

Brilliant! It works now!
Thanks for all the time and effort you put into this Pierre, I truly appreciate it.

Post Reply