Ubuntu: Problem to start the program

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
mnwstl
Posts: 1
Joined: Fri Apr 08, 2016 12:59 pm

Ubuntu: Problem to start the program

Post by mnwstl »

Hi!

I tried to install the new version of XnViewMP (0.79) in ubuntu. It was the installation but did not start the program. After much searching I found that missing the libgstapp-0.10.so.0 library, which was not easy to find. Could not be included in the installation package to prevent this problem?
User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: Problem to start the program.

Post by oops66 »

mnwstl wrote:Hi!
I tried to install the new version of XnViewMP (0.79) in ubuntu. It was the installation but did not start the program. After much searching I found that missing the libgstapp-0.10.so.0 library, which was not easy to find. Could not be included in the installation package to prevent this problem?
Hi, ... +1 (I think,statics libraries are needed to have XnViewMP into multi-platforms, even for olds distributions)
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64
gagala
Posts: 7
Joined: Sat Feb 28, 2015 9:01 am

Re: Problem to start the program.

Post by gagala »

Got the same problem with installation of Xubuntu 16.04. Until now I've never had that problem. libgstapp-0.10.so.0 really should be included to the installation file. Not everybody has the skills and time to seek for information to get help.

Found a solution:
sudo add-apt-repository ppa:dhor/myway
sudo apt-get update
sudo apt-get install xnviewmp
User avatar
Klaas
Posts: 22
Joined: Wed Jun 13, 2012 11:39 am
Location: Hannover, Deutschland
Contact:

Re: Problem to start the program.

Post by Klaas »

Yes, the very same problem here after upgrading Xubuntu to 16.04 today…

I solved it with:

Code: Select all

apt install libgstreamer-plugins-base0.10-0
I found that here.
mpeca
Posts: 5
Joined: Sun Apr 24, 2016 11:54 am

Re: Problem to start the program.

Post by mpeca »

XnView 64bit DEB file don't start after installation on Debian 8.4 (64bit, of course). Why?
Many thanks.

massimo
mpeca
Posts: 5
Joined: Sun Apr 24, 2016 11:54 am

[SOLVED] Re: Problem to start the program.

Post by mpeca »

mpeca wrote:XnView 64bit DEB file don't start after installation on Debian 8.4 (64bit, of course). Why?
Many thanks.

massimo
I have installed libgstreamer-plugins-base0.10-0 from Synaptic and now work fine. But there isn't any information on instructions information. Only for Microsoft Windows there is all, XnView staff?
Bye.

massimo
mdalacu
Posts: 36
Joined: Mon May 31, 2010 6:41 pm

Re: Problem to start the program.

Post by mdalacu »

I cannot start it on Ubuntu 16.10, it hangs on startup. I see nothing in terminal except:

Code: Select all

** (XnView:25057): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-YFmApRS67f: Connection refused
With sudo xnview it works.

On older Ubuntu versions it was working just fine.
mpeca
Posts: 5
Joined: Sun Apr 24, 2016 11:54 am

Re: Problem to start the program.

Post by mpeca »

mpeca wrote:
mpeca wrote:XnView 64bit DEB file don't start after installation on Debian 8.4 (64bit, of course). Why?
Many thanks.

massimo
I have installed libgstreamer-plugins-base0.10-0 from Synaptic and now work fine. But there isn't any information on instructions information. Only for Microsoft Windows there is all, XnView staff?
Bye.

massimo
the same problem occurs with version 0.84, but this time I have not solved
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem to start the program.

Post by xnview »

mpeca wrote:
mpeca wrote:
mpeca wrote:XnView 64bit DEB file don't start after installation on Debian 8.4 (64bit, of course). Why?
Many thanks.

massimo
I have installed libgstreamer-plugins-base0.10-0 from Synaptic and now work fine. But there isn't any information on instructions information. Only for Microsoft Windows there is all, XnView staff?
Bye.

massimo
the same problem occurs with version 0.84, but this time I have not solved
which message do you have in console?
Pierre.
mpeca
Posts: 5
Joined: Sun Apr 24, 2016 11:54 am

Re: Ubuntu: Problem to start the program

Post by mpeca »

excuse my ignorance: what console?
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Ubuntu: Problem to start the program

Post by xnview »

mpeca wrote:excuse my ignorance: what console?
sorry a terminal
Pierre.
mpeca
Posts: 5
Joined: Sun Apr 24, 2016 11:54 am

Re: Problem to start the program.

Post by mpeca »

the same problem occurs with version 0.84, but this time I have not solved[/quote]
which message do you have in console?[/quote]

I have installated with Gdebi on Debian 8.7 (not on Ubuntu) with LXDE
Post Reply