shortcut key Ctrl+shift+0 doesn't work

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
Nimrodel
Posts: 18
Joined: Mon Mar 20, 2017 5:02 pm

shortcut key Ctrl+shift+0 doesn't work

Post by Nimrodel »

Hello,
sorry, it is a very small thing but I cannot solve it: the shortcut key to remove the color category (Ctrl+shift+0) doesn't work with me... thanks in advance for help!
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: shortcut key Ctrl+shift+0 doesn't work

Post by helmut »

Thank you for your support request, Nimrodel.

Did you assign various shortcuts yourself? If you didn't, could you please try and reset your keyboard assignements ("default.key") as described in topic MP: How to reset program configuration?
Nimrodel
Posts: 18
Joined: Mon Mar 20, 2017 5:02 pm

Re: shortcut key Ctrl+shift+0 doesn't work

Post by Nimrodel »

Hello,
Thank you for your answer!
I didn't modify the shortcuts, except when it already didn't work and I tried to change it. Now I also did delete "default.key" as described. But still, this one shortcut doesn't work..
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: shortcut key Ctrl+shift+0 doesn't work

Post by xnview »

in browser mode?
Pierre.
User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: shortcut key Ctrl+shift+0 doesn't work

Post by GeorgD »

xnview wrote: Wed Jun 07, 2017 7:32 amin browser mode?
For me, it's in browser and viewer mode - but only on 2 of my 3 machines. It's not only depending on keyboard layout/language, as all machines have the same, but I guess it is something in this direction.
On 1 machine (Win 7), default works fine. On 2nd machine (Win 7), default does not work but I can assign e.g. shortcut Ctrl+Shift+9 to "uncolored" and it works. On 3rd machine (Win 10 laptop), default does not work and neither the other numbers, i.e. when I am in Settings > Interface > Shortcuts and press Ctrl+Shift+9 in "custom" field, Ctrl+Shift+) is shown - on my DE keyboard layout, Shift+9 produces ) so maybe it has to do with how a machine fetches the pressed keys in combination with modifier Shift. BTW, Crtl+0 is no problem on any of my machines, so it seems only to interfere with Shift.

Happy bug hunting ;) and if I can help somehow, just tell me how. Georg
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP
isjustaghost
Posts: 1
Joined: Tue Jul 10, 2018 9:56 pm

Re: shortcut key Ctrl+shift+0 doesn't work

Post by isjustaghost »

It does the same for me. However, it does it in both browser and view. I found it easier to use the ctrl+alt combo. It allows the use of the number pad.

What I have found. Pressing ctrl+shift recognizes that Shift is pressed. Therefore the buttons switch to the shifted version (on numpad, shift+1 eq. end.)
ctrl+shift+0 (above the keyboard) does not register in settings. Had to select "default" in order to change it back.
User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: shortcut key Ctrl+shift+0 doesn't work

Post by GeorgD »

The issue still exists in XnView MP v0.93.1 on Win10 1809 and grew worse: CTRL+SHIFT+9 does also not work any more, neither CTRL+SHIFT+6 neither CTRL+ALT+0. The mapping itself is working in general, e.g. CTRL+9 and CTRL+SHIFT+G work fine => it seems only keys are affected that produce characters when pressed together with the modifier(s), e.g. in DE keyboard, 9 with SHIFT produces ) and with ALT+CTRL produces ] but nothing with CTRL alone, 0 with SHIFT = and with ALT+CTRL }.

I tried to save the shortcuts to .key file, modify this one e.g. change CTRL+SHIFT+) to CTRL+SHIFT+= or CTRL+SHIFT+0 and loaded the .key file again, but this does not serve as workaround.

For me, I worked around the issue by assigning CTRL+SHIFT+U (like "uncolored"). Still, it's odd that XnView MP shortcut settings dialog fetches keystrokes the program cannot fetch identical.

Loosely related to Keyboard shortcuts for rating and labelling - missing
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP
Simon.H
Posts: 4
Joined: Thu Nov 22, 2018 7:32 pm

Re: shortcut key Ctrl+shift+0 doesn't work

Post by Simon.H »

Hello,
Experiencing this same issue with XnView MP Version 0.94.2 64bits (Dec 20 2019)

Ctrl+Shift+1 (or 2, 3, 4, 5) work fine to set the colour.

But Ctrl+Shift+0 does not set uncoloured. It doesn't work in any of the browser or view modes.

Recent model HP Laptop with Windows 10 64-bit, using the row of numbers above the qwerty.

I kind of wish the default just worked, without having to hack a different key binding.

Thanks
Simon
User avatar
xnview
Author of XnView
Posts: 33840
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: shortcut key Ctrl+shift+0 doesn't work

Post by xnview »

Simon.H wrote: Sat Jan 04, 2020 7:54 pm Experiencing this same issue with XnView MP Version 0.94.2 64bits (Dec 20 2019)
do you have tried to set 'Ctrl+Shift+0' in Settings>Interface>Shortcuts?
Pierre.
Post Reply