Thumbnail labels are always black

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

User avatar
lphilpot
Posts: 11
Joined: Wed Oct 05, 2016 2:49 am

Thumbnail labels are always black

Post by lphilpot »

XnView MP Linux
Version 0.87 64bits (Sep 5 2017)
Libformat version 7.10
Xubuntu 16.04 LTS

I'm using the Fusion Dark theme and until just lately it's been fine. A few days ago, all my thumbnail labels turned black. They're set to white on black, but nothing I do will make them appear in any color than black. I've lightened the thumbnail cell color to a medium grey so I can read them, but that's only a temporary workaround.

I'm getting frequentOS/app updates from Ubunutu, etc., so yes it's updated on a regular basis, but I've been at 0.87 since before this started. I'm not sure what UI toolkit XnView uses in my case (QT, GTK, etc.), but I guess it's possible a config file could've been touched (although I didn't do it explicitly).

Otherwise, everything is perfectly functional. Any idea of what's causing this?

Thanks!
Len Philpot
Xubuntu Linux
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Thumbnail labels are always black

Post by xnview »

XnView use QT, you have not changed your settings?
Pierre.
User avatar
lphilpot
Posts: 11
Joined: Wed Oct 05, 2016 2:49 am

Re: Thumbnail labels are always black

Post by lphilpot »

Not that I know of. Since leaving KDE for Xfce, I have very few programs using QT and I've not specifically changed anything.
Len Philpot
Xubuntu Linux
User avatar
lphilpot
Posts: 11
Joined: Wed Oct 05, 2016 2:49 am

Re: Thumbnail labels are always black

Post by lphilpot »

Hate to resurrect an old thread, but this is still happening. I'm currently on 0.98.4 64 bit, Xubuntu 18.04 LTS, using the Fusion Dark theme. Here's what I see:

Image

The foreground / background setting for the labels has no effect. As before I've set the thumbnail cell background to a medium grey to make the black labels visible (otherwise they're black on black).

Image

Image

I've made no QT changes and I can't find anything in XnView where I can correct this. Is it something in the theme that's overriding?

Thanks.
Len Philpot
Xubuntu Linux
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Thumbnail labels are always black

Post by xnview »

ok, i can reproduce if you don't use 'use color format based on file format'
Pierre.
User avatar
lphilpot
Posts: 11
Joined: Wed Oct 05, 2016 2:49 am

Re: Thumbnail labels are always black

Post by lphilpot »

Getting closer! :)

It seems logical that if file format colors are disabled, the label default should take over. Bug?

At any rate, I don't care about format colors, so I'll just set them all to the same color and use them. But even so, when there is a third line on the label it (File: {Modified Date [Y-m-d H:M:S]}) is still getting rendered in black. Is there another setting I'm missing?

Image

Also, it appears I've uncovered a bug, confirmed it three times. Open Preferences, go to Browser | Thumbnail | Appearance, click the cell background color picker, swipe and copy (Ctrl+C) the color value. XnView hangs hard and I have to kill it off.

Image

I haven't tried the foreground picker but it doesn't hang on the label background picker. I'm running Version 0.98.4 64bits (May 31 2021) Libformat version 7.81 on Xubuntu 18.04 (patched).

Thanks.
Len Philpot
Xubuntu Linux