Browsing thru folders very slow on network drives...

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
KingMatthew
Posts: 4
Joined: Tue Jul 16, 2019 2:30 pm

Browsing thru folders very slow on network drives...

Post by KingMatthew » Tue Jul 16, 2019 2:56 pm

Hi,

I've encounter a very annoying problem:
Every time i change the folder, i get a wait time ... more images, more wait time.
Just around 30-40sec for 200 images with approx. 500KB.

This happen:
- a yellowish indicator appear, which maybe 'scans' thru the images
- a progress bar showing up the whole procedure
xnviewmp.png
My XNViewMP Version: Version 0.93.1 64bits (Mar 6 2019)

And every time i change into a folder this happens, just also for visited folders.

This drive i operate is just a very slow network drive from my wireless router (~5MB/sec) and every unnecessary access slows down everything very strongly ... Where i can deactivate this 'stupid' behaviour?

And why in hell is this 'feature' still activated for network drives, why is this not automatic disabled for those drives?

PS: Sorry for my 'bad' english, i'm from Germany °°
Last edited by KingMatthew on Tue Jul 16, 2019 3:16 pm, edited 1 time in total.

KingMatthew
Posts: 4
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Mon Jul 22, 2019 7:36 am

Is this here a SUPPORT or not ... Did no one knows what crap are programmed in there?

User avatar
xnview
Author of XnView
Posts: 31373
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browsing thru folders very slow on network drives...

Post by xnview » Mon Jul 29, 2019 2:20 pm

XnView read the header to identify image format
Pierre.

KingMatthew
Posts: 4
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Tue Jul 30, 2019 5:36 pm

How to disable it, once and for all?

User avatar
xnview
Author of XnView
Posts: 31373
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browsing thru folders very slow on network drives...

Post by xnview » Mon Aug 05, 2019 3:35 pm

KingMatthew wrote:
Tue Jul 30, 2019 5:36 pm
How to disable it, once and for all?
its needed
Pierre.

rcpinheiro
Posts: 6
Joined: Tue Dec 13, 2011 1:01 pm

Re: Browsing thru folders very slow on network drives...

Post by rcpinheiro » Fri Aug 23, 2019 7:14 pm

+1. This is a huge nuisance even when we have locally a folder with many hundreds of files.
I don't know why XnView needs to read file header because the thumbnails appear fine and the images are OK even when the counter is stuck in 1%.

KingMatthew
Posts: 4
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Sun Aug 25, 2019 9:20 pm

I encountered that even ACDsee v3.1 has such an option for disabling header reads, but nowadays it is quite darn old and doesn't work flawlessly under Windows 10, not even in compatibility mode :(
acdsee31.png

Post Reply