Browsing thru folders very slow on network drives...

Bugs which have been reproduced by a second user or the developer, or features to do

Moderator: Dreamer

Post Reply
KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Browsing thru folders very slow on network drives...

Post by KingMatthew » Tue Jul 16, 2019 2:56 pm

Hi,

I've encounter a very annoying problem:
Every time i change the folder, i get a wait time ... more images, more wait time.
Just around 30-40sec for 200 images with approx. 500KB.

This happen:
- a yellowish indicator appear, which maybe 'scans' thru the images
- a progress bar showing up the whole procedure
xnviewmp.png
My XNViewMP Version: Version 0.93.1 64bits (Mar 6 2019)

And every time i change into a folder this happens, just also for visited folders.

This drive i operate is just a very slow network drive from my wireless router (~5MB/sec) and every unnecessary access slows down everything very strongly ... Where i can deactivate this 'stupid' behaviour?

And why in hell is this 'feature' still activated for network drives, why is this not automatic disabled for those drives?

PS: Sorry for my 'bad' english, i'm from Germany °°
Last edited by KingMatthew on Tue Jul 16, 2019 3:16 pm, edited 1 time in total.

KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Mon Jul 22, 2019 7:36 am

Is this here a SUPPORT or not ... Did no one knows what crap are programmed in there?

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browsing thru folders very slow on network drives...

Post by xnview » Mon Jul 29, 2019 2:20 pm

XnView read the header to identify image format
Pierre.

KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Tue Jul 30, 2019 5:36 pm

How to disable it, once and for all?

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browsing thru folders very slow on network drives...

Post by xnview » Mon Aug 05, 2019 3:35 pm

KingMatthew wrote:
Tue Jul 30, 2019 5:36 pm
How to disable it, once and for all?
its needed
Pierre.

rcpinheiro
Posts: 6
Joined: Tue Dec 13, 2011 1:01 pm

Re: Browsing thru folders very slow on network drives...

Post by rcpinheiro » Fri Aug 23, 2019 7:14 pm

+1. This is a huge nuisance even when we have locally a folder with many hundreds of files.
I don't know why XnView needs to read file header because the thumbnails appear fine and the images are OK even when the counter is stuck in 1%.

KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Sun Aug 25, 2019 9:20 pm

I encountered that even ACDsee v3.1 has such an option for disabling header reads, but nowadays it is quite darn old and doesn't work flawlessly under Windows 10, not even in compatibility mode :(
acdsee31.png

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browsing thru folders very slow on network drives...

Post by xnview » Mon Sep 02, 2019 3:19 pm

XnView needs to read header to update thumbnail labels for example
But during thumbnail process, you can't use XnView?
Pierre.

KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Wed Sep 04, 2019 6:09 pm

This header reading is indeed a background procedure but it slows down every image displaying while it's in progress, due (i guess) multiple readings on a very slow network drive.

Therefore this option should be disabled such to prevent this issue.

And nevertheless, it's annoying to see the yellow indicator marks running in every folder i switch every time and again and again....

KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Wed Sep 04, 2019 6:16 pm

PS: The problem is just more worse on a notebook ... the network drive i mentioned earlier is way slower over W-LAN with approx. 1MB/sec instead of 5MB/sec over LAN (i don't know why because the network drive is plugged into the wireless router which gives indeed all the LAN and W-LAN access at the same time)

But that is not in general the problem .... the problem is that still the old ACDSee Version runs fine with 1MB/sec but XNViewMP does not :!:

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browsing thru folders very slow on network drives...

Post by xnview » Tue Sep 10, 2019 8:18 am

ok, i'll add a setting
Pierre.

KingMatthew
Posts: 7
Joined: Tue Jul 16, 2019 2:30 pm

Re: Browsing thru folders very slow on network drives...

Post by KingMatthew » Wed Sep 11, 2019 8:00 pm

Well, I would be glad to see an upcoming version with an option as described.

Please make a note here when this version is ready. Thanks in advance.

Post Reply