Always open with Startup Wizard - Fedora 30 / Flatpak

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
Sprintdriver
Posts: 37
Joined: Mon Feb 02, 2009 11:46 pm

Always open with Startup Wizard - Fedora 30 / Flatpak

Post by Sprintdriver » Sun Sep 01, 2019 6:45 pm

Hi.

Have installed XnView MP onto a computer running Fedora 30, x64, Cinnamon.

Whenever I start XnView MP, the Startup Wizard dialog opens first. This happens if I open the program via menu and also if I open XnView from file explorer (double click on a jpg file for example).

The full command from launcher (aka. start menu) is:
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=xnview --file-forwarding com.xnview.XnViewMP @@ %F @@

Is there any settings I can do in order to prevent this menu opening up every time XnViewer MP opens ?
Attachments
Screenshot from 2019-09-01 20-44-19.png
Screenshot from 2019-09-01 20-44-19.png (34.01 KiB) Viewed 310 times

User avatar
xnview
Author of XnView
Posts: 31887
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Always open with Startup Wizard - Fedora 30 / Flatpak

Post by xnview » Mon Sep 02, 2019 3:27 pm

if you start it from shell console, no problem?
Pierre.

Sprintdriver
Posts: 37
Joined: Mon Feb 02, 2009 11:46 pm

Re: Always open with Startup Wizard - Fedora 30 / Flatpak

Post by Sprintdriver » Wed Sep 18, 2019 8:31 pm

Thing is - I'd used the "ln -s" command to redirect the /home/sprintrdriver/.var/app/com.xnview.XnViewMP to some folder in the /var directory (simply because I have a separate partition for /var that has plenty of space) - not realizing all the flatpak apps are running in a sandbox environment, not supposed to have access to /var.

I didn't realized it before now.
[edit]

No - it was something else. I was wrong. I tested this, and renamed the folder .var in homedir to something else, so that XnViewMP created the directory over again. So I expected the problem to be solved, but no. I still get this dialog box every start - and also XnVIewMP seems unable to save ANY settings.

Terminal output

Code: Select all

[sprintrdriver@localhost ~]$ /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=xnview --file-forwarding com.xnview.XnViewMP
==> 1.000000  91.793814  96.000000  (0)
XNVIEW restoreGeometry before : 640 480 
XNVIEW restoreGeometry after : 850 620 
w.init
XNVIEW SIZE 850 620 


########### BrowserWindow :: BrowserWindow 

libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
MENU install : 0x31e6760 
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
libpng warning: iCCP: known incorrect sRGB profile
########### BrowserWindow :: ok create (640 480)
BrowserWindow :: changeVisibility()
BrowserWindow :: changeVisibility()
BrowserWindow :: changeVisibility()
########### BrowserWindow :: restoreState (850 620)
BrowserWindow :: restoreState => 850 620 
                              => 588 410 
BrowserWindow :: restoreState ok => 588 410 
XNVIEW SIZE ok 
w.start
### BrowserWindow :: onStart go
#### onFavoriteDockVisible (1)
 BookmarkNode::BookmarkNode : 0x3414b50  
#### onCategoryFilterDockVisible (1)
libpng warning: iCCP: known incorrect sRGB profile
#### onCategoryDockVisible (1)
########### BrowserWindow :: restoreState (850 588)
BrowserWindow :: restoreState => 850 588 
                              => 588 233 
BrowserWindow :: restoreState ok => 588 233 
### BrowserWindow :: onStart
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
BrowserWindow :: onStart 2
setPathname </home/geir/>
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
### ThumbLoaderThread :: setFileList(0)
### ThumbLoaderThread :: setFileList() wait
######ThumbLoaderThread :: run : 32c5150 
######ThumbLoaderThread :: forever : 32c5150 
 ** start condition wait
### ThumbLoaderThread :: setFileList() after wait
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
 ** start condition wake one 2
### ThumbLoaderThread :: setFileList ok
######ThumbLoaderThread :: forever 2 : 32c5150 
CHECK <0> 
######ThumbLoaderThread :: forever : 32c5150 
 ** start condition wait
## OPEN FOLDER
  ## OPEN DB FOLDER ok
  ## UPDATE DB FOLDER ok
  ## OPEN FOLDER ok
## updateLabels
## updateLabels ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
######### CategoryModel :: checkAndSave()
TIME  0  
BitmapLoadThread :: stop()
QObject::disconnect: No such signal CategoryView::selectionChanged(const DBFilterModel::DBFileList&)
QObject::connect: No such signal CategoryView::selectionChanged(const DBFilterModel::DBFileList&)
Create children /home/sprintrdriver/
## OPEN FOLDER done
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
### ThumbLoaderThread :: setFileList(11)
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
 ** start condition wake one 2
### ThumbLoaderThread :: setFileList ok
### BrowserWindow :: finish
######ThumbLoaderThread :: forever 2 : 32c5150 
CHECK <10> 
### START 11 
######ThumbLoaderThread :: start : 10 
 CHECK : <XnView_MP.glibc2.17-x86_64.AppImage>
LOAD BITMAP </home/sprintrdriver/Downloads/XnView_MP.glibc2.17-x86_64.AppImage>
MyDirModelThread :: run
my_error_exit...<Not a JPEG file: starts with 0x7f 0x45>
ItemData :: update ==> Desktop OK 
ItemData :: update ==> Documents OK 
sizeHints : 128 
sizeHints : 128 
GFF :: LoadThumbnail : 2 
 CHECK : <Screenshot from 2019-09-01 20-19-52.png>
LOAD BITMAP </home/sprintrdriver/Pictures/Screenshot from 2019-09-01 20-19-52.png>
###### onChildrenChecked 7 <Videos>
###### onChildrenChecked 6 <Templates>
###### onChildrenChecked 5 <Public>
###### onChildrenChecked 4 <Pictures>
###### onChildrenChecked 3 <Music>
###### onChildrenChecked 2 <Downloads>
###### onChildrenChecked 1 <Documents>
###### onChildrenChecked 0 <Desktop>
ItemData :: update ==> Downloads OK 
ItemData :: update ==> Music OK 
GFF :: LoadThumbnail : 0 
 CHECK : <Screenshot from 2019-09-01 20-44-19.png>
LOAD BITMAP </home/sprintrdriver/Pictures/Screenshot from 2019-09-01 20-44-19.png>
GFF :: LoadThumbnail : 0 
ItemData :: update ==> Pictures OK 
ItemData :: update ==> Public OK 
ItemData :: update ==> Templates OK 
LOAD BITMAP </home/sprintrdriver/balenaEtcher.AppImage>
my_error_exit...<Not a JPEG file: starts with 0x7f 0x45>
GFF :: LoadThumbnail : 0 0  (2) 
ThumbLoaderThread - ADD into DB (-1)
LOAD BITMAP </home/geir/skript.sh>
my_error_exit...<Not a JPEG file: starts with 0x65 0x63>
GFF :: LoadThumbnail : 0 0  (2) 
ThumbLoaderThread - ADD into DB (-1)
######ThumbLoaderThread :: forever : 32c5150 
 ** start condition wait
ItemData :: update ==> Videos OK 
ItemData :: update ==> balenaEtcher.AppImage OK 
ItemData :: update ==> skript.sh OK 
### ThumbLoaderThread :: setFirstItemToLoad
 ** start condition wake one 3
### ThumbLoaderThread :: setFirstItemToLoad ok
######ThumbLoaderThread :: forever 2 : 32c5150 
CHECK <0> 
######ThumbLoaderThread :: forever : 32c5150 
 ** start condition wait
CategoryThread :: run
######### CategoryModel :: checkAndSave()
SAVE : 850 588
BrowserWindow :: saveState => 850 588 
                           => 588 233 
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
######ThumbLoaderThread :: run : 32c5150 OK
QMutex: destroying locked mutex
 AFTER WAIT
BitmapLoadThread :: stop()
 BookmarkNode::~BookmarkNode : 0x3414b50  
[sprintrdriver@localhost ~]$

Sprintdriver
Posts: 37
Joined: Mon Feb 02, 2009 11:46 pm

Re: Always open with Startup Wizard - Fedora 30 / Flatpak

Post by Sprintdriver » Sun Sep 22, 2019 12:13 pm

Update:

I installed Fedora 30 Mate on another computer. Then I installed XnView MP flatpak - didn't touch anything else. Seems to work properly now, so maybe I just did something wrong during or after installing on the other computer (Fedora 30 Cinnamon)

Sprintdriver
Posts: 37
Joined: Mon Feb 02, 2009 11:46 pm

Re: Always open with Startup Wizard - Fedora 30 / Flatpak

Post by Sprintdriver » Sun Sep 22, 2019 9:25 pm

Went back to the other computer that run Fedora 30 Cinnamon.

I uninstalled XnVIew (flatpak).
Then I removed the .var folder in my home dir.
Then I installed XnView again.

And the problem still persists. That is - it seems like the flatpak variant of XnVIew runs just fine on Fedora 30 Mate, but not on Fedora 30 Cinnamon :bug:


Edit
The appimage version of XnViewMP works without any problems on Fedora 30 Cinnamon, I use that as it works for me :)

Post Reply