External programs not working in Linux

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
CrustyCurmudgeon
Posts: 5
Joined: Sun Aug 16, 2020 12:27 pm

External programs not working in Linux

Post by CrustyCurmudgeon » Sun Aug 16, 2020 12:37 pm

I'm using XnView MP Linux Version 0.96.4 64bits (Jun 30 2020) under KDE Neon 20.04 focal (KDE 5.72.0 / Plasma 5.19.4). I'm seeing two major issues; one is a recent problem, the other is long-standing in every version of xnview linux I've ever used (several years now).

1. After updating from a previous version, the "Open With" external program assignments no longer work. They do not open any program now do they provide any feedback... just nuthin. I've removed and reprogrammed them with no joy. I've checked the config file and all seems to be in order, but nothing is working here.

2. The "Open with File Explorer" function has never worked in Linux. This has been true for me over many versions of xnview and several different distros.

QUESTIONS:

Are these known issues?
Will they ever be fixed?
Are there any work--arounds?

Thanks!

User avatar
xnview
Author of XnView
Posts: 33668
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: External programs not working in Linux

Post by xnview » Mon Aug 17, 2020 7:49 am

CrustyCurmudgeon wrote:
Sun Aug 16, 2020 12:37 pm
1. After updating from a previous version, the "Open With" external program assignments no longer work. They do not open any program now do they provide any feedback... just nuthin. I've removed and reprogrammed them with no joy. I've checked the config file and all seems to be in order, but nothing is working here.
check terminal, perhaps a Qt version conflict
2. The "Open with File Explorer" function has never worked in Linux. This has been true for me over many versions of xnview and several different distros.
no problem here on ubuntu
Pierre.

CrustyCurmudgeon
Posts: 5
Joined: Sun Aug 16, 2020 12:27 pm

Re: External programs not working in Linux

Post by CrustyCurmudgeon » Wed Aug 19, 2020 3:36 pm

xnview wrote:
Mon Aug 17, 2020 7:49 am
check terminal, perhaps a Qt version conflict
"check terminal" tells me absolutely nothing. "Qt version conflict" with what? How would I identify & resolve such a conflict?
no problem here on ubuntu
Def a problem on past ver. of Linux Mint, past & current vers. of KDE neon, and past vers. of a few other ubuntu/debian derivatives.

User avatar
xnview
Author of XnView
Posts: 33668
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: External programs not working in Linux

Post by xnview » Thu Aug 20, 2020 7:23 am

start XnView from a terminal, and check message when you start external app
Pierre.

CrustyCurmudgeon
Posts: 5
Joined: Sun Aug 16, 2020 12:27 pm

Re: External programs not working in Linux

Post by CrustyCurmudgeon » Fri Aug 21, 2020 4:35 am

xnview wrote:
Thu Aug 20, 2020 7:23 am
start XnView from a terminal, and check message when you start external app
That's a bit more helpful. I did just that and I did see a Qt error, referencing some "Qt version 5.14 not found" (I am running Qt 5.14.2). Neither the open with file explorer or open with external program worked.

I then checked for updates and saw a minor update available (0.96.4 >> 0.96.5) so I updated. Now, external programs are working as they did before. However, "open with file explorer" does not work. It shows the same error:

"kde-open5: /opt/XnView/lib/libQt5Core.so.5: version `Qt_5.14' not found (required by kde-open5)"
followed by several others referring to different files.

However, Qt 5.14.2 is currently installed. What is the problem here?

CrustyCurmudgeon
Posts: 5
Joined: Sun Aug 16, 2020 12:27 pm

Re: External programs not working in Linux

Post by CrustyCurmudgeon » Thu Aug 27, 2020 12:34 pm

anything at all?

User avatar
xnview
Author of XnView
Posts: 33668
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: External programs not working in Linux

Post by xnview » Mon Aug 31, 2020 1:43 pm

CrustyCurmudgeon wrote:
Thu Aug 27, 2020 12:34 pm
anything at all?
it seems that there is problem with paths for QT libs, XnView MP use QT 5.12
Pierre.

CrustyCurmudgeon
Posts: 5
Joined: Sun Aug 16, 2020 12:27 pm

Re: External programs not working in Linux

Post by CrustyCurmudgeon » Tue Sep 08, 2020 4:30 pm

xnview wrote:
Mon Aug 31, 2020 1:43 pm
CrustyCurmudgeon wrote:
Thu Aug 27, 2020 12:34 pm
anything at all?
it seems that there is problem with paths for QT libs, XnView MP use QT 5.12
Okay. So where might that "problem with paths for QT libs" exist? Considering that I'm using KDE as my primary desktop OS and it's pretty reliant on a functional QT foundation, I would suspect the problem is with XnViewMP Yes? No? Suggested troubleshooting steps or fix?

Post Reply