Need help with settings - color profiles, ICC...

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Need help with settings - color profiles, ICC...

Post by sasko1 »

Hi, there!

I wonder if someone can help me with this. Annoying problem with ICC profiles and Facebook and Mozilla and XnViewMP. Or at least with someone mentioned. Who knows. But I am sooo desperate.

Let me explain.

I use Win10 and I calibrated my monitor, so the colors are correct. Then I saved my ICC profile and made it default in windows. Everything as it should be.

I edit photos with LR or Photoshop. All have sRGB workspace, so edited images are exporter with sRGB profile.

Then I use XnViewMP for final converting to smaller files. Until yesterday everything worked OK and photos had the right colors even if I upload them to Facebook. But today something changed. When I upload photo to Facebook, colors are suddenly changed. They look dull, reduced colors. But few days ago everything was OK. The only thing I changed, was updating XnViewMP to last version.
Did something changed there? (which I doubt)

Here is the difference in image color, after uploaded to FB:


Image


The top one is more saturated, which is correct. Bottom one is dull, and not correct colors. Not a perfect example, but in other photos (i can't show them, privacy n' stuff) it is more visible.

So, let me explain my procedure to create photos. After photo is finished in LR or PS, it is time to go to XnViewMP.

In there, I have this settings under ICC settings:

Image


So, when I have my images in a directory, I make smaller ones, for web, with Batch/Convert option. My settings for metadata are like this:


Image

And under the output tab, I have this settings:


Image

And also, under the same tab, but under "Write settings" (Format) I have these settings:


Image


I was doing like this all the time and everything worked fine. Until today. As I mentioned, I did not change anything. Yesterday I uploaded to FB and the same images that today are wrong colors, yesterday were OK.
I thought that maybe Mozilla is out of date, so I updated to latest version, but it is the same. When image arrives to FB, colors are changed.


I checked also Mozilla gfx.color management settings, and everything looks the same and OK:

Image


What is very strange here is, that if I upload the same images via my iphone, everything works normal. But I can't upload every image via phone.
If I upload via Chrome, posted image also looks normal after I check it through Mozilla. Really strange. As if something Mozilla would do to the files. But again, I did not change anything during the night.
Did maybe Facebook desktop changed something in their system?

Oh and even if I check final resized photos, sRGB profile is mentioned there. So, not sure what is causing problems.

Now I don't know what to do. Maybe I am using some settings for color profiles wrong and I can't notice it. Is someone here that can take a look at my screenshots and see if I overlooked something?

Sorry for long post, but I am really desperate and clueless how to fix this. I hope someone can help me.

Thank you.
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

Oh, I just notice something:

Everything works OK only on Pages, and only if you upload via "publishing tools". If you try to upload directly on the wall, private or Business page, colors are off.

So this should be FB problem? :shock: I can't imagine getting some help from their side.
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

And another thinking:

there must be some problem with Mozilla too, since all images work OK with Chrome or Vivaldi. So, something in relation of Mozilla - Facebook wall.

Really crappy situation. I don't know how to fix it. Why everything works with Chrome, and not Mozilla? And why in Mozilla it works only inside of "publishing tools" of FB pages, but not on FB personal wall or FB page wall.

To whom should I address this? Is ther eanything I can to inside XnViewMP, to fix this mess? :?
User avatar
helmut
Posts: 8433
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Need help with settings - color profiles, ICC...

Post by helmut »

Thank you for your very detailed description of your problem, sasko1. First off: I'm not so familiar with colour profiles so handle my information with care. ;)

ICC profile corrects output of an image on your monitor
My current understanding is that a colour profile can be used to correct an input or output devices inaccuracies. In XnView MP, colour profiles are used for adjusting/calibrating an image before being displayed (monitor). This colour profile does not correct the image itself but the way you see it on your screen. In short: A colour profile adjusts the output of an image on your monitor without changing an image.

RGB and CMYK and embedded profiles
If I understand right, the other profile that you can set in XnView MP are for input. I.e. these colour profiles are used to correct inaccurracies of the camera and are either embedded in the image (by the camera?) or can be set in the settings, here (Tools > Settings | General | ICC).

So far so good. I notice that this doesn't explain basics of ICC profiles but not your problem. :? The problem occured after installing the new version XnView MP 1.00. So it might either a difference the two XnView MP versions or a setting that is different, now. Which version of XnView MP did you use before? Could you please try and install that version of XnView MP in addition and try out whether everything works fine with that version?
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

Thank you, Helmut for detailed explanation. I am aware of these things, I just wrote it so everything was detailed explained.

Now that you mention, maybe did something happen with the upgrade. Did not think of that as a problem.
I tried to downgrade, but I still have version 1.00. How do you do a correct downgrade?

If this won't work, I'll just use Chrome for the upload of images and hope that Facebook or Mozilla fix this. If the problem is on their side. But I wantet first to ask here, maybe I am doing something wrong.
User avatar
xnview
Author of XnView
Posts: 37538
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Need help with settings - color profiles, ICC...

Post by xnview »

could you send me the original and output file?
Pierre.
User avatar
helmut
Posts: 8433
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Need help with settings - color profiles, ICC...

Post by helmut »

sasko1 wrote: Tue May 10, 2022 5:56 am... I tried to downgrade, but I still have version 1.00. How do you do a correct downgrade?
XnView MP for Windows is available as Setup package or as ZIP package. For installing two versions of XnView MP on a PC in parallel, you either use two ZIP packages (with different versions) or a Setup package plus a ZIP package. Just make sure to install (second) ZIP package in a folder other than the program folder of XnView MP (created by the installer/setup or created when unpacking the ZIP archive).
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

xnview wrote: Tue May 10, 2022 6:25 am could you send me the original and output file?
It is sent to PM
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

hmm, that is very strange.

I uploaded unedited image, jpg straight out of camera and Facebook changed the colors. So I guess XnView is not a problem.

So it is a Mozilla or FB itself. But if inside of "publishing tools" on FB page everything works, and when uploading directly to the FB wall not, something is wrong with FB. Am I right?
Argh, what a mess
cday
XnThusiast
Posts: 3197
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Need help with settings - color profiles, ICC...

Post by cday »

Do you have a way to provide the original and output files in a ZIP, which should ensure that they are not altered in any way?

Current forum attachment size limit is 2MiB, otherwise provide a download link to the archive.
User avatar
xnview
Author of XnView
Posts: 37538
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Need help with settings - color profiles, ICC...

Post by xnview »

strange, the original & output file have same icc profile, i don't see difference...
Pierre.
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

xnview wrote: Thu May 12, 2022 1:50 pm strange, the original & output file have same icc profile, i don't see difference...
It was all good until few days ago. Than suddenly something changed. I assume on FB side. But to reach someone there would be mission impossible.

Although if this is FB problem, at least someone else should notice it. That is why I am so frustrated, since I don't know where to look for. Since xnview-admin checked the files, I guess I am not doing anything wrong. but, how that nobody else notice that? Or is just my computer? And If, what to fix, to correct that? Since I did not change anything at the first place. :?
sasko1
Posts: 58
Joined: Sat Oct 29, 2016 8:17 am

Re: Need help with settings - color profiles, ICC...

Post by sasko1 »

cday wrote: Thu May 12, 2022 11:54 am Do you have a way to provide the original and output files in a ZIP, which should ensure that they are not altered in any way?

Current forum attachment size limit is 2MiB, otherwise provide a download link to the archive.

cday, I sent you files in PM. Original, non edited file was uploaded from Mozilla to FB (directly to wall post), and colors changed.
If I do it via Publishing tools (FB pages have it), than it works normal. Also if I upload with Chrome, everything is OK, even if I post directly via wall.

Can you check somehow?

Oh and I also tried it on my wife's computer and it is the same problem. I also run Mozilla in safe mode, without add-ons, and it was the same problem.
I assume there must be some problem with FB receiving those files and not reading it well. Oh... famous FB support, that never answers.