Scanner is working, but no longer in "Select Twain Source"

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Scanner is working, but no longer in "Select Twain Source"

Post by windbag » Thu Mar 20, 2014 12:31 pm

I have on oldish scanner (Epson 1670), but it has been working on my (oldish) Vista 32bit desktop for the past 6 years.
I only do scans once in a while (last successful one was about a month ago).
Suddenly, it has stopped responding to the "Scan" button in XnView.
It DOES appear in Windows devices (says running OK), but does NOT appear in the the File>Select TWAIN source dialogue box.
I have tried reinstalling it from scratch, and while I can get the Epson scan routines to start up directly/independently (they used to fire up when I pressed the scan button), and can get a (rather useless) file save that way, it was much more user-friendly to fire it up via XnView & manipulate the images therein.

I have been reorganising some files lately - could I have moved some XnView set-up file to a different place that it now doesn't find?
(I do have some such XnView files on my data drive - I count software data setup files as my data as much as anything I author - they need backing up just as badly!)

I'm still using V 1.99.6, and while I've downloaded V 2.20, I thought I wouldn't just upgrade before understanding what has caused the loss of scanner from the list of TWAIN devices.

Realistic suggestions to get the scanner back into the PC TWAIN list welcome.

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by xnview » Thu Mar 20, 2014 2:52 pm

even by reinstalling driver?
Pierre.

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by windbag » Thu Mar 20, 2014 8:54 pm

xnview wrote:even by reinstalling driver?
As I said:
I have tried reinstalling it from scratch (yes, including the driver).
And it is working, in that I can do a scan via the Epson scan utility - it's just a rubbish interface.

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Tried again, but no joy

Post by windbag » Fri Mar 21, 2014 12:33 pm

Just to be sure, I went back into device manager, uninstalled the scanner, plugged it back in to force Windows to reinstall, went through the dialogue to reinstall & ran the software I used to get it working at the last rebuild (which worked for years).

No change. Still not appearing in the File>Select TWAIN source dialogue box.

It's NOT that the driver is no good, as the Epson Utility to induce new scans does still work (badly), and should be the same one that worked for ages.

My guess it's a Windows installation thing to do with TWAIN;
Any ideas how to get Windows to recognise it as part of the TWAIN devices available, and thereby to tell XnView?

Or could it be an XnView "use at startup" file I've moved that is causing the problem?

cday
XnThusiast
Posts: 2255
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Tried again, but no joy

Post by cday » Fri Mar 21, 2014 1:55 pm

windbag wrote:Any ideas how to get Windows to recognise it as part of the TWAIN devices available...
You could check that your Windows folder contains a folder called twain_32 -- on my Windows 7 computer I have that folder, and software for my Epson scanner is contained in a folder named escndv in it.
windbag wrote:I have been reorganising some files lately - could I have moved some XnView set-up file to a different place that it now doesn't find?
Which files have you moved and where are they located now?
windbag wrote:I do have some such XnView files on my data drive...
Is you 'data' drive a partition on your main hard drive, a separate installed hard drive, or possibly an external drive connected by USB?

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Re: Tried again, but no joy

Post by windbag » Fri Mar 21, 2014 4:53 pm

cday wrote: You could check that your Windows folder contains a folder called twain_32 -- on my Windows 7 computer I have that folder, and software for my Epson scanner is contained in a folder named escndv in it.
It does, and it did before.
cday wrote:Is you 'data' drive a partition on your main hard drive, a separate installed hard drive, or possibly an external drive connected by USB?
It has always been on a separate (internal) hard drive, and I have been migrating that to a NAS - BUT all the original program-related data is still on the internal drive too.
cday wrote:Which files have you moved and where are they located now?
This is where it gets tricky.
As I said, I'd been migrating the onboard data to an off-board NAS (for most of a year!) I've got to the point where the NAS route has been reliable (with quite a few caveats), but it's difficult to remember exactly which bits of software I'd managed to update about the change. Usually the program has complained it can't find it where it was (G:\...) and it is now on F:\...
No such complaint from XnView, but if a copy is still there, it's difficult to remember it was still using it until it's no longer there.

It doesn't help that I've also been trying to rationalise where in the (new) data tree structure such files are.
New ones are in F:\Software-ProgramData, but old ones are still in F(wasG):\OtherDataFileGroups\Software-ProgramData

I moved the root folder "XvView" containing the folder ToolbarButtonSetup & the files bookmark.ini & category.db from
F:\OtherDataFileGroups\Software-ProgramData
such that it is now F:\Software-ProgramData - but putting a copy back where it was does not cure the issue, and the original G:\ version is still there.

Looking at old onboard G:\-version, the XnView folder is dated 9/2/2011, the F:\ (NAS) version is dated 27/12/2013 (The scan has worked since then).
A byte-by-byte comparison shows that the category.db is different, and there is no .bak copy in the OLD folder.

But the point is, where can I tell XnView where to look ? (it eludes me at the moment).

I'll investigate if I've moved anything similar Epson, if relevant.

User avatar
XnTriq
Moderator & Librarian
Posts: 5499
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by XnTriq » Sat Mar 22, 2014 7:45 am

Are you able to acquire into other applications from the Epson 1670 via TWAIN, windbag?

Related topic: Evenement bouton scanner

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by windbag » Sun Mar 23, 2014 11:12 am

XnTriq wrote:Are you able to acquire into other applications from the Epson 1670 via TWAIN, windbag?
No. It's stopped working in Corel, too. I have X3, and scan has stopped working in Photo Paint & Draw, with the message:
"No Twain driver matching the application capabilities could be found" (I've Googled the phrase but got nowhere).
Which points a finger at Windows not "telling" relevant software that the scanner is part of the TWAIN hardware available (if it is- how can I tell?)
XnTriq wrote:Related topic: Evenement bouton scanner
Thanks for the link, but In the first (French) post (translation), it's mostly about getting the button on the scanner to fire up XnView directly.
Which would be great, if it knew my scanner was there !
The links in that, though, point to how to solve things in XP, and the "events" tab they cite under Scanner>Properties does not exist in my Vista setup.

cday
XnThusiast
Posts: 2255
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by cday » Sun Mar 23, 2014 11:47 am

windbag wrote:
XnTriq wrote:Are you able to acquire into other applications from the Epson 1670 via TWAIN, windbag?
No. It's stopped working in Corel, too...
That seems significant...

In view of all the changes you've made to your computer, could I suggest a simple test: download the XnView Classic 2.20 zip version and extract it to a folder on your Windows partition, then launch it and check if your scanner is shown as a TWAIN device?

If your scanner still isn't listed that would strongly suggest a Windows issue, if it is shown you can work from there to trouble shoot your file and drive changes, and will at least have a way to scan into XnView while you investigate further.

User avatar
XnTriq
Moderator & Librarian
Posts: 5499
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by XnTriq » Sun Mar 23, 2014 1:45 pm

  1. What are the contents of the file %temp%\TWAIN.LOG
  2. What are the contents of the folder %windir%\twain_32\escndv\?
  3. Where on you local drives or NAS are the following files located:
    • Escndv.exe
    • Estwm.exe
    • EsTWPMG.dll
    • Esutwb.dll
    • Per1670.ds
  4. Is Add XnView to applications for USB events (camera, scan, …) in Tools » Options » System integration » Integration activated?
  5. Are you able to scan from inside XnView through File » Acquire from Scanner or Camera (WIA)?

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by windbag » Mon Mar 24, 2014 5:11 pm

Thanks for the helpful response, XnTriq. It's taken me a while, but here's the answers:
XnTriq wrote:Where on you local drives or NAS are the following files located:
  • Escndv.exe
  • Estwm.exe
  • EsTWPMG.dll
  • Esutwb.dll
  • Per1670.ds
I have three copies of escndv.exe, all on c: (nowhere else):
C:\Program Files\EPSON\escndv\escndv.exe
C:\Windows\System32\DriverStore\FileRepository\es30.inf_9abc04ac\escndv.exe
C:\Windows\twain_32\escndv\escndv.exe

all are dated 7/3/2006 & are all 118,784 bytes

I have three copies of Estwm.exe, all on c: (nowhere else):
C:\Windows\System32\DriverStore\FileRepository\es30.inf_9abc04ac\Estwm.exe
C:\Windows\twain_32\escndv\es0030\Estwm.exe
C:\Windows\twain_32\escndv\Estwm.exe

Same date, all 40,960 bytes

2 copies of EsTWPMG.dll, all on c: (nowhere else):
C:\Windows\System32\DriverStore\FileRepository\es30.inf_9abc04ac\estwpmg.dll
C:\Windows\twain_32\escndv\es0030\estwpmg.dll

All dated 15/10/2006 & 249,856 bytes

2 copies of Esutwb.dll, all on c: (nowhere else):
C:\Windows\System32\DriverStore\FileRepository\es30.inf_9abc04ac\Esutwb.dll
C:\Windows\twain_32\escndv\es0030\Esutwb.dll

All dated 7/3/2006, all 126,976 bytes

2 copies of Per1670.ds.dll, all on c: (nowhere else):
C:\Windows\System32\DriverStore\FileRepository\es30.inf_9abc04ac\per1670.ds
C:\Windows\twain_32\escndv\per1670.ds

All dated 15/10/2006 & 98,304 bytes
XnTriq wrote:Are you able to scan from inside XnView through File » Acquire from Scanner or Camera (WIA)?
Yes! That was a surprise. It gets me a rather limited interface, better than before, but I've lost all the Epson scan stuff detail control of resolution, de-screening etc, and I no longer get the image back up in XnView.

XnTriq wrote:Is Add XnView to applications for USB events (camera, scan, …) in Tools » Options » System integration » Integration activated?
It wasn't, but it is now. Doesn't get the "Scan" to respond, though.
XnTriq wrote:What are the contents of the folder %windir%\twain_32\escndv\?
Full printfolders listing (with dates and sizes):

C:\Windows\twain_32\escndv
==========================

C:\Windows\twain_32\escndv\ES0030
C:\Windows\twain_32\escndv\ESSYS
C:\Windows\twain_32\escndv\LOCAL
C:\Windows\twain_32\escndv\escndv.exe
C:\Windows\twain_32\escndv\escndvrs.dll
C:\Windows\twain_32\escndv\estwm.exe
C:\Windows\twain_32\escndv\per1670.ds


C:\Windows\twain_32\escndv\es0030
=================================

C:\Windows\twain_32\escndv\es0030\FFMT DIR 17/04/2009 12:10:15
C:\Windows\twain_32\escndv\es0030\LOCAL DIR 17/04/2009 12:03:27
C:\Windows\twain_32\escndv\es0030\ade.dll 73216 07/12/1999 02:03:00
C:\Windows\twain_32\escndv\es0030\ade001.bin 3136 27/04/1999 00:17:00
C:\Windows\twain_32\escndv\es0030\es0030.hrd 4531 17/11/2006 03:00:00
C:\Windows\twain_32\escndv\es0030\escndv.chm 113618 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esddc.dll 77824 10/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esdevcl.dll 188416 16/10/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esdevif.dll 131072 16/10/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esdscl.dll 49152 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esdtr.dll 425984 16/10/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esdtr2.dll 94208 30/08/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esfit.dll 172032 06/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\ESICM.dll 53248 11/04/2008 00:00:00
C:\Windows\twain_32\escndv\es0030\esimfl.dll 561152 05/07/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esimgctl.dll 229376 17/04/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esimgdet.dll 1658880 01/08/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esmps.dll 348254 17/04/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esmpsres.dll 561272 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\esres.dll 3555328 16/04/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\esscncl.dll 327680 16/10/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\estwh.chm 31534 25/01/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\estwm.exe 40960 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\estwpmg.dll 249856 16/10/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esui.dll 675840 13/07/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\esutwb.dll 126976 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\version.dat 5 04/08/2006 03:04:00


C:\Windows\twain_32\escndv\es0030\FFMT
======================================

C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL DIR 17/04/2009 12:03:27
C:\Windows\twain_32\escndv\es0030\FFMT\epbmp.dll 73728 26/05/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\epbmpres.dll 45056 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\epipd.dll 98304 15/02/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\epjpg.dll 151552 23/06/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\epjpgres.dll 45056 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\epmtf.dll 94208 26/05/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\epmtfres.dll 45056 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eppdf.dll 102400 26/05/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eppdfres.dll 49152 16/04/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eppij.dll 86016 26/05/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eppijres.dll 45056 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eppit.dll 86016 26/05/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eppitres.dll 45056 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eptif.dll 94208 23/06/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\eptifres.dll 45056 07/03/2006 23:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\esexf.dll 143360 29/08/2005 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\espimtif.dll 98304 29/08/2005 00:00:00


C:\Windows\twain_32\escndv\escndv.exe


C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL
============================================

C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\epbmpres.dll 45056 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\epjpgres.dll 45056 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\epmtfres.dll 45056 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\eppdfres.dll 49152 17/04/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\eppijres.dll 45056 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\eppitres.dll 45056 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\FFMT\LOCAL\eptifres.dll 45056 08/03/2006 00:00:00


C:\Windows\twain_32\escndv\es0030\LOCAL
=======================================

C:\Windows\twain_32\escndv\es0030\LOCAL\escndv.chm 113618 08/03/2006 01:00:00
C:\Windows\twain_32\escndv\es0030\LOCAL\esmpsres.dll 561272 08/03/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\LOCAL\esres.dll 3555328 17/04/2006 00:00:00
C:\Windows\twain_32\escndv\es0030\LOCAL\estwh.chm 31534 25/01/2006 01:00:00

XnTriq wrote:What are the contents of the file %temp%\TWAIN.LOG
Only 1 "real" file, in C:\Users\A\AppData\Local\Temp (the other two are various old backups)
It is 96kb of text, here is the top bit:

TWAIN_32.DLL - MESSAGE - CTwunk ::AppInitialize - Reset Log
TWAIN_32.DLL - MESSAGE - CTwunk ::OpenServer - Starting Thunker
TWAIN_32.DLL - MESSAGE - CTwunk ::CloseServer - Why Can't We Find The Thunker Window?
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to NULL:
TWAIN_32.DLL - MESSAGE - CTWTRACE--CONTROL, IDENTITY, GETFIRST
TWAIN_32.DLL - ERROR - CDataSrc::IDataSrc - Duplicate Product Name Ignored: TW-Brother MFC-J6510DW LAN
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to NULL:
TWAIN_32.DLL - MESSAGE - CTWTRACE--CONTROL, IDENTITY, GETNEXT
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to NULL:
TWAIN_32.DLL - MESSAGE - CTWTRACE--CONTROL, IDENTITY, OPENDS
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, GET, XFERMECH
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, GET, PIXELFLAVOR
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, GET, [ 8014 ]
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, GET, [ 8010 ]
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, SET, [ 8025 ]
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, SET, [ 8010 ]
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, GET, [ 8002 ]
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):
TWAIN_32.DLL - MESSAGE - CTWTRACE--CAPABILITY, SET, [ 111e ]
TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)
TWAIN_32.DLL - MESSAGE - CTWTRACE--EPSON Scan(468) to EPSON Perfection 1670(470):

Gosh, lots of info, hope that helps!

User avatar
XnTriq
Moderator & Librarian
Posts: 5499
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by XnTriq » Mon Mar 24, 2014 7:00 pm

windbag wrote:Gosh, lots of info, hope that helps!
Sorry for giving you the run-around treatment, windbag. Troubleshooting TWAIN issues (particularly on Vista) is tricky business :-|

The fact that all files are on your C drive (and nowhere else) tells us that you probaly didn't (re)move any necessary components while reorganising stuff.

Are the drivers for the Brother MFC-J6510DW mentioned in your TWAIN.LOG still installed? Is it available from XnView via TWAIN?

cday
XnThusiast
Posts: 2255
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by cday » Mon Mar 24, 2014 10:42 pm

Wouldn't the easiest way to check your Epson scanner installation be the quick test I suggested in an earlier post?
cday wrote: In view of all the changes you've made to your computer, could I suggest a simple test: download the XnView Classic 2.20 zip version and extract it to a folder on your Windows partition, then launch it and check if your scanner is shown as a TWAIN device?

If your scanner still isn't listed that would strongly suggest a Windows issue, if it is shown you can work from there to trouble shoot your file and drive changes, and will at least have a way to scan into XnView while you investigate further.
Except that it might be better to use a slightly earlier and more proven zip version of XnView.

If the scanner still doesn't work correctly, that would seem to be the time to start delving into a detailed examination of the above files...
Last edited by cday on Tue Mar 25, 2014 8:10 am, edited 1 time in total.

User avatar
XnTriq
Moderator & Librarian
Posts: 5499
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by XnTriq » Tue Mar 25, 2014 12:30 am

My (beer) gut feeling tells me that an incomplete un-installation prevented a successful re-installation of the driver.

cday
XnThusiast
Posts: 2255
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by cday » Tue Mar 25, 2014 8:23 am

My (non-beer) gut feeling is that the scanner problem could well be due to the extensive changes made to the XnView installation, and that there may not have been a problem with the TWAIN interface originally, whatever the state now.

The problem existed before the driver was reinstalled...

Post Reply