Cached image names still show if caching isn't enabled

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
xnmen
Posts: 16
Joined: Fri Jul 11, 2014 2:50 pm

Cached image names still show if caching isn't enabled

Post by xnmen » Thu Aug 07, 2014 9:36 pm

If you look in options under Browser > Thumbnails > Cache, even with caching option disabled, it shows a long list of paths of images previously accessed & how many images were from each path (I guess). See attached screen.

Seems confusing. By unchecking the option, you've told it not to cache the paths & images, but it does anyway?

Also, for shared Windows user accounts (or even for hiding the existence of important data from adversaries), it could be an issue.

Is there a way to prevent it from displaying all those previously accessed paths?
The list of potential cached folders shown in options is much longer than in the screen. There are about 11 - 12 paths listed.

Thanks.
Attachments
xnview-options cache info 08-07-2014.gif
xnview-options cache info 08-07-2014.gif (7.49 KiB) Viewed 684 times

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Cached image names still show if caching isn't enabled

Post by XnTriq » Fri Aug 08, 2014 12:30 am

It's a known issue in XnView Classic…
xnview ([url=http://newsgroup.xnview.com/viewtopic.php?p=69645#p69645]Cache issue[/url]) wrote:
XnTriq wrote::bugconfirmed: XnView v1.95.4 @ Windows 2000 SP4

(Enable Caching & Use database to store file information deactivated)
Ok, but it's not a bug if fileinfo is stored in DB...
Lesmo16 ([url=http://newsgroup.xnview.com/viewtopic.php?p=113954#p113954]Minimal XnView[/url]) wrote:
helmut wrote:
Lesmo16 wrote:.. Aside that, creating a cache folder with disabled caching doesn't make sense to me.
I support your request to surpress the creation of unused/unnecessary (from user perspective) files, Lesmo.
Still the same in v2.04 ...
Still creates files category.db and category.bak, default.bar. :(
… and MP:

xnmen
Posts: 16
Joined: Fri Jul 11, 2014 2:50 pm

Re: Cached image names still show if caching isn't enabled

Post by xnmen » Fri Aug 08, 2014 4:01 am

Thanks.

Pierre commented in one of your links, about a file w/ those thumbnail entries being created, when caching is disabled: "Yes it's normal."

No, it's not normal. It may be the way XV classic & I gather, MP (mis)handle this... but it's not normal. I'm not familiar w/ any other well developed apps that would do this, once they give an option to not cache data.

EDIT: On re-reading the linked posts, I think what Pierre may've been saying is, it's normal for it to be creating entries that have 0 bytes, showing under the thumbnail cache list in Options. I kinda see what he means, but again - if you disable caching, it's not normal for it to build the DB anyway.
END EDIT.

When you tell a browser, "Don't save history," it doesn't go ahead & compile / display a history DB.
When you tell it, "Don't save typed PWs", it doesn't create a list anyway (using low quality encryption).
Even Windows, as bad as it is about certain privacy & security practices, generally doesn't continue showing data that it gave the option to not show.

Another ironic thing about the comment in one of your links, where it said you could remove the thumbnail cache entries. AFAIK, you have to ENABLE caching (check the box) before removing entries is an option.
So, it creates them when caching is disabled, but makes you ENable caching before you can remove them?

One could add custom files from XV to be deleted / erased in apps like CCleaner, BleachBit, Eraser. Delete the XV databases where those records are (I assume). Except for Eraser (or paid CCleaner), they wouldn't be automatic.

But, doing that is really kind of a pain for something that probably isn't that hard to fix and for something it definitely shouldn't be doing, anyway.
I haven't used Eraser in a while because it had bugs in at least Vista & it wasn't being actively developed (don't think it is now).

xnmen
Posts: 16
Joined: Fri Jul 11, 2014 2:50 pm

Re: Cached image names still show if caching isn't enabled

Post by xnmen » Fri Aug 08, 2014 4:37 am

After messing some more w/ the thumbnail cache list & deleting all current entries, I can't get it to create any new entries.

Before, the caching option was unchecked, but there were thumbnail entries under the "Caching" tab.
After I enabled caching, removed all entries, then disabled caching again, it didn't create more entries.

Until I re-enabled caching - then it created new entries.
So now I'm confused. Is there a bug where it creates entries regardless of whether caching is disabled, until that option is toggled at least once?
Maybe I changed another seemingly unrelated option, that changed caching thumbnails behavior?

Post Reply