0.69 x64 Focus on switch Browser > Viewer > Browser

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
User avatar
Grismar
Posts: 2
Joined: Thu Jan 29, 2009 1:08 pm
Location: The Hague
Contact:

0.69 x64 Focus on switch Browser > Viewer > Browser

Post by Grismar » Sat Nov 08, 2014 9:00 am

When using the hotkey assigned (in my case, Enter) to switch from browser to viewer and then hitting it again to switch back to browser, the focus on the previously selected thumbnail is lost.

Steps to reproduce (only tested on XNViewMP 0.69 x64) :
- configure XNViewMP to have a layout from left to right of: Folders, Thumbnails, Preview
- browse to a folder containing multiple images
- select an image and verify that navigation with cursor keys is working (works)
- hit Enter (or assigned hotkey) to switch to Viewer
- hit Enter (or assigned hotkey) again to switch back to Browser
- without selecting an image first (previously selected image is still selected), verify that navigation with cursor keys is working (DOESN'T WORK)

After selecting the thumbnail pane with the mouse, cursor navigation works again, so it seems like a loss of focus occurs for the thumbnails pane.

The problem also occurs when navigating to another image in viewer mode and then returning to browser: the newly selected image is selected in the Thumbnails pane, but focus is lost.

Greetings,
Jaap van der Velde (aka Grismar).

User avatar
xnview
Author of XnView
Posts: 33615
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.69 x64 Focus on switch Browser > Viewer > Browser

Post by xnview » Mon Nov 10, 2014 8:58 am

yes a known issue
Pierre.

bitz4
Posts: 36
Joined: Sun Apr 18, 2010 5:03 am

Re: 0.69 x64 Focus on switch Browser > Viewer > Browser

Post by bitz4 » Tue Nov 18, 2014 4:38 pm

Related just that in my case it's - hit ESC (or assigned hotkey) again to switch back to Browser.

This issue (mine) wasn't present in the previous public release. IDK what it was 0.64 or 0.61? Every time I've exited an image with ESC back to the Browser the focus was there. Now, I have to either go back to that version (if I still have it) or make a habit of pressing tab after pressing ESC.
MP 0.90 x64, Win 7 64-bit

bitz4
Posts: 36
Joined: Sun Apr 18, 2010 5:03 am

Re: 0.69 x64 Focus on switch Browser > Viewer > Browser

Post by bitz4 » Sun Nov 23, 2014 2:12 am

Grismar wrote:the focus on the previously selected thumbnail is lost
While Pierre figures it out and until the fixed version comes out, I've written an AutoHotKey script launcher to fix the issue.

The launcher is a separate exe file, it launches xnview_.exe, operates on it and closes when there are no more XnView windows visible.

What it does is it sends a tab key to XnView window whenever the user releases the Esc or Enter keys. This way, if the user enters the browser view, either with Enter or with Esc, the selected image gets focused and arrow keys can be used. There are no mouse checks so if a double-click is used to enter the browser view, then there will probably be no focus on it.

To use the launcher, just rename the original xnview.exe to xnview_.exe, and add XnView.exe (my launcher) in the same dir. This way the file associations for image types don't have to be changed and it will integrate smoothly.

https://www.dropbox.com/s/zkw3x88mzwih3 ... r.rar?dl=0

Edit: made a mistake, accidentally I've compiled a ANSI exe, instead of a UNICODE one, and unicode file names were making problems, now I've reuploaded the proper UNICODE exe.
MP 0.90 x64, Win 7 64-bit

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.69 x64 Focus on switch Browser > Viewer > Browser

Post by helmut » Fri Mar 03, 2017 9:22 pm

This problem is supposed to be fixed. Could you please try and confirm the bug fix, Grismar?

Post Reply