Problem with GIF images and image background color

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
gagala
Posts: 7
Joined: Sat Feb 28, 2015 9:01 am

Problem with GIF images and image background color

Post by gagala »

Take a GIF image and open it, setting (Edit, Background color...) is unchanged (RGB: 255,255,255 = white), now mark a field per mouse and press DEL. The deleted field appears in black instead in white.
This doesn't appear on JPG or PNG images.
Weird is that this doesn't happen with every GIF image. Seems the GIF version (87a, 89a) doesn't matter. I can't find out what the difference is that makes the most work false.


XnViewMP
Version 0.72 x32 (Dec 19 2014)

Distributor ID: ManjaroLinux
Release: 0.8.12
Codename: Ascella

P.S.
I've tried several small images to upload as attachment, but the server tell me, that the pic cannot be displayed, because it contains errors. So I added a screenshot. No clue, what kind of error is meant, but except the mentioned problem I never had trouble with my GIF images.
Attachments
Screenshot_2015-04-22_16-57-50.gif
The same file of the screenshot.
The same file of the screenshot.
sample.gif (5.31 KiB) Viewed 702 times
User avatar
xnview
Author of XnView
Posts: 34090
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem with GIF images and image background color

Post by xnview »

i think that it's caused by colormap, please post the gif
Pierre.
cday
XnThusiast
Posts: 2569
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Problem with GIF images and image background color

Post by cday »

xnview wrote:i think that it's caused by colormap, please post the gif
gagala wrote:I've tried several small images to upload as attachment, but the server tell me, that the pic cannot be displayed, because it contains errors.
You should be able to upload more or less any file in a ZIP attachment...
User avatar
XnTriq
Moderator & Librarian
Posts: 5618
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Problem with GIF images and image background color

Post by XnTriq »

This seems to be the same bug as in XnView Classic: “XnView kills GIF images in VM
gagala wrote:I've tried several small images to upload as attachment, but the server tell me, that the pic cannot be displayed, because it contains errors. So I added a screenshot. No clue, what kind of error is meant, but except the mentioned problem I never had trouble with my GIF images.
sample.gif is corrupted. Could you please compress the original/unedited/uncropped image and upload the archive, gagala?
gagala
Posts: 7
Joined: Sat Feb 28, 2015 9:01 am

Re: Problem with GIF images and image background color

Post by gagala »

Added the sample file as 7zip file.
Maybe I should mention, that all my gif files once have been jpg files, cropped and converted by XnView classic, but many versions ago.
Attachments
sample.gif.7z
(5.33 KiB) Downloaded 22 times
User avatar
XnTriq
Moderator & Librarian
Posts: 5618
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Problem with GIF images and image background color

Post by XnTriq »

gagala wrote:Added the sample file as 7zip file.
Thanks.

@Pierre: Have you found the cause for this bug?
  1. Open app-xnview-512.png with XnView.
  2. Go to Image » Convert to Grey » 8 Grey scale.
  3. Select a random area in the image and go to Edit » Clear.
  4. Save the result as app-xnview-512.gif.
User avatar
xnview
Author of XnView
Posts: 34090
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problem with GIF images and image background color

Post by xnview »

XnTriq wrote: @Pierre: Have you found the cause for this bug?
yes :)
Pierre.
Post Reply