0.84b2 freezes too when viewing 20.000+ video files

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Locked
jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

0.84b2 freezes too when viewing 20.000+ video files

Post by jadO »

This version keeps freezing like 0.82, 0.83, 0.84b1 and 0.84b2.
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.84b2 Freezes too

Post by Erixx haxx »

Hello:

I just wanted to say I had a problem with 3-4 .mp4 video files Just now. Every time I entered their folders xnview would freeze with "Not Responding" msg.
It locked up to the point I had to kill it every time. This was in 3 different folders. I tried 20+ times with same result.

-I tried all versions back to v0.79. (v0.81 - v0.79)
-v0.79 Was the only version that would not freeze. Not only that, It played the video files fine also.

-I'm not using ffmpeg
-auto select 1st file was on
-I also noticed the preview panel had a white background even though it was set to black. other videos show the correct background.
-I was able to get xnview 0.84 to stop freezing by re-encoding the problem files. (Finding what files were the cause was a PAIN)

Thanks

Win7x64 pro
User avatar
xnview
Author of XnView
Posts: 33839
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84b2 Freezes too

Post by xnview »

jadO wrote:This version keeps freezing like 0.82, 0.83, 0.84b1 and 0.84b2.
when?
Pierre.
User avatar
xnview
Author of XnView
Posts: 33839
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84b2 Freezes too

Post by xnview »

Erixx haxx wrote: I just wanted to say I had a problem with 3-4 .mp4 video files Just now. Every time I entered their folders xnview would freeze with "Not Responding" msg.
It locked up to the point I had to kill it every time. This was in 3 different folders. I tried 20+ times with same result.
You have a freeze when auto playing video? Do you have tried with VideoMode=true?
Pierre.
jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.84b2 Freezes too

Post by jadO »

Erixx haxx wrote:Hello:

I just wanted to say I had a problem with 3-4 .mp4 video files Just now. Every time I entered their folders xnview would freeze with "Not Responding" msg.
It locked up to the point I had to kill it every time. This was in 3 different folders. I tried 20+ times with same result.

-I tried all versions back to v0.79. (v0.81 - v0.79)
-v0.79 Was the only version that would not freeze. Not only that, It played the video files fine also.

-I'm not using ffmpeg
-auto select 1st file was on
-I also noticed the preview panel had a white background even though it was set to black. other videos show the correct background.
-I was able to get xnview 0.84 to stop freezing by re-encoding the problem files. (Finding what files were the cause was a PAIN)

Thanks

Win7x64 pro
Thanks for your message.

You know what the problem is: I don't have those freezes with version 0.81.
It started with 0.82 and remained in 0.83 and 0.84.

Unfortunately Pierre refuses to create intermediate builds between 0.81 and 0.82 which would help to nail down this issue. In this regards 0.81 works absolutely fine and I never have the freezing issue like in 0.82.
User avatar
xnview
Author of XnView
Posts: 33839
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84b2 Freezes too

Post by xnview »

jadO wrote: Unfortunately Pierre refuses to create intermediate builds between 0.81 and 0.82 which would help to nail down this issue. In this regards 0.81 works absolutely fine and I never have the freezing issue like in 0.82.
The freeze when launching external program??
I can't make intermediate build between 0.81 & 0.82, and there is no change on video code
Pierre.
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.84b2 Freezes too

Post by Erixx haxx »

jadO wrote:You know what the problem is: I don't have those freezes with version 0.81.
It started with 0.82 and remained in 0.83 and 0.84.
Hi:
It's possible your seeing a different issue. I just thought I'd post what I was seeing because maybe it was related to your problem.
Why I think that now is because I tried v0.81 and still had the same issues. I skipped v0.80 and tried v0.79 then it worked fine.

Usually devs need to be able and reproduce the problem on their own machine and run a debug version to track down the bugs,
I do hope we get it sorted out though.

Not sure if it'll have any effect, but have you tried the videoMode=true switch yet. Maybe worth a shot.

Thanks
Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.84b2 Freezes too

Post by Erixx haxx »

Hello:
xnview wrote:You have a freeze when auto playing video?
Negative, I have only "auto select first item" ticked. No autoplay, It freezes just by entering the folder.
XnView wrote:Do you have tried with VideoMode=true?
I just found some more troubled video file folders.
I tried this and it did indeed correct the problem I was having with xnview totally locking up.

Too bad we still have a few bugs with this mode.
0.81: VideoMode Set True Bug

At least I'm not freezing anymore though.


Thanks
jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.84b2 Freezes too

Post by jadO »

xnview wrote:The freeze when launching external program??
I can't make intermediate build between 0.81 & 0.82, and there is no change on video code
I don't know if the freeze is connected to an external application.
All I can say is this: With 0.81 I don't have those freezes. Starting with 0.82 on the very same computer, the freezes started to occur.
Even when your saying you did not change video code in XnViewMP something that was changed from 0.81 to 0.82 is causing theses freezes.
User avatar
xnview
Author of XnView
Posts: 33839
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84b2 Freezes too

Post by xnview »

jadO wrote:
xnview wrote:The freeze when launching external program??
I can't make intermediate build between 0.81 & 0.82, and there is no change on video code
I don't know if the freeze is connected to an external application.
All I can say is this: With 0.81 I don't have those freezes. Starting with 0.82 on the very same computer, the freezes started to occur.
Even when your saying you did not change video code in XnViewMP something that was changed from 0.81 to 0.82 is causing theses freezes.
when do you have freezing? when creating thumbnails in browser? when playing? Do you have tried with videomode=true?
Pierre.
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84b2 Freezes too

Post by helmut »

xnview wrote:... when do you have freezing? when creating thumbnails in browser? when playing? Do you have tried with videomode=true?
Correct me if I'm wrong, but from what I can see this topic is just a repetition of the discussions held in topics:
- Out of memory when recursive viewing 20.000+ videos
- 0.81: Frequent crashes when video thumbnailing with ffmpeg

Please continue discussions in those two topics. In case there should be a new and different bug, please start a new topic in forum "MP - Bug Reports". This topic will be archived on 8th Dec. 2016.
jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.84b2 Freezes too

Post by jadO »

helmut wrote:Correct me if I'm wrong, but from what I can see this topic is just a repetition of the discussions held in topics:
- Out of memory when recursive viewing 20.000+ videos
- 0.81: Frequent crashes when video thumbnailing with ffmpeg
No I mentioned it here in regards to v082: http://newsgroup.xnview.com/viewtopic.php?f=62&t=33763

Now it is still present in v084
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84b2 Freezes too

Post by helmut »

jadO wrote:... No I mentioned it here in regards to v082: http://newsgroup.xnview.com/viewtopic.php?f=62&t=33763

Now it is still present in v084
O.k.. Please continue discussion in that topic.

<Moderator's note: This topic is a duplicate and has been locked. Please add new posts in the other topic.>
Locked