Affichage de la colonne "commentaire" perturbé.

Questions générales en Français

Moderators: XnTriq, xnview

Post Reply
ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Sat Aug 18, 2018 2:49 pm

Bonjour,
Je remarque depuis quelque temps une chose étrange : en mode navigateur, Afficher/afficher/détails (c'est mon choix depuis toujours), la colonne "Commentaire" n'affiche plus les commentaires (commentaires intégrés). Ils sont pourtant toujours présent dans les fichiers. Je peux le voir via l'option "Editer description/commentaire", et d'autres softs les voient aussi. Dont XnviewMP, PaintShop, PhotoFiltre...

J'ai découvert qu'ils apparaissent si je bascule en Affichage/Afficher en miniature ou Affichage/Afficher en miniature et infos. Lorsque je reviens alors en mode détails, ils restent visibles. Si je change de répertoire, je dois refaire la manip'.


Ce qui est ci dessus est bien établi... Ce qui suit est peut-être du à ma "parano" (ou à mon grand âge ! :D ). Je le signale si ça peut aider à localiser le problème : je connais bien mes fichiers, et il me semble que certains commentaires ont totalement disparu -et là quelle que soit l'option d'affichage. Je ne retrouve pas certains commentaires que je suis quasi certain d'avoir saisis il y a longtemps. (ce qui me semble impossible car je parle toujours de commentaire internes !).
De même, certains commentaires que je n'avais jamais remarqués avant, apparaissent en nombre. Je suis pratiquement sûr qu'ils n'apparaissaient pas, j'ai en effet souvent utilisé le tri de la colonne "commentaire" (Affichage/Disposer par/commentaire(interne)
)
Ces "nouveaux commentaires" sont essentiellement du genre "CompuPic(R) - Photodex Corporation", "CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), quality = 85", "Intel(R) JPEG Library, version 1,5,4,36"


J'utilise la version 2.45 mais je suis incapable de dire quand ce comportement est apparu et s'il est lié à son installation.
De façon certaine, il y a 8 mois, tout fonctionnait.

Dois-je réinstaller la version en cours, attendre la suivante, changer des paramètres ?

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Sun Aug 19, 2018 10:31 am

Bonjour,

Concernant les commentaires que je pensais disparus, ou modifiés (2eme volet de ma question) : J'ai utilisé un éditeur hexa sur les fichiers que je pensais concernés. Je ne trouve effectivement pas dans les en-tête les commentaires que je pensais y avoir stocké.
(Peut-être un souci lors d'une modification graphique avec un logiciel tiers, mais je ne me souviens pas avoir retouché autant de fichiers)

Xnview n'est en tout cas pas en cause pour ce "problème" et ma "parano" est confirmée ! :mrgreen:

Le premier volet de ma question (commentaires non affichés dans la colonne commentaire) reste lui bien d'actualité.

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de la colonne "commentaire" perturbé.

Post by xnview » Tue Aug 28, 2018 9:09 am

donc en details vous ne voyez plus les commentaires intégrés?
Pierre.

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Sat Sep 01, 2018 4:54 pm

Bonjour Pierre,

En effet, je ne vois plus les commentaires en mode détail.
Bien sûr la colonne commentaire est visible elle, mais aucun commentaire n'y apparaît, sauf à effectuer la manœuvre mentionnée plus haut.

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de la colonne "commentaire" perturbé.

Post by xnview » Mon Sep 03, 2018 3:19 pm

pourriez vous m'envoyer un fichier image exemple?
Pierre.

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Tue Sep 04, 2018 10:36 pm

Voilà un exemple. Comportement typique : En "détail", commentaire invisible. Après passage en mode miniature (ou miniature info), le commentaire est visible en mode détail. Un simple changement de répertoire et retour fait "perdre" à nouveau le commentaire. (Le fichier concerné et 3 copies écran jointes)
Attachments
0343.jpg
0342.jpg
0341.jpg
affiche-je-suis-toi.jpg

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de la colonne "commentaire" perturbé.

Post by xnview » Wed Sep 05, 2018 8:59 am

des que vous changez de repertoire, plus de commentaire? je n'arrive pas à reproduire, le commentaire est toujours là
Pierre.

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Thu Sep 06, 2018 4:26 pm

Je résume :
Pas de commentaires affichés dans la colonne commentaires en mode détail, ceci dès le lancement de Xnview. Et quelque soit le mode utilisé pour le lancement (Menu contextuel de Windows Parcourir avec Xnview / Double clic sur une image / Lancement d'Xnview indépendamment puis parcours)

Les commentaires réapparaissent en mode détails après avoir basculé temporairement soit en Miniatures soit en Miniatures et libellés soit en Miniatures et infos (mais pas en Icônes ni en liste)

Et oui, lorsque je change de répertoire, plus de commentaires. Même si je reviens dans celui précédemment "réparé" par la manœuvre ci-dessus.

Peut être un soft tiers qui parasite le fonctionnement d'Xnview (hook, dll...) ?

Edit : Ma dernière phrase m'a incité à tenter un réinstallation de Xnview, ce que je viens de faire (La dernière version, en "full"). Aucune amélioration.

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de la colonne "commentaire" perturbé.

Post by xnview » Mon Sep 10, 2018 7:57 am

essayez de faire 'reconstruire les vignettes' sur ces images?
Pierre.

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Thu Sep 13, 2018 9:59 pm

"Reconstruire les miniatures" ne fait pas re-apparaître les commentaires lorsqu'ils sont invisibles.
En revanche ils disparaissent par cette manoeuvre quand ils ont été affichés auparavant (par la méthode Détails -> Miniatures et info -> détails)

J'ai installé il y a 3 mois un plugin (logiciel CosmeticGuide/tintguide.com) que j'ai rapidement désinstallé, il ne fonctionnait pas. Cela aurait-il provoqué le problème ? Merci en tout cas Pierre de vous intéresser à cette bizarrerie !

C'est vraiment le mode "détails" qui est affecté.
En effet les commentaires sont affichés :
- Lorsque je démarre en mode Miniatures+info.
- en plein écran, lorsque je sélectionne dans les paramètres l'option afficher les informations (Tag <Comment>)
- dans l'Aperçu, option Propriétés.

Lorsque je crée un commentaire en mode détails il n’apparaît pas spontanément... je dois opérer là aussi la même manœuvre.

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de la colonne "commentaire" perturbé.

Post by xnview » Mon Sep 17, 2018 5:32 am

Pourriez vous essayer de renommer category.db & xnview.db?
Pierre.

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Wed Sep 26, 2018 10:15 pm

Pardon Pierre pour le délai à la réponse, obligations professionnelles...

J'ai renommé les fichiers demandés. Ils sont recrées au lancement suivant (sans doute est-ce ce que vous visiez ?).
Mais aucun changement de comportement ni amélioration sur l'affichage des commentaires malgré la re-création de category.db et xnview.db. (J'ai essayé plusieurs fois...)

En revanche j'ai une autre info qui peut vous "aiguiller"... ou vous désespérer. :?

Depuis très longtemps par habitude, je n'affiche dans l"explorateur Xnview que les colonnes "Nom", "Taille", "Date" et "Commentaire"; Or j''ai fait il y a quelques jours l'essai en affichant toutes les colonnes (toujours en mode 'Détail') et j'ai constaté qu'il y a plusieurs colonnes qui présentent le même comportement que "Commentaire".
Il s'agit de "Propriétés", "Taille d'impression" et "Type"... Rien n’apparaît dans ces colonnes, sauf si je bascule en miniature+infos et retour en mode détail auquel cas leur contenu devient visible.
Les "Encoches" (si j'encoche un fichier) et le "Dossier" sont affichés normalement dès le lancement. Et le contenu de la colonne "Description" reste visible normalement aussi, si j'en saisi un.

Pour "Notation" et "Libellé couleur", je ne suis sûr de rien, rien n’apparaît quelque soit la manip effectuée. Mais je ne sais pas ce qui doit être affiché normalement dans ces colonnes. J'ai bien dans le menu contextuel une rubrique Notation mais tous les choix possibles sont grisés et un clic sur les encoches n'a aucun effet.

Notation.jpg

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Affichage de la colonne "commentaire" perturbé.

Post by xnview » Thu Sep 27, 2018 8:47 am

Vraiment etrange, serait t'il possible de renommer le xnview.ini?
Pierre.

ubik3
Posts: 10
Joined: Tue Jan 05, 2016 11:12 pm

Re: Affichage de la colonne "commentaire" perturbé.

Post by ubik3 » Sat Sep 29, 2018 12:39 am

Bingo ! Ce coup ci on y est ! :)

J'ai renommé le fichier ini, et j'ai retrouvé un comportement normal. Vous avez mis le doigt dessus, le fichier xnview.ini était sans doute corrompu.
J'avais il y a quelques semaines modifié les paramètres de localisation du .ini et même choisi l'option base de registre. En tâtonnant, j'étais presque sur la solution ! Si j'avais été plus entreprenant alors, ça m'aurait évité de vous ennuyer avec ce problème.

Je viens de passer un bon moment à re-paramétrer l'ensemble pour retrouver mes réglages habituels et vérifier ainsi que cette combinaison de réglages ne provoquait pas le problème à nouveau. Mais tout fonctionne bien.

L'occasion pour moi de vous remercier une fois de plus pour nous avoir offert ce logiciel. Ainsi que pour votre disponibilité dont je viens d'avoir une sympathique confirmation. Merci encore.

Cordialement.
Alex

Post Reply