Thick bar sometimes appears on the side of XnView...

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

ghost zero
Posts: 349
Joined: Mon Feb 05, 2007 8:26 pm

Re: Thick bar sometimes appears on the side of XnView...

Post by ghost zero » Sun Sep 09, 2018 2:52 am

i just upgraded from xnview 2.39 to 2.46 and was very surprised to find out this has been fixed! do you know what change was made to xnview to fix it or was it fixed by accident?

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thick bar sometimes appears on the side of XnView...

Post by xnview » Mon Sep 10, 2018 6:55 am

ghost zero wrote:
Sun Sep 09, 2018 2:52 am
i just upgraded from xnview 2.39 to 2.46 and was very surprised to find out this has been fixed! do you know what change was made to xnview to fix it or was it fixed by accident?
not by accident :)
Pierre.

ghost zero
Posts: 349
Joined: Mon Feb 05, 2007 8:26 pm

Re: Thick bar sometimes appears on the side of XnView...

Post by ghost zero » Mon Sep 10, 2018 8:13 am

so did you figure out what was causing the bug?

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thick bar sometimes appears on the side of XnView...

Post by xnview » Mon Sep 10, 2018 9:36 am

ghost zero wrote:
Mon Sep 10, 2018 8:13 am
so did you figure out what was causing the bug?
i've found a workaround
Pierre.

ghost zero
Posts: 349
Joined: Mon Feb 05, 2007 8:26 pm

Re: Thick bar sometimes appears on the side of XnView...

Post by ghost zero » Mon Sep 10, 2018 10:47 am

is it easy to explain your workaround method? there is another program [XYplorer] that has a similar bug, so i would like to forward your workaround method to that developer for a fix.

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thick bar sometimes appears on the side of XnView...

Post by xnview » Tue Sep 11, 2018 7:36 am

the problem comes from WS_THICKFRAME applied on MDI child
Pierre.

ghost zero
Posts: 349
Joined: Mon Feb 05, 2007 8:26 pm

Re: Thick bar sometimes appears on the side of XnView...

Post by ghost zero » Thu Aug 08, 2019 8:23 pm

i just upgraded from xnview 2.46 to 2.48 and noticed the bug is back again with the thick bar! :( can you fix it again?

User avatar
xnview
Author of XnView
Posts: 32052
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thick bar sometimes appears on the side of XnView...

Post by xnview » Fri Aug 09, 2019 7:51 am

do you have added

Code: Select all

[Start]/BugBlueLine=1
Pierre.

ghost zero
Posts: 349
Joined: Mon Feb 05, 2007 8:26 pm

Re: Thick bar sometimes appears on the side of XnView...

Post by ghost zero » Fri Aug 09, 2019 9:28 am

nope, i never added that. what does that do?

ghost zero
Posts: 349
Joined: Mon Feb 05, 2007 8:26 pm

Re: Thick bar sometimes appears on the side of XnView...

Post by ghost zero » Thu Sep 05, 2019 4:46 pm

xnview wrote:
Fri Aug 09, 2019 7:51 am
do you have added

Code: Select all

[Start]/BugBlueLine=1
ok, now i added it to get rid of the bug. but why are you making us manually add the tweak to the xnview.ini to get rid of the bug? why not have it just be fixed by default, like previously?

Post Reply