Problems with Tools->Compare

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Problems with Tools->Compare

Post by herb »

Hello Pierre,

I use XnViewMP 0.92 64-bit on a Windows 7 system.

I have a directory with some *.jpg images.
Selecting 2 images and opening Tools->Compare an additional tab opens and shows the selected images and also an area that contains the thumbnails of all images available in selected directory.
This is ok, but
(1) in case of the directory does only contain some images, the thumbnails do only contain an icon.
(2) In case of the directory has >5 images the thumbnails show all images itself.

For case (1) the thumbnails can/must be rebuilt properly selecting: "no thumbnails" and then "thumbnails bottom/right".

Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

could you post a screenshot?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Problems with Tools->Compare

Post by herb »

Hello Pierre,

attached please find the requested screenshot.
At bottom of screenshot you see 5 thumbnails, that show only the icon of the assigned application.
In case of the directory contains > 5 images, each thumb will show the image itself.

Best regards
Herb
Attachments
Screenshot.zip
(94.52 KiB) Downloaded 59 times
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

you means that thumbnails are not built, right? and you can reproduce it always?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Problems with Tools->Compare

Post by herb »

Hello Pierre,

yes exactly.
How to collect better symptoms?

Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

i've tried on Windows 7, and can't reproduce with 0.92
Do you use catalog?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Problems with Tools->Compare

Post by herb »

Hello Pierre,

Yes I use a catalog; BUT I do not store the thumbnails.

For a test I switched "Store thumbnails" ON and I could not reproduce the problem.

Best regards
Herb
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Problems with Tools->Compare

Post by herb »

Hello Pierre,

Sorry to say, but the problem is still there in version 0.93.
To remember I use Win 7 64bit.

Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

could you try with a clean ini (save your current .ini)
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Problems with Tools->Compare

Post by herb »

Hello Pierre,

thanks for your investigations.

Yes you are right: Starting with a fresh xnview.ini file the problem does not occur.
So I feeled free to send you my xnview.ini file for further investigations.

Hoping that it will help and thanks in advance
Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

i've tried with your .ini, and can't reproduce. If you enable settings>Catalog>Use thumbnails caching?
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Problems with Tools->Compare

Post by herb »

Hello Pierre,

I followed your suggestions; started with the xnview.ini file (as sent to you) and then I checked Tools->Catalog->Use thumbnail chaching.
Now I marked 2 *.jpg images and opened Tools->Compare. The result was: all thumbnails were displayed as expected.
I restarted XnViewMp and with Tools->Compare all thumbnails were displayed again.

Now I optimized my database and "Delete Thumbnails" was checked.
Now I repeated the "compare test" and no thumbnails were displayed ( as long as only <= 5 jpg images were stored in directory).

Thanks for your investigations
Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

yes it seems that the problem comes when thumbnails caching is not activated
Pierre.
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

See issue for current status and some details.
Pierre.
User avatar
xnview
Author of XnView
Posts: 34096
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Problems with Tools->Compare

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.
Post Reply