[MAC] Drag & drop to 3rd party application doesn't work as expect

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
yeoman
Posts: 2
Joined: Sat Feb 02, 2019 4:01 pm

[MAC] Drag & drop to 3rd party application doesn't work as expect

Post by yeoman » Sat Feb 02, 2019 4:17 pm

Drag & drop doesn't work as expect when it happens to 3rd party applications, e.g Lightroom, WeChat...
I've sent email to Pierre-e several weeks ago. I'm here reporting again, since fixing this will definitely help me a lot for daily picture management.
Actually I found other users also reported this issue when drag drop to outlook, I believe that is defintely the same thing.

Below is what I sent in the email (Ref. to the email I send in 1/16/2019 for the screenshot):
There is an issue when we drag & drop files from XnView to 3rd party applications. Seems there are some differences between Finder and XnView for the action of drag & drop.
The screenshot below shows what happened when I drag files through Finder:


And then you will find these files will be selected automatically in Lightroom. That is awesome because it will not need me to choose them out again in Lightroom.


But as you know, I will never use Finder to manage my pictures, I use XnView instead.
Unfortunately, when I try to do the same thing through XnView, nothing happened, that disappointed me.....

There is another scenario shows the same issue.
I can use drag & drop to send picture through Finder in WeChat chat window.But while I trying to use XnView to do the same thing,


It shows up the file path instead of sending out the picture. This also disappointed me.....
I will appreciate if you can help to find the root cause and make the enhancement. This will definitely help and save me a lot of time.

User avatar
xnview
Author of XnView
Posts: 31597
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [MAC] Drag & drop to 3rd party application doesn't work as expect

Post by xnview » Mon Feb 04, 2019 1:45 pm

yeoman wrote:
Sat Feb 02, 2019 4:17 pm
Actually I found other users also reported this issue when drag drop to outlook, I believe that is defintely the same thing.
No, it was for XnView Classic
Below is what I sent in the email (Ref. to the email I send in 1/16/2019 for the screenshot):
You had a reply from me??
Pierre.

User avatar
m.Th.
XnThusiast
Posts: 1545
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: [MAC] Drag & drop to 3rd party application doesn't work as expect

Post by m.Th. » Mon Feb 11, 2019 7:55 am

Pierre needs to upgrade the Qt to 5.12 LTS - see https://en.wikipedia.org/wiki/Qt_version_history
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
xnview
Author of XnView
Posts: 31597
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [MAC] Drag & drop to 3rd party application doesn't work as expect

Post by xnview » Sat Feb 16, 2019 1:22 pm

m.Th. wrote:
Mon Feb 11, 2019 7:55 am
Pierre needs to upgrade the Qt to 5.12 LTS - see https://en.wikipedia.org/wiki/Qt_version_history
?? Why
Pierre.

User avatar
m.Th.
XnThusiast
Posts: 1545
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: [MAC] Drag & drop to 3rd party application doesn't work as expect

Post by m.Th. » Tue Feb 19, 2019 4:03 pm

xnview wrote:
Sat Feb 16, 2019 1:22 pm
m.Th. wrote:
Mon Feb 11, 2019 7:55 am
Pierre needs to upgrade the Qt to 5.12 LTS - see https://en.wikipedia.org/wiki/Qt_version_history
?? Why
The https://bugreports.qt.io/browse/QTBUG-62662 is fixed in 5.10 Alpha. 5.12 is LTS.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

Post Reply