0.92: Browser view areas goes black, restart required

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
jstrom
Posts: 3
Joined: Sun Oct 14, 2018 6:48 pm

0.92: Browser view areas goes black, restart required

Post by jstrom » Sun Oct 14, 2018 7:03 pm

XNView MP Version 0.92 64bits (Sep 18 2018)
OS: Mac OS 10.11.6, Macbook Pro 13" Early 2015; Intel Iris Graphics 6100 1536 MB

After using XnView MP a while, just browsing around images back and forth (have not found any single way to reproduce it) parts of the window goes black and software is unusable until restarted.

Effect: Display gltich, see attached image. No crash, but program unusable.

To reproduce:
Browsing images, tagging a bit, using left/right arrow between images/video files etc. Cmd-tab back/forth to other apps..
... unfortunately nothing explicit :/

The directory I'm browsing is images from my Samsung S8, JPEGs typically ~4-5MB, 4032x1960. 2959 images currently in this dir (yeah I know...), browsing normally goes smooth.

Actual behaviour (bug): Display going black.
Expected behaviour: Display not going black.
______________________________________________________
Attachments
Screen Shot 2018-10-14 at 20.57.06.png

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Browser view areas goes black, restart required

Post by xnview » Mon Oct 15, 2018 5:16 am

:shock: and you had it more than once?
Pierre.

jstrom
Posts: 3
Joined: Sun Oct 14, 2018 6:48 pm

Re: 0.92: Browser view areas goes black, restart required

Post by jstrom » Sat Mar 09, 2019 12:34 pm

Hi,

sorry did not get a notification about the response :/

Yes, the problem persist. Not sure on that Macbook pro, don't use it there as often as on my other Mac but I always, and still have the issue on my desktop running MacOS High Sierra 10.13.6, on a NVidia GeForce GTX 970. Never had any other graphics glitches in any other apps.


Today running with 0.93.1, and while just sorting, previewing and moving around files, nothing advanced, the UI hangs every now and then. Sometimes it goes black, sometimes it just stops updating the views. For example, in some case the scrollbar in browser showed movement, but the actual thumbnails/files where frozen.

During this mornings session I think I've had to restart it 10 times or so.. :/ While it's quick to restart, it's quite a bit of irritation.

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Browser view areas goes black, restart required

Post by xnview » Mon Mar 11, 2019 3:01 pm

do you have played video file?
Pierre.

jstrom
Posts: 3
Joined: Sun Oct 14, 2018 6:48 pm

Re: 0.92: Browser view areas goes black, restart required

Post by jstrom » Tue Mar 12, 2019 6:23 am

If I had played video file as part of browsing? Yes, there have been some video files present in the different directories. Tried to reproduce just now by moving around in a directory with zero video files, and it never showed the problem. Moved to another directory which did have video files, and after a while it showed up.. But I would not draw any definitive conclusions from this.

In general, it was a bit tricky to reproduce it today.. I'll try to see if I can reproduce it quicker/more reliably on my laptop later today.



While talking about video files and preview, if I move around the browser window and pressing left/right arrow, when hitting a video file it automatically starts playing in the preview (as expected). If I move to the next file, and it is a video, that one starts playing instad. But, if the next file happens to be a picture instead of a video, the video seems to continue playing in the background. The preview shows the newly selected image, but the audio from the video is still playing in the background. Might very well be some bug report on this already, haven't searched!

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Browser view areas goes black, restart required

Post by xnview » Tue Mar 12, 2019 8:33 am

I know that there is some strange problem with video playing
Pierre.

User avatar
foxyshadis
Posts: 384
Joined: Sat Nov 18, 2006 8:57 am

Re: 0.92: Browser view areas goes black, restart required

Post by foxyshadis » Mon Apr 15, 2019 6:05 am

FWIW, Qt 5.10 and up are supposed to have a ton of fixes for HiDPI display and GPU rendering issues, which might be related. XnView is currently on 5.9; now that there's a 5.12 LTS tagged that might be the way to go.

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Browser view areas goes black, restart required

Post by xnview » Mon Apr 15, 2019 1:22 pm

foxyshadis wrote:
Mon Apr 15, 2019 6:05 am
FWIW, Qt 5.10 and up are supposed to have a ton of fixes for HiDPI display and GPU rendering issues, which might be related. XnView is currently on 5.9; now that there's a 5.12 LTS tagged that might be the way to go.
The problem with 5.12 is that only MacOS 10.12+ is supported
Pierre.

Post Reply