Mouse-wheel makes fun…

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Mouse-wheel makes fun…

Post by Clo » Sat Jul 23, 2005 6:46 am

:) Hello !

- A strange (funny) bug I found out :
• First : be sure that the mouse wheel isn't used anywhere for the zooming operations.
1. Open any image dir. containing some animated GIFs in the Browser,
2. Select one …
3. Play with the mouse-wheel : you might get a blown-up frame of the selected animated GIF in the preview,
4. Just wait a few seconds : you will see the pic as its original size 1/1, embedded into the blown up frame in the preview :!:
5. The animation continues to run in the 1/1 image, though :evil:

Something like this :

——————————————Image

• I think it's a :bug: …:P

- Win 98 SE - XnView 1.80.1

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sat Jul 23, 2005 2:40 pm

Confirmed :bugconfirmed: , this bug is present also in Fullscreen "lite" (press F11 in the browser) and also with LMB+wheel zoom option.
Dreamer

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

2in1

Post by Clo » Sun Jul 24, 2005 6:48 pm

:arrow: Dreamer

:) Hello !
- This occurs too for me with NUM+ in the browser preview and in the "Light" Full screen from the preview.
But there, not with the MW.

- In fact, there are two bugs in one for me :
a) The MW works as a kind of “wild” default in the browser preview, while it should not,
since the MW is not configured for any zooming in the Options.

b) The GIF as 1/1 running its animation in the inopportune blown up frame is the rest of the issue…
• I noticed that it's more difficult to get the bug with so large GIFs, but it occurs too, though.

:mrgreen: Kind regards,
Claude
Clo
Last edited by Clo on Sun Oct 26, 2008 2:21 am, edited 1 time in total.
Old user ON SELECTIVE STRIKE till further notice

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: 2in1

Post by Dreamer » Sun Jul 24, 2005 9:08 pm

Clo wrote:a) The MW works as a kind of “wild” default in the browser preview, while it should not, since the MW is not configured for any zooming in the Options.
It's a new feature...

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

For me…

Post by Clo » Sun Jul 24, 2005 9:57 pm

:) For me, something boring you did not choose and that you cannot disable is not a “feature”, it's a Image

:mrgreen: K R
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32005
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Jul 25, 2005 12:44 pm

Dreamer wrote:Confirmed :bugconfirmed: , this bug is present also in Fullscreen "lite" (press F11 in the browser) and also with LMB+wheel zoom option.
ok, i can reproduce it, :bugconfirmed:
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Bug fixed, but not the "zoom-feature"---

Post by Clo » Tue Aug 30, 2005 6:55 pm

:arrow: Pierre

:) Hello !
• The original bug is fixed in 1.80.2 - about the embedded 1/1 image in a blown up frame - thank you !
- However, I've still the unwanted zooming of the preview with the mouse-wheel… while the wheel is set to scroll large images only :(

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: Bug fixed, but not the "zoom-feature"---

Post by Dreamer » Tue Aug 30, 2005 10:46 pm

Clo wrote:- However, I've still the unwanted zooming of the preview with the mouse-wheel… while the wheel is set to scroll large images only
I think it's a new feature, not a bug (and I think it's better).

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Disable if wanted

Post by Clo » Wed Aug 31, 2005 4:09 am

:) Hello !

- For me, better should be disabled; I don't like this at all.
The general setting of the mouse-wheel is not applied here, I can't disable this, and so it's a :bug: or at least a boring lacuna…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32005
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Bug fixed, but not the "zoom-feature"---

Post by xnview » Wed Aug 31, 2005 8:19 am

Clo wrote: - However, I've still the unwanted zooming of the preview with the mouse-wheel… while the wheel is set to scroll large images only :(
In option/View/keyboard, you have not zoom for mouse wheel???
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Abnormal---

Post by Clo » Wed Aug 31, 2005 8:58 am

:D Hi Pierre !
- I have not ! The mouse wheel is configured only to scroll the large images, like you can see below :

———————Image
- So, I don't understand why and from where a zooming by the mouse-wheel can work in the browser "Preview" area :P

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32005
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Abnormal---

Post by xnview » Wed Aug 31, 2005 9:02 am

Clo wrote::D Hi Pierre !
- I have not ! The mouse wheel is configured only to scroll the large images, like you can see below :

———————Image
- So, I don't understand why and from where a zooming by the mouse-wheel can work in the browser "Preview" area :P

:mrgreen: KR
Claude
Clo
Right, i use always the mouse wheel to zoom in the preview area...
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Please, a tick-box---

Post by Clo » Wed Aug 31, 2005 9:24 am

:arrow: Pierre

This can't be disabled, so what about something like this : "Disable zooming for Preview" ?

———————Image

- I use the keys NUM + or NUM – for zooming in the preview, and never the mouse-wheel in View…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Aug 31, 2005 9:47 am

I think the one and only solution here is to make mouse wheel in Preview and View mode behave the same. If the user sets "Previous/Next" file for mouse wheel in View mode, he/she should have this behaviour for the preview, too.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

For everybody…

Post by Clo » Wed Aug 31, 2005 7:27 pm

• Hi !
- Indeed, this sounds logical, and'ld do the trick for me.

- However, it seems that some users (and Pierre ?) like the current hard-coded behaviour; then, the tick-box could satisfy everybody… Or else (although you don't like this…), an extra entry for the INI file should be convenient too; the benefit is that Pierre is not bound to change the interface…

:mrgreen: G
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

Post Reply