[0.94] Annoying mouse scrolling bug

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

[0.94] Annoying mouse scrolling bug

Post by jadO » Sun Dec 08, 2019 9:08 am

I think it started with 0.93. In browser view when scrolling to the bottom of a folder either by mouse wheel, scroll bar or keyboard the mouse wheel ceases to work and I can no longer scroll back up with it. This is thumbnail view and it seems that somehow the mouse gets locked displaying the last 3 rows of thumbnails. Once I move up manually into 4th row the mouse wheel starts to work again and I can scroll back up with it.

It seems that hitting the bottom triggers something that prevents the mouse wheel up function to work properly.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.94] Annoying mouse scrolling bug

Post by xnview » Sun Dec 08, 2019 10:30 am

i can't reproduce. You have always this problem? Windows 10?
Pierre.

jadO
Posts: 430
Joined: Wed Apr 29, 2015 6:36 am

Re: [0.94] Annoying mouse scrolling bug

Post by jadO » Mon Dec 09, 2019 6:53 am

xnview wrote:
Sun Dec 08, 2019 10:30 am
i can't reproduce. You have always this problem? Windows 10?
It seems to be tied to a setting in xnview.ini.
With thumbPadding=1 and above, scrolling is normal.
With thumbPadding=0 the scrolling shows the error.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [0.94] Annoying mouse scrolling bug

Post by xnview » Wed Dec 11, 2019 10:41 am

i can't reproduce with this setting
Pierre.

Post Reply