"Properties" column shows incorrect # of colors

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
JDB
Posts: 3
Joined: Fri Jan 10, 2020 12:56 pm

"Properties" column shows incorrect # of colors

Post by JDB » Fri Jan 10, 2020 1:40 pm

Subject: 0.94.2 -- "Properties" column shows incorrect # of colors

XnView: MP 0.94.2 64 bit
OS: Windows 7 64bit

When viewing images in the detailed list view, the Properties column always shows "16M" for 48-bit depth TIFF files. Perhaps it should show something like "281T". Or perhaps instead of translating bit depth to the number of colors, just show the number of bits, ie, 1, 8, 16, 24, 48, etc. Better yet, add more choices for columns to include: Bit Depth, Color Model (RGB vs. Grayscale), etc. Or allow any EXIF value to be displayed in a column.

Effect: I have a lot of scanned images that I like to keep in 48-bit uncompressed TIFF format. However, over time, I have made some errors and scanned some using 24-bit or 8-bit settings. I would like to be able to easily visualize which files need to be re-scanned. Since both 24 bit and 48 bit files show up as "16M", I cannot use the detail list view to do this. Using mouse-over popups, I can view the bit depth, but that's too cumbersome.

To reproduce:
1. Scan a photo at 48-bit depth and save as an uncompressed TIFF file. (or use the attachment I uploaded with this report)
2. View it with XnView MP with "View As" set to Details.
3. Right-click on the column header and add the "Properties" column.
4. Note that the properties show "16M".
5. Confirm that the bit depth is truly 48 by looking at the "# of bits" field in the Info section of the Properties panel at the bottom of the window.

Thank you for looking into this!
-JDB
Attachments
Sample48bit.tif
Sample 48-bit TIFF image. Small picture of a steamship from an old postcard.
(205.16 KiB) Downloaded 33 times

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "Properties" column shows incorrect # of colors

Post by xnview » Mon Jan 13, 2020 8:05 am

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "Properties" column shows incorrect # of colors

Post by xnview » Wed Mar 04, 2020 10:26 am

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "Properties" column shows incorrect # of colors

Post by xnview » Sat Mar 21, 2020 9:18 am

This problem is supposed to be fixed in XnView MP 0.96. Please check and confirm the bug fix here.
Pierre.

Post Reply