0.93.1 MP - Custom Hotkeys are forgotten

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
unqltango
Posts: 53
Joined: Sun Sep 01, 2019 8:16 am

0.93.1 MP - Custom Hotkeys are forgotten

Post by unqltango »

OS:W10
XnMP: 0.93.1

I'm not sure how to reproduce this and I can't check it now. I'll try to figure out proper steps to reproduce after work.

I did set up new hotkeys for Fullscreen (both in Browser and Viewer) and also added one for "Lock Zoom".
Later I noticed that none of them are working. I checked the Settings and the above mentioned Hotkeys were back to their Default value.
User avatar
xnview
Author of XnView
Posts: 33872
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1 MP - Custom Hotkeys are forgotten

Post by xnview »

are you able to reproduce?
Pierre.
unqltango
Posts: 53
Joined: Sun Sep 01, 2019 8:16 am

Re: 0.93.1 MP - Custom Hotkeys are forgotten

Post by unqltango »

xnview wrote: Tue Sep 03, 2019 2:12 pm are you able to reproduce?
I just got home. I tried to reproduce it, but I couldn't. Sorry about this, let's park this issue for now, if I figure out how to reproduce it, I'll write a detailed bugreport about it.

Thanks,
Tango
CleverPig
Posts: 8
Joined: Wed Oct 01, 2014 9:48 pm

Re: 0.93.1 MP - Custom Hotkeys are forgotten

Post by CleverPig »

True. I did not use Lock zoom feature at all, now I need it.
I tried to setup hot key for it, like ctrl+L or F9 or numpad 9 - none of them work. While other hotkeys work, at least those Save as or 100% zoom or enter fullscreen or resize image.

Dunno what about reproducing it though, I just tried it on 0.93.1 and it happens... Never used this for years before. Hot key is set up in settings and this hotkey does nothing. Win10 too.
Lock zoom itself works perfect way for me though, it retains lock for current session and reset after closing app instance, dunno if it should be that way, but it is right for me.

EDIT:

I've just found solution
this might look nontrivial, but shortcuts in XnView has TWO tabs within their settings, browser and viewer - default setup is for browser mode and obviously this has nothing to do with Lock Zoom, must set up hot key in both tabs or at least in viewer. 8)
Post Reply